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9. Appendix 

9.1. Dictionary 

9.1.1. Dictionary Schema 

<!-- 
 This is Dictionary schema. 
 Copyright (c) Tatsuya Inaba 2004 
  --> 
<!-- ============================================= 
                  CHANGE HISTORY 
   Version            Date      Time   Author 
   =============  ========  =====  ====== 
   Initial Draft        20040202   15:00   Inaba 
   1.1               20040224   15:00   Inaba 
   1.2               20040318   11:15   Inaba  
=============================================== --> 
<!ENTITY % common-elements "Name, Desc"> 
<!ENTITY % common-attributes " 
  id  ID  #REQUIRED 
  ver CDATA #REQUIRED 
  "> 
<!ELEMENT Dictionary (Identifier, Action*, ValueSet*, Value*)> 
<!ELEMENT Identifier (Type, MajRev, MinRev, Date)> 
<!ELEMENT Type (#PCDATA)> 
<!ELEMENT MajRev (#PCDATA)> 
<!ELEMENT MinRev (#PCDATA)> 
<!ELEMENT Date (#PCDATA)> 
<!ELEMENT Action (%common-elements;, ValueSetId*, ValueId*)> 
<!ATTLIST Action 
 %common-attributes;  
> 
<!ELEMENT Name (#PCDATA)> 
<!ELEMENT Desc (#PCDATA)> 
<!ELEMENT ValueSetId (#PCDATA)> 
<!ELEMENT ValueId (#PCDATA)> 
<!ELEMENT ValueSet (%common-elements;, ValueId*)> 
<!ATTLIST ValueSet 
 %common-attributes;  
> 
<!ELEMENT Value (%common-elements;, Format, UOM)> 
<!ATTLIST Value 
 %common-attributes;  
> 
<!ELEMENT Format (#PCDATA)> 
<!ELEMENT UOM (#PCDATA)> 
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9.1.2. Event Dictionary 

<?xml version="1.0"?> 
<!DOCTYPE Dictionary SYSTEM "Dictionary.dtd"> 
<?xml-stylesheet type="text/xsl" href="dictionary.xsl"?> 
<Dictionary> 
 <Identifier> 
  <Type>Event</Type> 
  <MajRev>1</MajRev> 
  <MinRev>0</MinRev> 
  <Date>2004-03-18</Date> 
 </Identifier> 
 <Action id="EA001" ver="1.0"> 
  <Name>Detect</Name> 
  <Desc>Event used when physical object is scanned.</Desc> 
  <ValueId>EV001</ValueId> 
  <ValueId>EV002</ValueId> 
  <ValueId>EV003</ValueId> 
 </Action> 
 <Action id="EA002" ver="1.0"> 
  <Name>Aggregate</Name> 
  <Desc>Event used when two physical objects are aggregated.</Desc> 
  <ValueId>EV001</ValueId> 
  <ValueId>EV002</ValueId> 
  <ValueId>EV003</ValueId> 
  <ValueId>EV004</ValueId> 
  <ValueId>EV005</ValueId> 
  <ValueId>EV013</ValueId> 
 </Action> 
 <Action id="EA003" ver="1.0"> 
  <Name>Disaggregate</Name> 
  <Desc>Event used when two physical objects are disaggregated.</Desc> 
  <ValueId>EV001</ValueId> 
  <ValueId>EV002</ValueId> 
  <ValueId>EV003</ValueId> 
  <ValueId>EV004</ValueId> 
  <ValueId>EV005</ValueId> 
  <ValueId>EV013</ValueId> 
 </Action> 
 <Action id="EA004" ver="1.0"> 
  <Name>Handling</Name> 
  <Desc>Event used when business entity handles physical object.</Desc> 
  <ValueSetId>EVS001</ValueSetId> 
  <ValueId>EV006</ValueId> 
  <ValueId>EV007</ValueId> 
 </Action> 
 <ValueSet id="EVS001" ver="1.0"> 
  <Name>Physical Address</Name> 
  <Desc>Physical Address of physical object location, business entity etc.</Desc> 
  <ValueId>EV008</ValueId> 
  <ValueId>EV009</ValueId> 
  <ValueId>EV010</ValueId> 
  <ValueId>EV011</ValueId> 
  <ValueId>EV012</ValueId> 
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 </ValueSet> 
 <Value id="EV001" ver="1.0"> 
  <Name>EPC</Name> 
  <Desc>EPC of scanned physical object. Key of historical record.</Desc> 
  <Format>EPC</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV002" ver="1.0"> 
  <Name>DateTime</Name> 
  <Desc>DateTime of the event.</Desc> 
  <Format>DateTime</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV003" ver="1.0"> 
  <Name>ReaderEPC</Name> 
  <Desc>EPC of reader which scans physical object.</Desc> 
  <Format>EPC</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV004" ver="1.0"> 
  <Name>RelatedEPC</Name> 
  <Desc>EPC of related physical object. Used for Aggregation event.</Desc> 
  <Format>EPC</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV005" ver="1.0"> 
  <Name>AggregationRelation</Name> 
  <Desc>Relation of the aggregation. If value is "1", physical object is larger concept physical 
object.</Desc> 
  <Format>Binary</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV006" ver="1.0"> 
  <Name>BusinessEntity</Name> 
  <Desc>Name of business entity which executes the event.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV007" ver="1.0"> 
  <Name>ContactName</Name> 
  <Desc>Contact information</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV008" ver="1.0"> 
  <Name>Street</Name> 
  <Desc>Street of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV009" ver="1.0"> 
  <Name>City</Name> 
  <Desc>City of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
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 </Value> 
 <Value id="EV010" ver="1.0"> 
  <Name>State</Name> 
  <Desc>State of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV011" ver="1.0"> 
  <Name>Zip</Name> 
  <Desc>Zip code of physical address.</Desc> 
  <Format>Number</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV012" ver="1.0"> 
  <Name>Country</Name> 
  <Desc>Country of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="EV013" ver="1.0"> 
  <Name>Dependency</Name> 
  <Desc>Dependency of the two physical objects. If the item is contained in a case, the value is 
"1".</Desc> 
  <Format>binary</Format> 
  <UOM/> 
 </Value> 
</Dictionary> 
 
 

9.1.3. Property Dictionary 

<?xml version="1.0"?> 
<!DOCTYPE Dictionary SYSTEM "Dictionary.dtd"> 
<?xml-stylesheet type="text/xsl" href="dictionary.xsl"?> 
<Dictionary> 
 <Identifier> 
  <Type>Property</Type> 
  <MajRev>1</MajRev> 
  <MinRev>1</MinRev> 
  <Date>2004-03-18</Date> 
 </Identifier> 
 <Action id="PA001" ver="1.0"> 
  <Name>Create</Name> 
  <Desc>Action used to create data</Desc> 
  <ValueSetId/> 
  <ValueId/> 
 </Action> 
 <Action id="PA002" ver="1.0"> 
  <Name>Delete</Name> 
  <Desc>Action used to delete data</Desc> 
  <ValueSetId/> 
  <ValueId/> 
 </Action> 
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 <Action id="PA003" ver="1.0"> 
  <Name>Update</Name> 
  <Desc>Action used to update data</Desc> 
  <ValueId/> 
 </Action> 
 <Action id="PA004" ver="1.0"> 
  <Name>Notify</Name> 
  <Desc>Action used to notify business document such as ASN</Desc> 
  <ValueSetId>PVS002</ValueSetId> 
  <ValueId/> 
 </Action> 
 <ValueSet id="PVS001" ver="1.0"> 
  <Name>Manufacturer</Name> 
  <Desc>Data related to manufacturer</Desc> 
  <ValueId>PV007</ValueId> 
  <ValueId>PV008</ValueId> 
  <ValueId>PV009</ValueId> 
  <ValueId>PV010</ValueId> 
  <ValueId>PV011</ValueId> 
  <ValueId>PV012</ValueId> 
  <ValueId>PV013</ValueId> 
 </ValueSet> 
 <ValueSet id="PVS002" ver="1.0"> 
  <Name>ASN</Name> 
  <Desc>Data related to ASN</Desc> 
  <ValueId>PV014</ValueId> 
 </ValueSet> 
 <Value id="PV001" ver="1.0"> 
  <Name>EPC</Name> 
  <Desc>EPC of property data</Desc> 
  <Format>EPC</Format> 
  <UOM/> 
 </Value> 
 <Value id="PV002" ver="1.0"> 
  <Name>DateTime</Name> 
  <Desc>DateTime of the event.</Desc> 
  <Format>YYYYMMDDThhmm+hhmm</Format> 
  <UOM>DateTime</UOM> 
 </Value> 
 <Value id="PV003" ver="1.0"> 
  <Name>Height</Name> 
  <Desc>Height of physical object</Desc> 
  <Format/> 
  <UOM>meter</UOM> 
 </Value> 
 <Value id="PV004" ver="1.0"> 
  <Name>Depth</Name> 
  <Desc>Depth of physical object</Desc> 
  <Format/> 
  <UOM>meter</UOM> 
 </Value> 
 <Value id="PV005" ver="1.0"> 
  <Name>Width</Name> 
  <Desc>Width of physical object</Desc> 
  <Format/> 
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  <UOM>meter</UOM> 
 </Value> 
 <Value id="PV006" ver="1.0"> 
  <Name>Weight</Name> 
  <Desc>Weight of physical object</Desc> 
  <Format/> 
  <UOM>kg</UOM> 
 </Value> 
 <Value id="PV007" ver="1.0"> 
  <Name>BusinessEntity</Name> 
  <Desc>Name of business entity which executes the event.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="PV008" ver="1.0"> 
  <Name>ContactName</Name> 
  <Desc>Contact information</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="PV009" ver="1.0"> 
  <Name>Street</Name> 
  <Desc>Street of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="PV010" ver="1.0"> 
  <Name>City</Name> 
  <Desc>City of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="PV011" ver="1.0"> 
  <Name>State</Name> 
  <Desc>State of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="PV012" ver="1.0"> 
  <Name>Zip</Name> 
  <Desc>Zip code of physical address.</Desc> 
  <Format/> 
  <UOM>Number</UOM> 
 </Value> 
 <Value id="PV013" ver="1.0"> 
  <Name>Country</Name> 
  <Desc>Country of physical address.</Desc> 
  <Format>Text</Format> 
  <UOM/> 
 </Value> 
 <Value id="PV014" ver="1.0"> 
  <Name>DocumentId</Name> 
  <Desc>Document identifier of transaction(e.g. PO, ASN)</Desc> 
  <Format>Text</Format> 
  <UOM/> 
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 </Value> 
 <Value id="PV015" ver="1.0"> 
  <Name>ExpirationDate</Name> 
  <Desc>Expiration date of the item</Desc> 
  <Format>DateTime</Format> 
  <UOM/> 
 </Value> 
</Dictionary> 
 
 

9.2. Message 

9.2.1. Schema 

9.2.1.1. Notify message 
<!-- 
 This is Notify schema. 
 Copyright (c) Tatsuya Inaba 2004 
  --> 
<!-- ============================================= 
                  CHANGE HISTORY 
 
   Version        Date      Time   Author 
   =============  ========  =====  ====== 
   Initial Draft  20040212  15:00  Inaba 
   1.1    20040225  14:00  Inaba 
   1.2    20040311  16:00  Inaba 
   1.3    20040318  12:00  Inaba 
    
=============================================== --> 
<!ENTITY % common-elements "DateTime, Identifier, DocumentType"> 
<!ENTITY % common-attributes " 
  dicRef  CDATA  #REQUIRED 
  "> 
<!ELEMENT Notify (%common-elements;, PhysicalObject*)> 
<!ATTLIST Notify 
 dicIdentifier CDATA #IMPLIED 
> 
<!ELEMENT PhysicalObject (Action*)> 
<!ATTLIST PhysicalObject 
 EPC CDATA #REQUIRED 
> 
<!ELEMENT Action (ElementSet*, Element*, Inferred?)> 
<!ATTLIST Action 
 %common-attributes;  
> 
<!ELEMENT ElementSet (ElementSet?, Element*)> 
<!ATTLIST ElementSet 
 %common-attributes;  
> 
<!ELEMENT Element (Name?, Value?)> 
<!ATTLIST Element 
 %common-attributes;  
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 id ID #IMPLIED 
 idref IDREF #IMPLIED 
> 
<!ELEMENT Name (#PCDATA)> 
<!ELEMENT Value (#PCDATA)> 
<!ELEMENT Inferred (#PCDATA)> 
<!ELEMENT DateTime (#PCDATA)> 
<!ELEMENT Identifier (#PCDATA)> 
<!ELEMENT DocumentType (#PCDATA)> 
 
 

9.2.1.2. Query message 
<!-- 
 This is Query schema. 
 Copyright (c) Tatsuya Inaba 2004 
  --> 
<!-- ============================================= 
                  CHANGE HISTORY 
 
   Version        Date      Time   Author 
   =============  ========  =====  ====== 
   Initial Draft  20040311  16:00  Inaba 
   1.1                 20040318  14:00  Inaba 
=============================================== --> 
<!ENTITY % common-elements "DateTime, Identifier, DocumentType"> 
<!ENTITY % common-attributes " 
  dicQuery  CDATA  #REQUIRED 
  name CDATA #REQUIRED 
  "> 
<!ELEMENT Query (%common-elements;, Action+)> 
<!ATTLIST Query 
 dicIdentifier CDATA #IMPLIED 
> 
<!ELEMENT Action (ElementSet?, Element*, Inferred?)> 
<!ATTLIST Action 
 %common-attributes;  
> 
<!ELEMENT ElementSet (ElementSet?, Element*)> 
<!ATTLIST ElementSet 
 %common-attributes;  
> 
<!ELEMENT Element (Value)> 
<!ATTLIST Element 
 %common-attributes;  
 id ID #IMPLIED 
 idref IDREF #IMPLIED 
> 
<!ELEMENT Value (#PCDATA)> 
<!ELEMENT Inferred (#PCDATA)> 
<!ELEMENT DateTime (#PCDATA)> 
<!ELEMENT Identifier (#PCDATA)> 
<!ELEMENT DocumentType (#PCDATA)> 
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9.2.1.3. Response message 
<!-- 
 This is Response schema. 
 Copyright (c) Tatsuya Inaba 2004 
  --> 
<!-- ============================================= 
                  CHANGE HISTORY 
 
   Version        Date      Time   Author 
   =============  ========  =====  ====== 
   Initial Draft  20040311  16:00  Inaba 
   1.1                 20040318  14:00 Inaba 
=============================================== --> 
<!ENTITY % common-elements "DateTime, Identifier, DocumentType"> 
<!ENTITY % common-attributes " 
  dicQuery  CDATA  #REQUIRED 
  name CDATA #REQUIRED 
  "> 
<!ELEMENT Response (%common-elements;, OriginalIdentifier, PhysicalObject*, Result?)> 
<!ATTLIST Response 
 dicIdentifier CDATA #IMPLIED 
> 
<!ELEMENT PhysicalObject (Action+, Result?)> 
<!ATTLIST PhysicalObject 
 EPC CDATA #IMPLIED 
> 
<!ELEMENT Action (ElementSet?, Element*, Inferred?, Result?)> 
<!ATTLIST Action 
 %common-attributes;  
> 
<!ELEMENT ElementSet (ElementSet?, Element*)> 
<!ATTLIST ElementSet 
 %common-attributes;  
> 
<!ELEMENT Element (Value)> 
<!ATTLIST Element 
 %common-attributes;  
 id ID #IMPLIED 
 idref IDREF #IMPLIED 
> 
<!ELEMENT Value (#PCDATA)> 
<!ELEMENT Inferred (#PCDATA)> 
<!ELEMENT Result (Reason?)> 
<!ATTLIST Result 
 category (success | fail | partly_success)  #REQUIRED 
> 
<!ELEMENT Reason (#PCDATA)> 
<!ELEMENT DateTime (#PCDATA)> 
<!ELEMENT OriginalIdentifier (#PCDATA)> 
<!ELEMENT Identifier (#PCDATA)> 
<!ELEMENT DocumentType (#PCDATA)> 
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9.2.1.4. Acknowledge message 
<!-- 
 This is Acknowledge schema. 
 Copyright (c) Tatsuya Inaba 2004 
  --> 
<!-- ============================================= 
                  CHANGE HISTORY 
 
   Version        Date      Time   Author 
   =============  ========  =====  ====== 
   Initial Draft  20040318  15:00  Inaba 
 
=============================================== --> 
<!ENTITY % common-elements "DateTime, Identifier, DocumentType"> 
<!ENTITY % common-attributes " 
  dicQuery  CDATA  #REQUIRED 
  name CDATA #REQUIRED 
  "> 
<!ELEMENT Acknowledge (%common-elements;, OriginalIdentifier, PhysicalObject*, Result?)> 
<!ATTLIST Response 
 dicIdentifier CDATA #IMPLIED 
> 
<!ELEMENT PhysicalObject (Action+, Result?)> 
<!ATTLIST PhysicalObject 
 EPC CDATA #IMPLIED 
> 
<!ELEMENT Action (Result?)> 
<!ATTLIST Action 
 %common-attributes;  
> 
<!ELEMENT Result (Reason?)> 
<!ATTLIST Result 
 category (success | fail | partly_success) #REQUIRED 
> 
<!ELEMENT Reason (#PCDATA)> 
<!ELEMENT DateTime (#PCDATA)> 
<!ELEMENT OriginalIdentifier (#PCDATA)> 
<!ELEMENT Identifier (#PCDATA)> 
<!ELEMENT DocumentType (#PCDATA)> 
 

9.2.2. Sample Instances 

9.2.2.1. Notify the scanned item 
When items are scanned by the Savant, the data is sent to the server which stores the physical 
object data. This sample instance is used in this situation. A reader (urn:epc:1.10.101.1001) 
scans four items at 15:13:43-5:00 2004 February 25. In response to the Notify message, the 
Acknowledge message is sent back to the Savant. 

 

Notify message 
<?xml version="1.0" encoding="UTF-8"?> 
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<!DOCTYPE Notify SYSTEM "Notify.dtd"> 
<Notify dicIdentifier="EventDictionary ver1.0"> 
 <DateTime>20040225T15:13:43 -0500</DateTime> 
 <Identifier>200402250001</Identifier> 
 <DocumentType>notify</DocumentType> 
 <PhysicalObject EPC="urn:epc:1.10.100.1"> 
  <Action dicRef="EA001" name="Detect"> 
   <Element dicRef="EV001" name="EPC"> 
    <Value>urn:epc:1.10.100.1</Value> 
   </Element> 
   <Element dicRef="EV002" id="D200402250001" name="DateTime"> 
    <Value>20040225T15:00:00-05:00</Value> 
   </Element> 
   <Element dicRef="EV003" id="E1001" name="ReaderEPC"> 
    <Value>urn:epc:1.10.101.1001</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.2"> 
  <Action dicRef="EA001" name="Detect"> 
   <Element dicRef="EV001" name="EPC"> 
    <Value>urn:epc:1.10.100.2</Value> 
   </Element> 
   <Element dicRef="EV002" idref="D200402250001" name="DateTime"/> 
   <Element dicRef="EV003" idref="E1001" name="ReaderEPC"/> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.3"> 
  <Action dicRef="PA001" name="Detect"> 
   <Element dicRef="EV001" name="EPC"> 
    <Value>urn:epc:1.10.100.3</Value> 
   </Element> 
   <Element dicRef="EV002" idref="D200402250001" name="DateTime"/> 
   <Element dicRef="EV003" idref="E1001" name="ReaderEPC"/> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.4"> 
  <Action dicRef="PA001" name="Detect"> 
   <Element dicRef="EV001" name="EPC"> 
    <Value>urn:epc:1.10.100.4</Value> 
   </Element> 
   <Element dicRef="EV002" idref="D200402250001" name="DateTime"/> 
   <Element dicRef="EV003" idref="E1001" name="ReaderEPC"/> 
  </Action> 
 </PhysicalObject> 
</Notify> 
 
Acknowledge message 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Acknowledge SYSTEM "Acknowledge.dtd"> 
<Acknowledge> 
 <DateTime>20040225T15:13:43 -0500</DateTime> 
 <Identifier>200402250002</Identifier> 
 <DocumentType>acknowledge</DocumentType> 
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 <OriginalIdentifier>200402250001</OriginalIdentifier> 
 <Result category="success"/> 
</Acknowledge> 

�

9.2.2.2. Notify the expiration date 
When the property data is inputted at the Savant, the data is sent to the server which stores the 
physical object data. This sample instance is used in this situation. The expiration date data is 
sent to the server. In response to the Notify message, the Acknowledge message is sent back 
to the Savant. In this case, the result of an item(urn:epc:1.10.100.4) becomes error because the 
EPC has not registered in the server. 

 

Notify message 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Notify SYSTEM "Notify.dtd"> 
<Notify dicIdentifier="PropertyDictionary ver1.0"> 
 <DateTime>20040318T14:13:43 -0500</DateTime> 
 <Identifier>200403180009</Identifier> 
 <DocumentType>notify</DocumentType> 
 <PhysicalObject EPC="urn:epc:1.10.100.1"> 
  <Action dicRef="PA003" name="Update"> 
   <Element dicRef="PV015" name="ExpirationDate"> 
    <Value>20040425T12:00:00-5:00</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.2"> 
  <Action dicRef="PA003" name="Update"> 
   <Element dicRef="PV015" name="ExpirationDate"> 
    <Value>20040425T12:00:00-5:00</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.3"> 
  <Action dicRef="PA003" name="Update"> 
   <Element dicRef="PV015" name="ExpirationDate"> 
    <Value>20040425T12:00:00-5:00</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.4"> 
  <Action dicRef="PA003" name="Update"> 
   <Element dicRef="PV015" name="ExpiratioDate"> 
    <Value>20040425T12:00:00-5:00</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
</Notify> 
 
 

Acknowledge message 
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<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Acknowledge SYSTEM "Acknowledge.dtd"> 
<Acknowledge dicIdentifier="PropertyDictionary ver1.0"> 
 <DateTime>20040318T15:13:43 -0500</DateTime> 
 <Identifier>200403180010</Identifier> 
 <DocumentType>acknowledge</DocumentType> 
 <OriginalIdentifier>200403180009</OriginalIdentifier> 
 <Result category="partly_success"> 
  <Reason>EPC not find</Reason> 
 </Result> 
 <PhysicalObject EPC="urn:epc:1.10.100.4"> 
  <Action dicRef="PA001" name="Register"> 
   <Result category="fail"> 
    <Reason>EPC not find</Reason> 
   </Result> 
  </Action> 
 </PhysicalObject> 
</Acknowledge> 
 

9.2.2.3. Notify the advance ship notice 
When items/cases/pallets are sent from a company to its trading partner, the company sends 
advance ship notice to its trading partner. This sample instance is used in this situation. First, 
the enterprise application of the sending company sends the Notify message to its server with 
EPC-IS, and the server sends the Notify message to the server with EPC-IS which is located 
at the trading partner’s facility. In this case, the sending company packs two items in cases 
(urn:epc:1.10.100.10, urn:epc:1.10.100.11). The shipment document identifier also uses EPC 
(urn:epc:1.10.102.1) in this case. 

 

Notify message from the enterprise application to the server with EPC-IS 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Notify SYSTEM "Notify.dtd"> 
<Notify dicIdentifier="EventDictionary ver1.0"> 
 <DateTime>20040324T15:13:43 -0500</DateTime> 
 <Identifier>200403240001</Identifier> 
 <DocumentType>notify</DocumentType> 
 <PhysicalObject EPC="urn:epc:1.10.102.1"> 
  <Action dicRef="PA004" name="Notify"> 
   <ElementSet dicRef="PV002" name="ASN"> 
    <Element dicRef="PV014" name="DocumentId"> 
     <Value>urn:epc:1.10.102.1</Value> 
    </Element> 
   </ElementSet> 
  </Action> 
 </PhysicalObject> 
</Notify> 
 
Notify message from the server of the sending company to the sever of the receiving 
company 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Notify SYSTEM "Notify.dtd"> 
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<Notify dicIdentifier="EventDictionary ver1.0"> 
 <DateTime>20040324T16:13:43 -0500</DateTime> 
 <Identifier>urn.epc:1.10.102.1</Identifier> 
 <DocumentType>notify</DocumentType> 
 <PhysicalObject EPC="urn:epc:1.10.102.1"> 
  <Action dicRef="PA004" name="Notify"> 
   <ElementSet dicRef="PV002" name="ASN"> 
    <Element dicRef="PV014" name="DocumentId"> 
     <Value>urn:epc:1.10.102.1</Value> 
    </Element> 
   </ElementSet> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.10"> 
  <Action dicRef="EA001" name="Detect"> 
   <Element dicRef="EV001" name="EPC"> 
    <Value>urn:epc:1.10.100.10</Value> 
   </Element> 
   <Element dicRef="EV002" id="D200403241000001" name="DateTime"> 
    <Value>20040324T10:00:00-5:00</Value> 
   </Element> 
   <Element dicRef="EV003" id="D200403241000002" name="ReaderEPC"> 
    <Value>urn:epc:1.10.101.1001</Value> 
   </Element> 
  </Action> 
  <Action dicRef="EA003" name="Aggregate"> 
   <Element dicRef="EV004" name="RelatedEPC"> 
    <Value>urn:epc:1.10.100.1</Value> 
   </Element> 
  </Action> 
  <Action dicRef="EA003" name="Aggregate"> 
   <Element dicRef="EV004" name="RelatedEPC"> 
    <Value>urn:epc:1.10.100.2</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
 <PhysicalObject EPC="urn:epc:1.10.100.11"> 
  <Action dicRef="PA001" name="Detect"> 
   <Element dicRef="EV001" name="EPC"> 
    <Value>urn:epc:1.10.100.11</Value> 
   </Element> 
   <Element dicRef="EV002" idref="D200403241000001" name="DateTime"/> 
   <Element dicRef="EV003" idref="D200403241000002" name="ReaderEPC"/> 
  </Action> 
  <Action dicRef="EA002" name="Aggregate"> 
   <Element dicRef="EV004" name="RelatedEPC"> 
    <Value>urn:epc:1.10.100.3</Value> 
   </Element> 
  </Action> 
  <Action dicRef="EA002" name="Aggregate"> 
   <Element dicRef="EA004" name="RelatedEPC"> 
    <Value>urn:epc:1.10.100.4</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
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</Notify> 
 
 

9.2.2.4. Query the product size 
When a buyer wants to know the size of an item, the company sends a query to the supplier. 
This sample instance is used in this situation. Precondition of this sample is that the buyer gets 
the EPC of the product of which the company wants the size. First, the buyer sends a query 
with the EPC of the item, and then the supplier sends back the size of the item to the buyer.  
 
Query message 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Query SYSTEM "Query.dtd"> 
<Query dicIdentifier="PropertyDictionary ver1.0"> 
 <DateTime>20040311T14:13:43 -0500</DateTime> 
 <Identifier>200402250006</Identifier> 
 <DocumentType>query</DocumentType> 
 <Action dicQuery="PA001" name="Create"> 
  <ElementSet dicQuery="PVS001" name="Manufacturer"> 
   <Element dicQuery="PV007" name="BusinessEntity"> 
    <Value/> 
   </Element> 
  </ElementSet> 
  <Element dicQuery="PV003" name="Height"> 
   <Value/> 
  </Element> 
  <Element dicQuery="PV004" name="Depth"> 
   <Value/> 
  </Element> 
  <Element dicQuery="PV005" name="Width"> 
   <Value/> 
  </Element> 
  <Element dicQuery="PV006" name="Weight"> 
   <Value/> 
  </Element> 
  <Element dicQuery="PV001" name="EPC"> 
   <Value>urn:epc:1.10.100.1</Value> 
  </Element> 
 </Action> 
</Query> 
 

Response message 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Response SYSTEM "Response.dtd"> 
<Response dicIdentifier="PropertyDictionary ver1.0"> 
 <DateTime>20040311T14:13:43 -0500</DateTime> 
 <Identifier>200402250007</Identifier> 
 <DocumentType>response</DocumentType> 
 <OriginalIdentifier>200402250006</OriginalIdentifier> 
 <PhysicalObject EPC="urn:epc:1.10.100.1"> 
  <Action dicQuery="PA001" name="Create"> 
   <ElementSet dicQuery="PVS001" name="Manufacturer"> 
    <Element dicQuery="PV007" name="BusinessEntity"> 
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     <Value>MIT</Value> 
    </Element> 
   </ElementSet> 
   <Element dicQuery="PV003" name="Height"> 
    <Value>0.3</Value> 
   </Element> 
   <Element dicQuery="PV004" name="Depth"> 
    <Value>0.1</Value> 
   </Element> 
   <Element dicQuery="PV005" name="Width"> 
    <Value>0.2</Value> 
   </Element> 
   <Element dicQuery="PV006" name="Weight"> 
    <Value>1.0</Value> 
   </Element> 
   <Element dicQuery="PV001" name="EPC"> 
    <Value>urn:epc:1.10.100.1</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
</Response> 
 
 

9.2.2.5. Query the Expiration Date 
When a buyer wants to know the expiration date of an item, the company sends a query to the 
supplier. This sample instance is used in this situation. Precondition of this sample is that the 
buyer gets the EPC of the product of which the company wants the expiration date. First, the 
buyer sends a query with the EPC of the item, and then the supplier sends back the expiration 
date of the item to the buyer.  
 
Query message 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Query SYSTEM "Query.dtd"> 
<Query dicIdentifier="PropertyDictionary ver1.0"> 
 <DateTime>20040311T14:13:43 -0500</DateTime> 
 <Identifier>200402250006</Identifier> 
 <DocumentType>query</DocumentType> 
 <Action dicQuery="PA001" name="Create"> 
  <Element dicQuery="PV001" name="EPC"> 
   <Value>urn:epc:1.10.100.2</Value> 
  </Element> 
  <Element dicQuery="PV015" name="ExpirationDate"> 
   <Value/> 
  </Element> 
 </Action> 
</Query> 
 

Response message 
<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE Response SYSTEM "Response.dtd"> 
<Response dicIdentifier="PropertyDictionary ver1.0"> 
 <DateTime>20040311T15:13:43 -0500</DateTime> 
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 <Identifier>200402250007</Identifier> 
 <DocumentType>response</DocumentType> 
 <OriginalIdentifier>200402250006</OriginalIdentifier> 
 <PhysicalObject EPC="urn:epc:1.10.100.2"> 
  <Action dicQuery="PA001" name="Create"> 
   <Element dicQuery="PV001" name="EPC"> 
    <Value>urn:epc:1.10.100.2</Value> 
   </Element> 
   <Element dicQuery="PV015" name="ExpirationDate"> 
    <Value>20040425T12:00:00-5:00</Value> 
   </Element> 
  </Action> 
 </PhysicalObject> 
</Response> 
 

 


