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OASIS Specification Document Template 
Usage 
Working Draft, October 18, 2004  
Document Identifier: 

oasis-spectools-1.0-word-sample-draft-01.doc 
OASIS Identifier: 

[OASIS document number]  
Location: 

Persistent: [persistent location]  
This Version: [location of this version]  
Previous Version: [location of previous version]  

Technical Committee: 
OASIS [official name of technical committee]  TC 

Chair(s): 
[Chair name]  
[Chair name]  

Editor(s): 
Karl Best, OASIS 
Eve Maler, Sun Microsystems 
Mary McRae, OASIS 

Subject/Keywords: 
[Comma-separated keyword listing]  

OASIS Conceptual Model topic area: 
[Topic Area]  

Related work: 
This specification replaces or supercedes: 

• [specifications replaced by this standard]  
• [specifications replaced by this standard]  

This specification is related to: 
• [related specifications]  
• [related specifications]  

Abstract: 
This document was created using the Microsoft Word template (wd-spectools-word-template-1.0-
draft-01.dot) and is intended to serve as documentation of its usage.  

Status: 
This document was last revised or approved by the [TC name | membership of OASIS] on the 
above date. The level of approval is also listed above. Check the current location noted above for 
possible later revisions of this document. This document is updated periodically on no particular 
schedule. 
Technical Committee members should send comments on this specification to the Technical 
Committee’s email list. Others should send comments to the Technical Committee by using the 
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“Send A Comment” button on the Technical Committee’s web page at www.oasis-
open.org/committees/[TC short name] . 
For information on whether any patents have been disclosed that may be essential to 
implementing this specification, and any offers of patent licensing terms, please refer to the 
Intellectual Property Rights section of the Technical Committee web page (www.oasis-
open.org/committees/[TC short name] /ipr.php. 
The non-normative errata page for this specification is located at www.oasis-
open.org/committees/[TC short name] . 
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Notices 
OASIS takes no position regarding the validity or scope of any intellectual property or other rights that 
might be claimed to pertain to the implementation or use of the technology described in this document or 
the extent to which any license under such rights might or might not be available; neither does it 
represent that it has made any effort to identify any such rights. Information on OASIS's procedures with 
respect to rights in OASIS specifications can be found at the OASIS website. Copies of claims of rights 
made available for publication and any assurances of licenses to be made available, or the result of an 
attempt made to obtain a general license or permission for the use of such proprietary rights by 
implementors or users of this specification, can be obtained from the OASIS President. 
OASIS invites any interested party to bring to its attention any copyrights, patents or patent applications, 
or other proprietary rights which may cover technology that may be required to implement this 
specification. Please address the information to the OASIS President. 
Copyright  © OASIS Open 2004. All Rights Reserved. 
This document and translations of it may be copied and furnished to others, and derivative works that 
comment on or otherwise explain it or assist in its implementation may be prepared, copied, published 
and distributed, in whole or in part, without restriction of any kind, provided that the above copyright notice 
and this paragraph are included on all such copies and derivative works. However, this document itself 
does not be modified in any way, such as by removing the copyright notice or references to OASIS, 
except as needed for the purpose of developing OASIS specifications, in which case the procedures for 
copyrights defined in the OASIS Intellectual Property Rights document must be followed, or as required to 
translate it into languages other than English. 
The limited permissions granted above are perpetual and will not be revoked by OASIS or its successors 
or assigns. 
This document and the information contained herein is provided on an “AS IS” basis and OASIS 
DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY 
WARRANTY THAT THE USE OF THE INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR 
ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
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1 Introduction 1 

The Microsoft Word Specification template consists of page layouts, styles, boilerplate text and hints to 2 
assist specification editors in preparing documents conforming to the OASIS standard style. Similar 3 
templates are provided for use with Open Office as well as DocBook.  4 

1.1 Terminology 5 

The key words “MUST”, “MUST NOT”, “REQUIRED”, “SHALL”, “SHALL NOT”, “SHOULD”, “SHOULD 6 
NOT”, “RECOMMENDED”, “MAY”, and “OPTIONAL” in this document are to be interpreted as described 7 
in [RFC2119]. 8 

1.2 Normative References 9 

[RFC2119] S. Bradner, Key words for use in RFCs to Indicate Requirement Levels, 10 
http://www.ietf.org/rfc/rfc2119.txt, IETF RFC 2119, March 1997. 11 

[Reference]  [Full reference citation]   12 

1.3 Non-Normative References 13 

[Reference]  [Full reference citation]  14 
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2 Installing and Using the Word Template 15 

In order to take advantage of the functionality built into the Microsoft Word template it must be installed in 16 
a location accessible to the application. It is then available each time the user chooses to create a new 17 
document.  18 

2.1 Template Installation 19 

By default, user templates are stored at C:\Documents and Settings\username\Application 20 
Data\Microsoft\Templates. Copy the template file (indicated by the .dot extension) to this directory. 21 

2.2 Creating a New Document Based on the OASIS Template 22 

To create a new document based on the OASIS Specification template, do one of the following: 23 

2.2.1 From Microsoft Word 24 

Select File -> New (from template) from the menu bar. The Templates pop-up form will appear. Select the 25 
OASIS Specification template and click “OK”.  26 

2.2.2 From Windows Explorer 27 

Navigate to the template directory and double-click on the OASIS Specification template. Microsoft Word 28 
will be launched and a new document will be created based on the selected template. 29 

2.3 Using the OASIS Template 30 

There are three major components to the OASIS Specification template: placeholder text or hints, 31 
boilerplate text, and document styles.  32 

2.3.1 Placeholder Text 33 

Much of the front matter makes use of placeholder text. These hints are shown in square brackets, and 34 
when the cursor is placed within those brackets, the entire contents will be highlighted. Typing will cause 35 
the placeholder text to be removed and the new information to be inserted in its place. Note that once the 36 
placeholder text has been deleted it will not reappear. It can be reinstated by using the undo function, 37 
reversing any actions taken following the deletion of the placeholder text. 38 

2.3.2 Boilerplate Text 39 

Boilerplate text is automatically incorporated into the template and should not be modified, except as 40 
noted.  41 

2.3.3 Document Styles 42 

There are two major categories of styles: paragraph and character. As the names imply, paragraph styles 43 
are applied to blocks of text, and character styles are applied to individual characters or words within 44 
paragraph blocks. It is important that the document styles be used rather than direct formatting to ensure 45 
that the OASIS specification style is followed and to facilitate transformation to other document formats, 46 
such as PDF and HTML. 47 
To apply a paragraph style, place the cursor anywhere within the paragraph and either: 48 
• Select Format -> Styles from the Menu Bar and select the desired style name; 49 
• Select the desired style name from the style drop-down menu in the formatting tool bar; or 50 
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• Display the Styles and Formatting Task Pane (Office XP or 2003 only) and select the desired style 51 
name. 52 

 53 
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3 Title Page(s) 54 

The Title Page contains a significant amount of metadata that must be supplied by the document 55 
editor(s). Much of this information will be used to populate the OASIS Registry. The title page also 56 
contains an abstract as well as the status of the document itself. 57 

3.1 Specification Title 58 

Insert the title of the document, followed by the version number (ex., v1.0) 59 

3.2 Stage and Publication Date 60 

The document stage refers to one of the following document states: Committee Draft, Committee 61 
Specification, or OASIS Standard.  62 

3.3 Document Metadata 63 

3.3.1 Document Identifier: 64 

The Document Identifier MUST follow the guidelines as set forth in the OASIS Artifact Naming Guidelines. 65 
In general, this is owner-product-version-part-artifacttype-stage-revision-language.form (http://docs.oasis-66 
open.org/tab/OASIS-artifact_naming_guidelines-1.0-spec.pdf). This information will automatically be 67 
entered into the document footer. 68 

3.3.2 OASIS Identifier 69 

The OASIS identifier is assigned to an OASIS Standard by the OASIS TC Administrator upon approval by 70 
the OASIS membership. Documents that have not yet achieved OASIS Standard status will not have an 71 
OASIS Identifier associated with them. 72 

3.3.3 Location 73 

In order to create persistent URLs for publicly-available documents, each committee will be assigned a 74 
specific URL in the form of http://docs.oasis-open.org/docs/[tc_short_name]/[spec]/[this_version]. This 75 
tree will contain all relevant forms of the document as well as any related materials. Any document that 76 
has been voted upon by the technical committee and approved by its members will be posted to this URL.  77 

3.3.3.1 Persistent 78 

The persistent location will be identified as http://docs.oasis-open.org/docs/[tc_short_name]/[spec]. This 79 
will ensure access to the latest version of the specification. 80 

3.3.3.2 This Version 81 

This version refers to the URL for this particular document instance, creating a publicly-available historical 82 
record of the specification. (http://docs.oasis-open.org/docs/[tc_short_name]/[spec]/[this_version]) 83 

3.3.3.3 Previous Version 84 

The previous version is meant to refer to the most recent previous version. (http://docs.oasis-85 
open.org/docs/[tc_short_name]/[spec]/[previous_version]) 86 

3.3.4 Technical Committee: 87 

The full name of the technical committee that produced the document. 88 
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3.3.5 Chair(s): 89 

The name or names of the committee chair or chairs.  90 

3.3.6 Editor(s): 91 

The name or names of the specification editor or editors. 92 

3.3.7 Subject/Keywords: 93 

There is no exhaustive list of possible subjects and/or keywords; instead, the editors should use their 94 
discretion in assigning relevant terms that may be used to locate documents in the OASIS Registry. 95 

3.3.8 OASIS Conceptual Model Topic Area: 96 

The OASIS Technical Advisory Board (TAB) has identified a conceptual model relating to the work of 97 
OASIS technical committees. Please refer to [DOCUMENT NAME and LOCATION needed] to determine 98 
the appropriate category for this work. 99 

3.3.9 Related Work: 100 

List any and all standards, whether created by an OASIS technical committee or other standards 101 
organization, that are replaced or superceded by this document. Also list any related work, whether 102 
created by an OASIS technical committee or other standards organization. 103 

3.3.10 Abstract: 104 

The abstract should include a brief problem statement, the scope of the solution, the intended audience, 105 
and a short overview of the specification. It should not be longer than a single paragraph. 106 

3.3.11 Status: 107 

The Status section consists of boilerplate text that should not be changed, other than the reference in the 108 
first line to either the TC name or OASIS membership and the specific references to the TC website. The 109 
last paragraph pertaining to errata may be omitted if there is no such document; it is recommended that 110 
when a substantive change is required to be made to a specification that the document itself be updated 111 
rather than creating a normative errata document. 112 

3.4 Footers 113 

Headers and Footers can be accessed by either of the following methods: 114 
• Double-click on the grayed header or footer text; or 115 
• Select View -> Header and Footer from the Menu Bar. 116 
The contents of the footer should automatically be updated with the document approval date and 117 
document identifier are modified. 118 
 119 
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4 Notices 120 

The entire Notices section is boilerplate text and MUST NOT be modified.  121 
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5 Table of Contents 122 

The Table of Contents section is auto-generated. To update the Table of Contents to accurately reflect 123 
the modified document, do one of the following. 124 

5.1 Using the Index and Tables Dialog 125 

• From the Menu Bar, select Insert -> Reference -> Index and Tables. 126 
• Select the Table of Contents tab. 127 
• Press “OK”. 128 
• You will then be asked if you wish to replace the Table of Contents – select “OK” to replace or 129 

“Cancel” to abort the update. 130 

5.2 Using the Right-Button Pop-Up Menu 131 

• Place the cursor anywhere within the Table of Contents. 132 
• Right-click to display the pop-up menu. 133 
• Select Update Field 134 
• Choose to either update page references only or to update the entire table (will update all entries 135 

including titles and added or removed sections. 136 
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6 Introduction 137 

Provide an introductory chapter. Starting with this chapter all text is normative unless labeled otherwise. 138 
Non-normative text SHOULD be placed in Appendix C. 139 

6.1 Terminology 140 

This section is boilerplate and MUST NOT be omitted unless the entire document is non-normative. 141 

6.2 Normative References 142 

Normative references include a reference to RFC2119 (terminology) and any other standards that must 143 
also be adhered to in order for an implementation to be considered compliant. 144 

6.3 Non-Normative References 145 

Non-normative references are informational only; they may provide background or supplemental 146 
information. 147 
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7 Word Styles 148 

Word styles are collections of raw formatting codes that facilitate consistent application of formatting 149 
characteristics throughout a document instance. Use of direct formatting should be avoided whenever 150 
possible. 151 

7.1 Overall Style 152 

The paper size is set to Letter, which is 8 ½ x 11. You may change this to A4 or whatever other size suits 153 
your needs. Page margins are set to 1” left, 1” right, 1” top, and ½” bottom. The default font is 10 pt Arial 154 
and is controlled by the Normal style. Major sections begin a new page. 155 
Line numbers are enabled by default for easy reference by those providing comments. Line numbers 156 
begin at the Introduction section; front matter material should not be numbered.  157 

7.2 Title Page 158 

The Title Page contains a significant amount of information about the Specification Document. This 159 
metadata serves to quickly identify key information about a specification and will be used to populate the 160 
OASIS Registry. Most of the information to be entered on the Title Page is done through the use of 161 
placeholder text.  162 
Styles used on the Title Page include the following (in order of appearance): 163 
• Title 164 
• Subtitle 165 
• Title page info 166 
• Title page info description 167 
• Contributor 168 
• Related work 169 
• Abstract 170 

7.3 Headings 171 

There are three sets of Heading styles: undesignated, Arabic designation, and alphabetic designation. 172 
Title and Subtitle are used on the cover and carry no designation. Notices is similar to the Title style, but 173 
also causes a new page to be started. Heading1 through Heading 9 are used throughout the body of the 174 
document and follow a legal style of numbering. AppendixHeading1 through AppendixHeading3 are 175 
similar to Heading 1 through Heading 3, but use Alphabetic designations.  176 
First-level headings (Title, Notices, Heading1, and AppendixHeading1) begin a new page and include a 177 
horizontal gray rule. 178 

7.4 Paragraphs 179 

The basic paragraph style for the body of the document is Normal. Pressing the enter key following the 180 
last character in any of the Heading styles will not only insert a new line but will also cause the style to be 181 
changed to Normal. The Normal style is set to 10 pt Arial, with 4pt of extra lead between paragraphs. 182 

7.5 Lists 183 

There are several styles associated with lists: Definition, Ref, List Bullet, and List Continue.  184 
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7.5.1 Definition Lists 185 

The Definition term and Definition paragraph styles produce a definition list with a hanging indent. 186 
Pressing Return after one inserts the other directly after. 187 
Definition term 188 

Definition for the term. 189 

7.5.2 Reference Lists 190 

For bibliography lists, use the Ref paragraph style. Use the Ref term character style for the bracketed 191 
text that serves as the bibliography entry key, and make each reference term into a bookmark for use as 192 
references from the text. For example, [RFC2119] is a generated cross-reference to the IETF RFC 2119 193 
bibliography entry in Section 1.2 of this sample. 194 

7.5.2.1 Creating Bookmarks 195 

xx 196 

7.5.3 Bulleted Lists 197 

There are two levels of unordered lists: List Bullet and List Bullet 2. Use List bullet for first-level 198 
bulleted lists. Use List bullet 2 for second-level bulleted lists. Use List continue for multiple paragraphs 199 
in list items. 200 
• List bullet 201 

List continue. 202 

– List bullet 2 203 
List continue 2. 204 

7.6 Tables 205 

Xxx 206 

7.7 Graphics / Figures 207 

xx 208 

7.8 Code Examples 209 

For schema code and other normative code, use the Code paragraph style. It fits 71 characters.  210 
For example: 211 

12345678901234567890123456789012345678901234567890123456789012345678901 212 
         1         2         3         4         5         6         7 213 
<simpleType name="DecisionType"> 214 
    <restriction base="string"> 215 
        <enumeration value="Permit"/> 216 
        <enumeration value="Deny"/> 217 
        <enumeration value="Indeterminate"/> 218 
    </restriction> 219 
</simpleType> 220 

Use the Code small style if the code has very long lines. It fits 80 characters. For example: 221 

12345678901234567890123456789012345678901234567890123456789012345678901234567890 222 
         1         2         3         4         5         6         7         8 223 
<simpleType name="DecisionType"> 224 
    <restriction base="string"> 225 
        <enumeration value="Permit"/> 226 
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        <enumeration value="Deny"/> 227 
        <enumeration value="Indeterminate"/> 228 
    </restriction> 229 
</simpleType> 230 

See Appendix C for non-normative code examples.  231 

7.9 Character Styles 232 

This template defines several character styles for general text use: 233 
• Attribute style (shortcut Ctrl-Shift-A) for attributeNames 234 

• Code temp style (shortcut Ctrl-Shift-Alt- 235 
• Datatype style (shortcut Ctrl-Shift-Alt-D) for DataType names 236 

• Element style (shortcut Ctrl-Shift-E) for <NativeElement> names and <ns:ForeignElement> 237 
names; add the angle brackets yourself 238 

• Emphasis style (shortcut Ctrl-Shift-Alt- 239 
• HTML Typewriter style (shortcut Ctrl-Shift-Alt- 240 
• Hyperlink style (shortcut Ctrl-Shift-Alt- 241 
• Keyword style (shortcut Ctrl-Shift-K) for OtherKeyword names 242 

• Ref term style (shortcut Ctrl-Shift-Alt- 243 
• Variable style (shortcut Ctrl-Shift-Alt-V) for variable names 244 
 245 
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8 Appendices 246 

Templates for the following appendices have been included. Their use is optional. 247 

8.1 Appendix A – Acknowledgements 248 

The acknowledgements section MAY contain a list of all TC members or some subset of members who 249 
have been recognized for their contributions to the work of the committee. The actual list of participants is 250 
at the chair’s discretion.  251 

8.2 Appendix B – Revision History 252 

A revision history is useful to provide a summary of the changes to the document throughout its life cycle. 253 
The revision history SHOULD NOT be included in a document that has reached the stage of OASIS 254 
Standard. 255 

8.3 Appendix C – Non-Normative Text 256 

Appendix C (and any other additional appendices) is considered to be Non-Normative; that is, 257 
informational only. All normative text MUST be part of the main body of the document. 258 
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9 Creating HTML 259 

xxx 260 
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10 Creating PDF 261 

Xxx 262 
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11 Updating an Existing Document 263 

xxx 264 
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Appendix B. Revision History 272 

[optional; should not be included in OASIS Standards]  273 
 274 

Revision Date Editor Changes Made 

[Rev number]  [Rev Date]  [Modified By]  [Summary of Changes]  

 275 
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