Learning your way around DITA markup

DITA Language Reference

(C) Copyright IBM Corp. 2001 2004

owner:

International Business Machines
New Orchard Road
Armonk, New York 10504
914-499-1900 http://www.ibm.com/


DITA Language Reference overview

The design of the Darwin Information Typing Architecture (DITA) is based on deriving multiple information types, or info-types , from a common, generic topic. This language reference describes the elements that comprise the topic DTD and its initial, info-typed descendents: concept, reference, and task.

The elements that make up the DITA design represent a set of different authoring concerns:

  • The main components of a topic, concept, reference, or task document,
  • The common elements available for creating content within the body of a topic,
  • The elements that make up the two types of tables in DITA,
  • Elements that represent different subject domains,
  • Elements that appear in many contexts,
  • The elements contained in the prolog of a topic,
  • The elements contained in the related-links part of a topic,
  • Elements that are available for further specialization,
  • Commonly referenced descriptions,
  • and elements contained in a DITA map.

In addition, this reference also describes elements that are used to manage DITA topics, either for convenience in editing or for production as sets of topics for particular kinds of deliverables.


Topic elements

Use the generic topic structure for untyped topics. Although it is possible to develop most types of topic content within a generic topic, only the typed topics contain designed-in features that enable you to collect topics of a kind (for example, reference) into automatic groups in a navigation system (as in an information center.)


dita

The <dita> element provides a top-level container for multiple topics when you create documents using the ditabase DTD. The <dita> element lets you create any sequence of concept, task, and reference topics, and the ditabase DTD lets you further nest these topic types inside each other. The <dita> element has no particular output implications; it simply allows you to create multiple topics of different types at the same level in a single document.

Contained by

No parent content.

Contains

topic or concept or task or reference

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA

Example

<dita>
  <concept id="batintro">...</concept>
  <reference id="batparts">...</reference>
  <task id="batfeeding">...</task>
  <task id="battraining">...</task>
  <task id="batcleanup">...</task>
</dita>


topic

The <topic> element is the top-level DITA element for a single-subject topic or article. Other top-level DITA elements that are more content-specific are <concept>, <task>, and <reference>.

Contained by

dita , topic , concept , task , reference

Contains

title then ( titlealts ) (optional) then ( shortdesc ) (optional) then ( prolog ) (optional) then body then ( related-links ) (optional) then ( topic ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
conref This attribute is used to reference an ID on a topic that can be reused. For example, you could create a series of topics in a compound (dita) or nested context for authoring convenience and then reference each topic individually into a new target location. During output processing, a lookup process will pull the contents of the first topic into the calling topic markup that has the conref attribute.

The conref value follows the same conventions as HTML for normal file links. To refer to target content in a different file, put the full URL of that topic before the # character.

Target elsewhere in the same file: conref="#topicid"
In different file: conref="filename.xml"
In different compound file: conref="filename.xml#topicid"
 CDATA #IMPLIED boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:lang | Specifies the language of the element content. When no xml:lang value is supplied, the default value of English is assumed. For example, if there is a note element with the attribute xml:lang set to the value "es-es," then the label on the note, which is normally output as "Note" is now output in Spanish as "Nota." A list of supported values is given in xml:lang values. | NMTOKEN | #IMPLIED | boolean: no
DTDVersion | Designates the version of the DTD that is in use. | CDATA | "V1.1.0" (version dependent; will increase) | boolean: yes
domains | Indicates the specialized domains that are included in the DTD. | CDATA | ui-d hi-d pr-d sw-d | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<topic id="topic">
 <title>Some little topic</title>
 <body>
  <p>Here's a <b><i>cute</i></b>,
  <b>little</b> topic.</p>
  <ul>
   <li>Some item</li>
   <li>Another item</li>
  </ul>
 </body>
</topic>


title

The <title> element contains a heading or label for the main parts of a document such as <topic>, <section>, and <example> and for the display elements such as figure (<fig>) and <table>.

Contained by

topic , section , example , fig , figgroup , linklist , table , concept , task , reference , refsyn , syntaxdiagram , synblk , groupseq , groupchoice , groupcomp , fragment

Contains

text data or ph or term or q or boolean or state or keyword or tm or image

Attributes

Name | Description | Data Type | Default Value | Required?
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<topic id="topic">
 <title>Some little topic</title>
 <body>
  <p>Some discourse.</p>
 </body>
</topic>


titlealts

The alternate title element (<titlealts>) is optional, but can occur after the topic title. Two elements can be inserted as sub-elements of <titlealts>: navigation title <navtitle> and search title <searchtitle>. When your DITA topic is transformed to XHTML, the <searchtitle> element is used to create a title element at the top of the resulting XHTML file. This title may differ from the first level heading that shows in the main browser window. In HTML output, the <navtitle> may be used to create navigation panels when your DITA topics are part of an HTML-based help or information system. The design intent is to enable navigation for HTML Help and Eclipse help systems.

Contained by

topic , concept , task , reference

Contains

( navtitle ) (optional) then ( searchtitle ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="progexample">
   <title>Programming Example</title>
      <titlealts><navtitle>Example of Required Programming</navtitle></titlealts>
   <taskbody> . . . </taskbody>
</task>


navtitle

The navigation title (<navtitle>) element is one of a set of alternate titles that can be included inside the <titlealts> element. This navigation title may differ from the first level heading that shows in the main browser window. Use <navtitle> when the actual title of the topic isn't appropriate for use in navigation panes or online contents (for example, because the actual title is too long or needs stated in terse, imperative voice in the navigation).

Contained by

titlealts

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id=progexample">
 <title>Publishing a DITA information set in PDF</title>
  <titlealts><navtitle>Publishing in PDF</navtitle></titlealts>
 <taskbody> . . . </taskbody>
</task>


searchtitle

When your DITA topic is transformed to XHTML, the <searchtitle> element is used to create a title element at the top of the resulting HTML file. This title is normally used in search result summaries by some search engines, such as that in Eclipse ( http://eclipse.org ); if not set, the XHTML's title element defaults to the source topic's title content (which may not be as well optimized for search summaries)

Contained by

titlealts

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="progexample">
 <title>Programming Example</title>
  <titlealts><searchtitle>Example of Required Programming</searchtitle></titlealts>
 <taskbody> . . . </taskbody>
</task>


shortdesc

The short description (<shortdesc>) element occurs between the topic title and the topic body, as the initial paragraph-like content of a topic. The short description, which represents the purpose or theme of the topic, is also intended to be used as a link preview and for searching.

Contained by

topic , concept , task , reference

Contains

text data or ph or term or q or boolean or state or keyword or tm or image

Attributes

Name | Description | Data Type | Default Value | Required?
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="abstractexample">
   <title>Abstract Example</title>
      <shortdesc>This documentation addresses messages...</shortdesc>
   <taskbody>...</taskbody>
</task>


body

The <body> element is the container for the main content of a <topic>.

Contained by

topic

Contains

p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or required-cleanup or section or example

Attributes

Name | Description | Data Type | Default Value | Required?
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<topic>
<title>...</title>
<prolog>...</prolog>
<body> ... ... </body>
</topic>


section

The <section> element represents an organizational division in a topic. Sections are used to organize subsets of information that are directly related to the topic. For example, the titles Reference Syntax, Example and Properties might represent section-level discourse within a topic about a command-line process—the content in each section relates uniquely to the subject of that topic. Multiple sections within a single topic do not represent a hierarchy, but rather peer divisions of that topic. Sections cannot be nested. A section may have an optional title.

Contained by

body , conbody , refbody

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or title or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<reference id="reference">
 <title>Copy Command</title>
 < refbody>
  <section>
   <title>Purpose</title>
   This little command copies
   things.
  </section>
 </refbody>
</reference>


example

The <example> element is a section with the specific role of containing examples that illustrate or support the current topic. The <example> element has the same content model as <section>.

Note: The <example> element represents much more than IBMIDDoc's <xmp> element. DITA uses <example> to contain both discussion and sample code or outputs, whereas in <xmp>, only the example data is supported. Hence, in a DITA topic, to represent programming code and results within the discussion in an example, use the <codeblock> and <systemoutput> elements. For lines of text, use the <lines> element. For pre-formatted text such as email headers, use the <pre> element.

Contained by

body , conbody , taskbody , refbody

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or title or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This example section is used in the DITA element references to demonstrate one or more ways of using DITA elements. For example, the codeblock element supports program listings:
/* simple CSS */
bold {font-weight: bold;}
whereas the lines element represents textual productions such as poetry:
I think that I shall never see
A poem lovely as a tree.
...
Poems are made by fools like me,
But only God can make a tree.

Joyce Kilmer
Trees

Another common structure supported by the example element is the familiar command prototype followed by parameters:

To format a hard drive, use the format volume /fs: file-system command, where
volume
specifies the resource to be formatted
/fs: file-system
specifies the file system format to create (FAT32, NTFS, etc.)


related-links

The related information links of a topic (<related-links> element) are stored in a special section following the body of the topic. After a topic is processed into it final output form, the related links are usually displayed at the end of the topic, although some Web-based help systems might display them in a separate navigation frame.

Prerequisite links are an exception (that is, in which importance="required" and the role is compatible–not ancestor/parent/child/descendant/next). These get sorted after the <shortdesc> (all topics) or after the <prereq> section (for tasks).

Processing notes:

  1. PDF output ignores hierarchical links, for example ancestor/parent/child/descendant/next/previous/sibling.
  2. Links not in a <linklist> will be sorted on output based on type, role, and importance.
  3. The value of the format attribute defaults to "dita" unless the attribute scope="external", when format is assumed to be not-dita.

Contained by

topic , concept , task , reference

Contains

link or linklist or linkpool

Attributes

Name | Description | Data Type | Default Value | Required?
%rel-atts; (type, role, otherrole) | A set of related attributes, described at %rel-atts; | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
format The format attribute identifies the format of the resource being cross referenced. The default format is dita.

Allowable values are:

dita
The format of the linked-to resource is native DITA. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
(no value)
Defaults to "dita"
(for anything else)
Use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value)
 CDATA #IMPLIED boolean: no
scope | The scope attribute identifies the closeness of the relationship between the current topic and the target resource. Set scope to local when the resource is part of the current set of content, and should be accessed and copied to the output directory. Set scope to peer when the resource is part of the current set of content but is not accessible at build time. Set scope to external when the resource is not part of the current information set and should open in a new browser window. The default is local. | (local | peer | external) | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>...</taskbody>
 <related-links>
  <link href="#concept"><linktext>Some little concept</linktext></link>
 </related-links>
</task>


Concept elements

Use the concept topic to introduce the background or overview information for tasks or reference topics. The concept topic has the restriction that following a section or example, only other sections or examples are permitted as content. This particular topic is a concept topic.


concept

The <concept> element is the top-level element for a topic that answers the question "what is?" Concepts provide background information that users must know before they can successfully work with a product or interface. Often, a concept is an extended definition of a major abstraction such as a process or function. It might also have an example or a graphic, but generally the structure of a concept is fairly simple.

Contained by

dita

Contains

title then ( titlealts ) (optional) then ( shortdesc ) (optional) then ( prolog ) (optional) then conbody then ( related-links ) (optional) then ( topic ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
conref This attribute is used to reference an ID on a topic that can be reused. For example, you could create a series of topics in a compound (dita) or nested context for authoring convenience and then reference each topic individually into a new target location. During output processing, a lookup process will pull the contents of the first topic into the calling topic markup that has the conref attribute.

The conref value follows the same conventions as HTML for normal file links. To refer to target content in a different file, put the full URL of that topic before the # character.

Target elsewhere in the same file: conref="#topicid"
In different file: conref="filename.xml"
In different compound file: conref="filename.xml#topicid"
 CDATA #IMPLIED boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:lang | Specifies the language of the element content. When no xml:lang value is supplied, the default value of English is assumed. For example, if there is a note element with the attribute xml:lang set to the value "es-es," then the label on the note, which is normally output as "Note" is now output in Spanish as "Nota." A list of supported values is given in xml:lang values. | NMTOKEN | #IMPLIED | boolean: no
DTDVersion | Designates the version of the DTD that is in use. | CDATA | "V1.1.0" (version dependent; will increase) | boolean: yes
domains | Indicates the specialized domains that are included in the DTD. | CDATA | ui-d hi-d pr-d sw-d | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<concept id="concept">
 <title>Introduction to Bird Calling</title>
 <conbody>
  <p>If you wish to attract more birds to your Acme Bird Feeder,
learn the art of bird calling.  Bird calling is an efficient way
to alert more birds to the presence of your bird feeder.</p>
  <example>
   <p>Bird calling requires learning:</p>
   <ul>
    <li>Popular and classical bird songs</li>
    <li>How to whistle like a bird</li>
   </ul>
  </example>
 </conbody>
</concept>


conbody

The <conbody> element is the main body-level element for a concept. Like the body element of a general topic, <conbody> allows paragraphs, lists, and other elements as well as sections and examples. But <conbody> has a constraint that a section or an example can be followed only by other sections or examples.

Contained by

concept

Contains

( p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or required-cleanup ) (0 or more) then ( section or example ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<conbody>
 <p>If your workgroup has symbols files that are defined once for all
the books you author, you can define parameter entities for those symbols
within your SGML document. Parameter entities allow you to define an
imbed file of symbols, then reuse the same entities many times in your document.</p>
 <example>
  <p>Entity declarations have the following formats:</p>
  <ul>
  <li><!ENTITY symbol "text"> for a text entity</li>
  <li><!ENTITY name system "systemID"> for a file entity</li>
  </ul>
 </example>
 </conbody>


Reference elements

Use the reference elements to describe regular features of sets of things, most commonly the commands in a programming language. However, this format is also suitable for recipes, bibliographies, catalogues, and similar collections of structured descriptive prose.


reference

The <reference> element defines a top-level container for a reference topic. Reference topics document programming constructs or facts about a product. Examples of reference topics include language elements, class descriptions, commands, functions, statements, protocols, types, declarators, operands, and API information, which provide quick access to facts, but no explanation of concepts or procedures. Reference topics have the same high-level structure as any other topic type, with a title, short description, and body. Within the body, reference topics are typically organized into one or more sections, property lists, and tables. The reference topic type provides general rules that apply to all kinds of reference information, using elements like <refsyn> for syntax or signatures, and <properties> for lists of properties and values.

Contained by

dita

Contains

title then ( titlealts ) (optional) then ( shortdesc ) (optional) then ( prolog ) (optional) then refbody then ( related-links ) (optional) then ( topic ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
conref This attribute is used to reference an ID on a topic that can be reused. For example, you could create a series of topics in a compound (dita) or nested context for authoring convenience and then reference each topic individually into a new target location. During output processing, a lookup process will pull the contents of the first topic into the calling topic markup that has the conref attribute.

The conref value follows the same conventions as HTML for normal file links. To refer to target content in a different file, put the full URL of that topic before the # character.

Target elsewhere in the same file: conref="#topicid"
In different file: conref="filename.xml"
In different compound file: conref="filename.xml#topicid"
 CDATA #IMPLIED boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:lang | Specifies the language of the element content. When no xml:lang value is supplied, the default value of English is assumed. For example, if there is a note element with the attribute xml:lang set to the value "es-es," then the label on the note, which is normally output as "Note" is now output in Spanish as "Nota." A list of supported values is given in xml:lang values. | NMTOKEN | #IMPLIED | boolean: no
DTDVersion | Designates the version of the DTD that is in use. | CDATA | "V1.1.0" (version dependent; will increase) | boolean: yes
domains | Indicates the specialized domains that are included in the DTD. | CDATA | ui-d hi-d pr-d sw-d | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<?xml version="1.0"?>
<!DOCTYPE reference SYSTEM "../../build/dita/dtd/reference.dtd">
<reference id="refexample">
 <title>A reference topic/title>
 <refbody>
  <refsyn>Describe command or api syntax here, possibly
  using &lt;synph> or &lt;syntax> markup for explicit
  definition of syntax or prototype construction.
  </refsyn>
  <section>
   <title>Some section title</title>
  </section>
  <properties>
   <property>
    <proptype>type</proptype>
    <propvalue>value</propvalue>
    <propdesc>description</propdesc>
   </property>
  </properties>
 </refbody>
</reference>


refbody

The <refbody> element is a container for the main content of the reference topic. Reference topics limit the body structure to tables (both simple and standard), property lists, syntax sections, and generic sections and examples, in any sequence or number.

Reference topics represent the kind of information that users typically consult to understand programming objects, statements, commands, configuration file options, recipes, terminological descriptions, and so forth.

Contained by

reference

Contains

( section or refsyn or example or table or simpletable or properties ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<?xml version="1.0"?>
<!DOCTYPE reference SYSTEM "../../build/dita/dtd/reference.dtd">
<reference id="refexample">
 <title>A reference topic</title>
 <refbody>
  <refsyn>Describe command or api syntax here, possibly
  using &lt;synph> or &lt;syntax> markup for explicit
  definition of syntax or prototype construction.</refsyn>
  <section>
   <title>Some section title</title>
  </section>
  <properties>
   <property>
    <proptype>type</proptype>
    <propvalue>value</propvalue>
    <propdesc>description</propdesc>
   </property>
  </properties>
 </refbody>
</reference>


refsyn

The <refsyn> element is a special section inside a reference topic. The section often contains syntax or signature content (for example, a command-line utility's calling syntax, or an API's signature). The <refsyn> contains a brief, possibly diagrammatic description of the subject's interface or high-level structure.

Contained by

refbody

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or title or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<?xml version="1.0"?>
<!DOCTYPE reference SYSTEM "../../build/dita/dtd/reference.dtd">
<reference id="refexample">
 <title>A reference topic</title>
 <refbody>
  <refsyn><syntaxdiagram>
<title>Adding</title>
<groupseq><kwd>1</kwd><oper>+</oper><var>two</var><delim>=</delim>
<kwd>something</kwd></groupseq></syntaxdiagram></refsyn>
  <section>
   <title>Some section title</title>
  </section>
  <properties>
   <property>
    <proptype>type</proptype>
    <propvalue>value</propvalue>
    <propdesc>description</propdesc>
   </property>
  </properties>
 </refbody>
</reference>


properties

The <properties> element gives a list of properties for the subject of the current topic, for example whether a class is public or protected. Each property can include the type, value, and a description. The typical rendering is usually in a table-like format. To represent multiple values for a type, just create additional property elements and use only the <propvalue> element (and <propdesc> when needed) for each successive value.

Contained by

refbody

Contains

property

Attributes

Name | Description | Data Type | Default Value | Required?
relcolwidth A relative value to specify the width of a column in relationship to the width of the other columns for print output. The values are totaled and made a percent. For example:
relcolwidth="1* 2* 3*"
causes widths of 16.7%, 33.3%, and 66.7%.
relcolwidth="90* 150*"
causes width of 37.5% and 62.5%. 		CDATA #IMPLIED boolean: no
keycol | Defines the column that will be used for row headings. No value indicates no key column. When present, the numerical value causes the specified column to be highlighted as a vertical header. | NMTOKEN | #IMPLIED | boolean: no
refcols | Designates columns that contain references, and are candidates for automated linking (not currently supported). Columns are identified by a comma-delimited list of numbers (for example: 1,3). | NMTOKENS | #IMPLIED | boolean: no
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<properties>
  <property>
    <proptype>color</proptype>
      <propvalue>red</propvalue>
        <propdesc>depicts anger</propdesc>
  </property>
  <property>
      <propvalue>green</propvalue>
        <propdesc>depicts permission</propdesc>
  </property>
</properties>


property

The <property> element represents a property of the current topic's subject. For example, if the current topic is a class, the property might show that the class is protected rather than public. It contains three optional elements: type, value, and description.

Contained by

properties

Contains

( proptype ) (optional) then ( propvalue ) (optional) then ( propdesc ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<properties>
   <property>
     <proptype>type</proptype>
     <propvalue>value</propvalue>
    <propdesc>description</propdesc>
  </property>
</properties>


proptype

The proptype element describes the type of property.

Contained by

property

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or image or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<properties>
   <property>
     <proptype>type</proptype>
     <propvalue>value</propvalue>
    <propdesc>description</propdesc>
  </property>
</properties>


propdesc

The <propdesc> element is used to provide a short description of the property type and its listed values (or just the value).

Contained by

property

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or image

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<properties>
  <property>
    <proptype>type</proptype>
    <propvalue>value</propvalue>
    <propdesc>description</propdesc>
  </property>
</properties>


propvalue

The <propvalue> element indicates the value or values for the current property type. You can put values in separate rows if they need separate descriptions, and just leave the <proptype> element blank.

Contained by

property

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or image or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<properties>
   <property>
     <proptype>type</proptype>
     <propvalue>value</propvalue>
    <propdesc>description</propdesc>
  </property>
</properties>


prophead

The prophead element supports user-defined headings for the properties element.

By default, the processing for the properties element produces standard headings of "Type,""Value," and "Description." The prophead element allows you to create custom headings as needed by special cases.

Contains

proptypehd, propvaluehd, propdeschd

Contained by

Allowed in the properties element of the reference information type.

Attributes

Same as for strow.

Examples

A properties section with a custom prophead looks like:

Type | Value | Description
Datatype | Recommended Value | Meaning
integer | 42 | The answer to all the questions in the universe.
keyword | default, rect, circle, poly | The values allowed for an image map shape.


Task elements

Use the task topic to describe the steps of a particular task. The task topic includes sections for describing the context, prerequisites, expected results, and other aspects of a task.


task

The <task> element is the top-level element for a task topic. Tasks are the main building blocks for task-oriented user assistance. They generally provide step-by-step instructions that will enable a user to perform a task. A task answers the question of "how to?" by telling the user precisely what to do and the order in which to do it. Tasks have the same high-level structure as other topics, with a title, short description and body.

Contained by

dita

Contains

title then ( titlealts ) (optional) then ( shortdesc ) (optional) then ( prolog ) (optional) then taskbody then ( related-links ) (optional) then ( topic ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
conref This attribute is used to reference an ID on a topic that can be reused. For example, you could create a series of topics in a compound (dita) or nested context for authoring convenience and then reference each topic individually into a new target location. During output processing, a lookup process will pull the contents of the first topic into the calling topic markup that has the conref attribute.

The conref value follows the same conventions as HTML for normal file links. To refer to target content in a different file, put the full URL of that topic before the # character.

Target elsewhere in the same file: conref="#topicid"
In different file: conref="filename.xml"
In different compound file: conref="filename.xml#topicid"
 CDATA #IMPLIED boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:lang | Specifies the language of the element content. When no xml:lang value is supplied, the default value of English is assumed. For example, if there is a note element with the attribute xml:lang set to the value "es-es," then the label on the note, which is normally output as "Note" is now output in Spanish as "Nota." A list of supported values is given in xml:lang values. | NMTOKEN | #IMPLIED | boolean: no
DTDVersion | Designates the version of the DTD that is in use. | CDATA | "V1.1.0" (version dependent; will increase) | boolean: yes
domains | Indicates the specialized domains that are included in the DTD. | CDATA | ui-d hi-d pr-d sw-d | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>
  <context>Once you have set up SQLJ, you need to create a new SQLJ file.
  </context>
  <steps>
   <step><cmd>Open...</cmd></step>
  </steps>
 </taskbody>
</task>


taskbody

The <taskbody> element is the main body-level element inside a task topic. A task body has a very specific structure, with the following elements in this order: <prereq>, <context>, <steps>, <result, <example> and <postreq>. Each of the body sections are optional.

Contained by

task

Contains

( prereq ) (optional) then ( context ) (optional) then ( steps or steps-unordered ) (optional) then ( result ) (optional) then ( example ) (optional) then ( postreq ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id=sqlj>
 <title>Creating an SQLJ file</title>
 <taskbody>
  <context>Once you have set up SQLJ, you need to create a new SQLJ file.
  </context>
  <steps>
   <step><cmd>In a text editor, create a new file.</cmd></step>
   <step><cmd>Add your Java source code and SQLJ statements.</cmd></step>
   <step><cmd>Save your file with an .sqlj extension and close the
   editor.</cmd></step>
  </steps>
  <postreq>
   <p>Once you have created a new .sqlj file, import the file into
   your project and translate the file.</p>
   <p>For information on SQLJ syntax, contact your database vendor or
   see <xref href="web.ansi.org/public/std_info.html" type="external"/>.</p>
  </postreq>
 </taskbody>
</task>


postreq

The <postreq> element describes steps or tasks that the user should do after the successful completion of the current task. It is often supported by links to the next task or tasks in the <related-links> section.

Contained by

taskbody

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<postreq>Notify the proctor upon completing this self-test.</postreq>


prereq

The pre-requisite (<prereq>) section of a task should document things the user needs to know or do before starting the current task. Prerequisite links will be placed in a list after the related-links section; on output the <prereq> links from the related-links section are added to the <prereq> section.

Contained by

taskbody

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>
  <prereq>Before creating a new SQLJ file, you must
  log in to the SQLJ server.</prereq>
 </taskbody>
</task>


result

The <result> element describes the expected outcome for the task as a whole.

Note: If this is the outcome of a specific step, put this in the <stepresult> element instead.

Contained by

taskbody

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
 <titleCreating an SQLJ file</title>
 <taskbody>
  <context>Once you have set up SQLJ, you need to create a new SQLJ file.
  You cannot add #sqlj statements directly in the Source pane of the
  Workbench.</context>
  <result>The SQLJ file is successfully created when the SQLJ server
  displays the "File Created" dialog.</result>
 </taskbody>
</task>


context

The <context> section of a task provides background information for the task. This information helps the user understand what the purpose of the task is and what they will gain by completing the task. This section should be brief and does not replace or recreate a concept topic on the same subject, although the context section may include some conceptual information.

Contained by

taskbody

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
<title>Creating an SQLJ file</title>
<taskbody>
<context>Once you have set up SQLJ, you need to create a new SQLJ file.
</context>
</task>


steps

The <steps> section of a task provides the main content of the task topic. The task is described as a series of steps that the user must follow to accomplish the task. One or more <steps> elements is required inside the <steps> section.

Two or more steps appear as an ordered list. A single step appears as a paragraph.

Contained by

taskbody

Contains

( step ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
<title>Creating an SQLJ file</title>
 <taskbody>
 <context>Once you have set up SQLJ, you need to create a new SQLJ file.</context>
  <steps>
   <step>
    <cmd>In a text editor, create a new file.</cmd>
   </step>
   <step>
    <cmd>Enter the first query statement.</cmd>
   </step>
  </steps>
 </taskbody>
</task>


steps-unordered

Like the <steps> element, the <steps-unordered> section of a task provides the main content of the task topic, but particularly for cases in which the order of steps may vary from one situation to another. For example, fields of a form can be filled in without particular regard to order as long as the required ones are filled in before submitting the form. One or more steps is required inside the <steps-unordered> section.

Two or more steps appear as an unordered list. A single step appears as a paragraph.

Contained by

taskbody

Contains

( step ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>
  <context>Once you have set up SQLJ, you need to create a new SQLJ file.</context>
  <steps-unordered>
   <step><cmd>In a text editor, create a new file.</cmd></step>
  </steps-unordered>
 </taskbody>
</task>


step

The <step> element represents an action that a user must follow to accomplish a task. Each step in a task must contain a command <cmd> element which describes the particular action the user must do to accomplish the overall task. The step element can also contain information <info>, substeps <substeps>, tutorial information <tutorialinfo>, a step example <stepxmp>, choices <choices> or a stepresult <stepresult>, although these are optional.

Contained by

steps , steps-unordered

Contains

cmd then ( info or substeps or tutorialinfo or stepxmp or choicetable or choices ) (0 or more) then ( stepresult ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether the element it modifies is optional or required. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | #IMPLIED | boolean: no
%select-atts; | A set of related attributes, described at select-atts. Note: For this element, the attribute importance has only the values "required" and "optional." |  |  |
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
translate | Indicates whether the content of the element should be translated or not. | yes | no | #IMPLIED | boolean: no
xml:lang | Specifies the language of the element content. When no xml:lang value is supplied, the default value of English is assumed. For example, if there is a note element with the attribute xml:lang set to the value "es-es," then the label on the note, which is normally output as "Note" is now output in Spanish as "Nota." A list of supported values is given in xml:lang values. | NMTOKEN | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
<title>Creating an SQLJ file</title>
<taskbody>
<context>Once you have set up SQLJ, you need to create a new SQLJ file.
</context>
<steps>
<step><cmd></cmd></step>
</steps>
</taskbody>
</task>


choices

The <choices> element contains a list of <choice> elements. It is used when the user will need to choose one of several actions while performing the steps of a task.

Contained by

step

Contains

( choice ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Choose a server.</cmd>
<choices><choice>If you have a remote server you want to test on, type the
IP address or hostname of the server here.</choice>
<choice>If you want to do local testing, just type localhost.</choice>
</choices>
</step>


choice

Each <choice> element describes one way that the user could accomplish the current step.

Contained by

choices

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Choose a server.</cmd>
 <choices>
  <choice>If you have a remote server you want to test on, type the
IP address or hostname of the server here.</choice>

            <choice>If you want to do local testing, just type localhost.</choice>
 </choices>
</step>


stepxmp

The step example (<stepxmp>) element is used to illustrate a step of a task. The example can be a couple of words, or an entire paragraph.

Contained by

step , substep

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step>
 <cmd>Type a name for the widget.</cmd>
 <stepxmp>For example, <userinput>mywidget</userinput></stepxmp>
</step>


substeps

The <substeps> element allows you to break a step down into a series of separate actions, and should be used only if necessary. Try to describe the steps of a task in a single level of steps. If you need to use more than one level of substep nesting, you should probably rewrite the task to simplify it.

Contained by

step

Contains

substep

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<substeps>
<substep><cmd>Hold pencil in a steady, level position.</cmd></substep>
<substep><cmd>Turn handle until resistance diminishes.</cmd>
<info>Note: initially, it may be somewhat difficult to turn the handle if
pencil has never been sharpened before.</info></substep>
<substep><cmd>To determine if pencil is sharp, remove it from the sharpener
and inspect the tip.</cmd></substep>
</substeps>


substep

A <substep> element has the same structure as a <step>, except that it does not allow lists of choices or substeps within it, in order to prevent unlimited nesting of steps.

Contained by

substeps

Contains

cmd then ( info or tutorialinfo or stepxmp ) (0 or more) then ( stepresult ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether the element it modifies is optional or required. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | #IMPLIED | boolean: no
%select-atts; | A set of related attributes, described at select-atts. Note: For this element, the attribute importance has only the values "required" and "optional." |  |  |
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
translate | Indicates whether the content of the element should be translated or not. | yes | no | #IMPLIED | boolean: no
xml:lang | Specifies the language of the element content. When no xml:lang value is supplied, the default value of English is assumed. For example, if there is a note element with the attribute xml:lang set to the value "es-es," then the label on the note, which is normally output as "Note" is now output in Spanish as "Nota." A list of supported values is given in xml:lang values. | NMTOKEN | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<substeps>
<substep><cmd>Hold pencil in a steady, level position.</cmd></substep>
<substep><cmd>Turn handle until resistance diminishes.</cmd>
<info>Note: initially, it may be somewhat difficult to turn the handle if
pencil has never been sharpened before.</info></substep>
<substep><cmd>To determine if pencil is sharp, remove it from the sharpener
and inspect the tip.</cmd></substep>
</substeps>


cmd

The command (<cmd>) element is required as the first element inside a <step>. It provides the active voice instruction to the user for completing the step, and should not be more than one sentence. If the step needs additional explanation, this can follow the <cmd> element inside an info element.

Contained by

step , substep

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or image or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to associate the <cmd> with another task that provides more details for that particular step. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>In a text editor, create a new file.</cmd></step>


info

The information element (<info>) occurs inside a <step> element to provide additional information about the step.

Contained by

step , substep

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Type a name for the widget.</cmd>
<info>The widget name is created when you configure the widget
in the Widget Configuration Dialog. It is not an actual class
name or file name, just a label for the widget as used in this
application.</info>
</step>


stepresult

The <stepresult> element provides information on the expected outcome of a step. If a user interface is being documented, the outcome could describe a dialog box opening, or the appearance of a progress indicator. Step results are useful to assure a user that they are on track, but should not be used for every step, as this quickly becomes tedious.

Contained by

step , substep

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step>
 <cmd importance="urgent">Once you have the water place it in the microwave.
Try not to spill any, as water is very wet.</cmd>
 <substeps>
  <substep importance="required">
   <cmd>Start the Microwave.</cmd>
   <stepxmp>As an example, push the <b>Start</b> button</stepxmp>
   <stepresult importance="normal">The Microwave is running</stepresult>
  </substep>
  <substep importance="optional">
   <cmd>In a minute or two the water will boil.</cmd>
  </substep>
 </substeps>
</step>


tutorialinfo

The tutorial info (<tutorialinfo>) element contains information that is included in a step when a task is part of a tutorial. The <tutorialinfo> element allows you to turn a task into a learning exercise by including explanatory content about methods for completing the current step. This information is currently included in all output processing results, not just tutorials. It is not for use in tasks that are being used outside of tutorials.

Contained by

step , substep

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<steps>
 <step>
  <cmd>Do this</cmd>
  <tutorialinfo>In your editor, open the first element and click on
  the dialog.</tutorialinfo>
 </step>
 <step>
  <cmd>Do that</cmd>
  <tutorialinfo>Move the framulator into the foobar box.</tutorialinfo>
 </step>
</steps>


choicetable

The <choicetable> element contains a series of optional choices available within a step of a task.

Contained by

step

Contains

( chhead ) (optional) then ( chrow ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
relcolwidth A relative value to specify the width of a column in relationship to the width of the other columns for print output. The values are totaled and made a percent. For example:
relcolwidth="1* 2* 3*"
causes widths of 16.7%, 33.3%, and 66.7%.
relcolwidth="90* 150*"
causes width of 37.5% and 62.5%. 		CDATA #IMPLIED boolean: no
keycol | Defines the column that will be used for row headings. No value indicates no key column. When present, the numerical value causes the specified column to be highlighted as a vertical header. | NMTOKEN | #IMPLIED | boolean: no
refcols | Designates columns that contain references, and are candidates for automated linking (not currently supported). Columns are identified by a comma-delimited list of numbers (for example: 1,3). | NMTOKENS | #IMPLIED | boolean: no
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Then this</cmd>
 <substeps>
  <substep importance="optional"><cmd>which is done by doing this</cmd></substep>
  <substep importance="required"><cmd>and then this.</cmd></substep>
 </substeps>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>


chrow

The <chrow> element is a container inside the <choicetable> element. The <chrow> element contains both a <choption> and <chdesc> element as a pair.

Contained by

choicetable

Contains

( choption ) then ( chdesc )

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Then this</cmd>
 <substeps>
  <substep importance="optional"><cmd>which is done by doing this</cmd></substep>
  <substep importance="required"><cmd>and then this.</cmd></substep>
 </substeps>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>

            <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>


chhead

The <chhead> element is a container inside the <choicetable> element that provides specific heading text to override the default Options and Description headings. The <chhead> element contains both a choptionhd and chdeschd element as a pair.

Contained by

choicetable

Contains

( choptionhd ) then ( chdeschd )

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Then this</cmd>
 <substeps>
  <substep importance="optional"><cmd>which is done by doing this</cmd></substep>
  <substep importance="required"><cmd>and then this.</cmd></substep>
 </substeps>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>


chdesc

The <chdesc> element is a description of an option that a user chooses while performing a step to accomplish a task. It explains why the user would choose that option, and might explain the result of the choice when it is not immediately obvious.

Contained by

chrow

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Then this</cmd>
 <substeps>
  <substep importance="optional"><cmd>which is done by doing this</cmd></substep>
  <substep importance="required"><cmd>and then this.</cmd></substep>
 </substeps>
 <choicetable>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>


chdeschd

The <chdeschd> option provides a specific label for the list of descriptions of options that a user must choose to accomplish a step of a task. The default label overridden by <chdeschd> is Description.

Contained by

chhead

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Then this</cmd>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>


choption

The <choption> element describes an option that a user could choose to accomplish a step of a task. In a user interface, for example, this might be the name of radio button.

Contained by

chrow

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Then this</cmd>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>


choptionhd

The <choptionhd> element provides a specific label for the list of options that a user chooses from to accomplish a step. The default label for options is Option.

Contained by

chhead

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Then this</cmd>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>


Body elements

The body elements support the most common types of content authoring for topics: paragraphs, lists, phrases, figures, and other common types of exhibits in a document.


alt

The alt element provides an element equivalent of the alt attribute on the image element. As an element, it provides direct text entry within an XML editor and is more easily accessed than an attribute for translation.

[say more about best practices when writing content for this element; relate it to creating accessible descriptions for the object element, and to accessibility in general.]

Contains

[to be revised]

Contained by

[image]

Attributes

[to be revised]

Examples

The markup for alt text within an image looks like this:

<image href="tip-ing.jpg" height="12" width="21"/>
  <alt>Tip!</alt>
</image>

The use of the alt attribute is still supported, but the element form is likely preferable for authoring.


cite

The <cite> element is used when you need a bibliographic citation that refers to a book or article. It specifically identifies the title of the resource. Its keyref attribute allows the citation to be associated to other possible bibliographic processing (not supported yet).

Contained by

section , example , desc , p , note , lq , q , sli , li , itemgroup , dt , dd , pre , lines , ph , stentry , draft-comment , fn , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , synnote

Contains

text data or ph or term or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up the location of the cited material, and potentially create a link to it. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>The online article <cite>Specialization in the Darwin Information Typing
Architecture</cite> provides a detailed explanation of how to define new
topic types.</p>


desc

The <desc> element contains the description of the current element. A description should provide more information than the title.

Contained by

fig , object , link , linklist , table

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or image

Attributes

Name | Description | Data Type | Default Value | Required?
%id-atts; (id, conref) | A set of related attributes, described at %id-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<fig><title>The Handshake</title>
<desc>This image shows two hands clasped in a formal,
business-like handshake.</desc>
<image href="handshake.jpg" alt="The Handshake"/>
</fig>


dd

The definition description (<dd>) element contains the description of a term in a definition list entry.

Contained by

dlentry

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or itemgroup or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extention</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>


ddhd

The definition descriptions heading (<ddhd>) element contains an optional heading or title for a column of descriptions or definitions in a definition list

Contained by

dlhead

Contains

text data or ph or term or q or boolean or state or keyword or tm or image

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extention</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>


dl

A definition list (<dl>) is a list of terms and corresponding definitions. The term (<dt>) is usually flush left. The description or definition (<dt>) is usually either indented and on the next line, or on the same line to the right of the term.

You can also provide an optional heading for the terms and definitions, using the <dlhead> element, which contains header elements for those columns. The default formatting for the <dlhead> looks like a table with a heading row.

Contained by

body , section , example , desc , p , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

( dlhead ) (optional) then ( dlentry ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
 (yes | no) "yes" boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<dl>
<dlentry>
<dt>Bytes returned</dt>
<dd>The number of bytes of data returned.</dd>
</dlentry>
<dlentry>
<dt>Bytes available</dt>
<dd>The number of bytes of data available to be returned.</dd>
</dlentry>
<dlentry><dt>Handle</dt>
<dd>The returned handle value</dd>
</dlentry>
</dl>

Note: In the final output (PDF, XHTML, etc), the default appearance of text-only definition terms is bold. The only time they are not bold is if you have added some tagging to the definition term. Here is an example of when the definition term would not be bold in the output:

...
<dlentry><dt>Property One: <varname>value</varname></dt>
<dd>The first property.</dd>
</dlentry>
...
The bold effect is removed so that "value" will not be bold. To make the phrase "Property One:" bold, you must add specific markup around it:
...
<dlentry><dt><b>Property One:</b> <varname>value</varname></dt>
<dd>The first property.</dd>
</dlentry>
...
These examples are both represented in the following literal definition list. The appearance here is typical of expected DITA output as XHTML or PDF:
Property One: value
The first property.
Property One: value
The first property.


dlentry

In a definition list, each list item is defined by the definition list entry (<dlentry>) element. The definition list entry element includes a term <dt> and one or more definitions or descriptions <dd> of that term.

Contained by

dl

Contains

( dt ) (one or more) then ( dd ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extention</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>


dlhead

The <dlhead> element contains optional headings for the term and description columns in a definition list. The definition list heading contains a heading <dthd> for the column of terms and an optional heading <ddhd>for the column of descriptions.

Contained by

dl

Contains

( dthd ) (optional) then ( ddhd ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extention</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>


dt

The definition term <dt> element contains a term in a definition list entry.

Contained by

dlentry

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or image

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extention</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>


dthd

The definition term heading (<dthd>) element is contained in a definition list head (<dlhead>) and provides an optional heading for the column of terms in a description list.

Contained by

dlhead

Contains

text data or ph or term or q or boolean or state or keyword or tm or image

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extention</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>


fig

The figure (<fig>) element is a display context (sometimes called an "exhibit") with an optional title for a wide variety of content. Most commonly, the figure element contains an image element (a graphic or artwork), but it can contain several kinds of text objects as well. A title is placed inside the figure element to provide a caption to describe the content.

Contained by

body , section , example , p , note , lq , li , itemgroup , dd , stentry , draft-comment , fn , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , pd

Contains

( title ) (optional) then ( desc ) (optional) then ( figgroup or p or lq or note or dl or ul or ol or sl or pre or lines or image or object or simpletable ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<fig expanse="column"><title>The Handshake</title>
<image href="handshake.jpg" alt="The Handshake"/>
</fig>


figgroup

The <figgroup> element is used only for specialization at this time. Figure groups can be used to contain multiple cross-references, footnotes or keywords, but not multipart images. Multipart images in DITA should be represented by a suitable media type displayed by the <object> element.

Contained by

fig , figgroup

Contains

( title ) (optional) then ( figgroup or xref or fn or ph or keyword ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example


image

Include artwork or images in a DITA topic by using the <image> element. The <image> element has optional attributes that indicate whether the placement of the included graphic or artwork should be inline (like a button or icon), or on a separate line for a larger image. An href attribute is required on the image element, as this attribute creates a pointer to the image, and allows the output formatting processor to bring the image into the text flow. To make the intent of the image more accessible for users using screen readers or text-only readers, always include a description of the image's content in the alt attribute.

Contained by

title , shortdesc , body , section , example , desc , p , note , lq , sli , li , itemgroup , dthd , ddhd , dt , dd , fig , ph , stentry , draft-comment , fn , xref , linkinfo , entry , conbody , prereq , context , cmd , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , uicontrol , pt , pd

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
href The relative path or URL to the GIF or JPEG image. The href attribute uses conventional URL syntax to point to the resource:
href="../images/construction.gif"
 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to refer to the <image> by a key rather than referencing it directly. | NMTOKEN | #IMPLIED | boolean: no
alt | Alternative text that describes the image to provide accessibility to page readers, or provides a text description when an image cannot be displayed by the user's software. | CDATA | #IMPLIED | boolean: no
longdescref | A reference to a textual description of the graphic. This attribute supports creating accessible content. | CDATA | #IMPLIED | boolean: no
height | Indicates the maximum height of an image. | NMTOKEN | #IMPLIED | boolean: no
width | Indicates the maximum width of an image. | NMTOKEN | #IMPLIED | boolean: no
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
 (left | right | center | justify | char) #IMPLIED boolean: no
placement | Indicates whether an image should be displayed inline or separated from the surrounding text. The default is inline. Allowable values are: inline or break. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<image href="bike.gif" alt="Two-wheeled bicycle" placement="break"/>


keyword

The <keyword> element identifies a keyword or token, such as a single value from an enumerated list, the name of a command or parameter, or a lookup key for a message (contrast with term ).

Specialized elements derived from <keyword> may also have extended processing, such as different formatting or automatic indexing. If the keyref attribute is used, the keyword can be turned into a hyperlink on output (not currently supported).

When DITA topics are output to XHTML, any <keyword> or <indexterm> elements in the <keywords> element are placed in the Web page metadata. In addition, any index terms in this context are also used for supported index processing (for example, for print versions).

Contained by

title , shortdesc , section , example , desc , p , note , lq , q , sli , li , itemgroup , dthd , ddhd , dt , dd , figgroup , pre , lines , ph , stentry , draft-comment , fn , cite , xref , linkinfo , entry , keywords , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , fragref , synnote

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to associate the <keyword> with another topic that provides more details for that particular keyword. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>The <keyword>assert</keyword> pragma statement allows messages to be passed
to the emulator, pre-compiler, etc..


li

A list (<li>) item is a single item in an ordered <ol> or unordered <ul> list. When a DITA topic is formatted for output, numbers and alpha characters are usually output with list items in ordered lists, while bullets and dashes are usually output with list items in unordered lists.

Contained by

ul , ol

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or itemgroup or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<ul>
<li>This is an item in an unordered list.</li>
</ul>


lines

The <lines> element may be used to represent dialogs, lists, text fragments, and so forth. The <lines> element is similar to <pre> in that hard line breaks are preserved, but the font style is not set to monospace, and extra spaces inside the lines are not preserved.

Contained by

body , section , example , desc , p , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:space | This attribute is provided on <pre>, <lines>, and on elements derived from them. It ensures that parsers in editors and transforms respect the line-end characters that are part of the data in those elements. It is intended to be part of the default properties of these elements, and not for authors to change or delete. | (preserve) | #FIXED 'preserve' | boolean: yes
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

On a trip to the beach, don't forget:
<lines>
suntan lotion
sunglasses
a beach towel
</lines>


lq

The long quote (<lq>) element indicates content quoted from another source. Use the quote element <q>for short, inline quotations, and long quote <lq> for quotations that are too long for inline use, following normal guidelines for quoting other sources. You can store a URL to the source of the quotation in the href attribute.

Future DITA considerations:

Bibliographic citations obviously are more complex than can be supported by a URL alone. Typical alternate addressing schemes include ISBN, Dewey Decimal, floor/aisle/shelf number, catalog number, Web publisher query link, newpaper name/date/section/page#, and many others, depending on the media, conventions for addressing, and the amount of additional metadata required to describe a bibliographic resource (such as prescribed by MLA citation guidelines).

Many external repositories of bibliographic descriptions already exist. The still-to-be-implemented keyref is an application-independent way to index a quote to a more complete bibliographic description for a resource that exists elsewhere (perhaps in other DTDs or databases).

Contained by

body , section , example , desc , p , note , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
href A hyperlink representing a bibliographic citation to resources that can be accessed by browsers (meaning a URL). See keyref processing for information about alternate ways to indicate other, non Web-accessible bibliographic resources. The href attribute identifies the destination of the resource using conventional URL syntax:
href="http://www.xxx.com" format="html"
href="myfile.xml" type="concept"  (or task, reference, or topic)
href="myfile.xml#topicid/figid" type="fig"  (or table, fn, or
  section)
href="mything.pdf" format="pdf"
 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
type Indicates the location of the source of the quote. Allowable values are:
external
the href is to a Web site
internal
the href is to a DITA topic
bibliographic
the href is to a specialized bibliographic topic. Currently not supported in DITA.
 (external | internal | bibliographic) #IMPLIED boolean: no
reftitle | The title of the document or topic being quoted. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>This is the first line of the address that
Abraham Lincoln delivered on November 19, 1863 for the dedication
of the cemetery at Gettysburg, Pennsylvania.</p>
<lq>Four score and seven years ago our fathers brought forth on this continent a new
nation, conceived in liberty, and dedicated to the proposition that all men
are created equal.</lq>


note

A <note> element contains information, differentiated from the main text, which expands on or calls attention to a particular point.

Tip: Variant types of note (tip, caution, danger, restriction, etc.) can be indicated through values selected on the type attribute. This note is typed as a "tip."

Contained by

body , section , example , desc , p , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
type Defines the type of a note. For example, if the note is a tip, the word Tip is used to draw the reader's attention to it. If type is set to other, the value of the othertype attribute is used. If you use othertype, there needs to be a stylesheet or transform override that does something with the information, or it will be ignored. Allowable values for the type attribute are:
note
This is just a note.
attention
Please pay extra attention to this note.
caution
Care is required when proceeding. For example:
<note type="caution">Contents may be erased.</note>
produces:

Caution: You may reformat your hard drive.

danger
Important! Be aware of this before doing anything else. For example:
<note type="danger">You may hurt yourself!</note>
produces:

Danger: You may hurt yourself!

fastpath
This note will speed you on your way.
important
This note is important.
remember
Don't forget to do what this note says.
restriction
You can't do what this note says.
tip
This is a fine little tip.
other
This is something other than a normal note.
 (note | tip | fastpath | restriction | important | remember | attention | caution | danger | other) "note" boolean: no
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
othertype | Indicates an alternate note type, when the type is not available in the type attribute value list. This value is used as the user-provided note title when the type attribute value is set to "other." | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This example:
<note type="tip">Thinking of a seashore, green meadow, or cool
mountain overlook can help you to relax and be more
patient.</note>
produces this result:

Tip: Thinking of a seashore, green meadow, or cool mountain overlook can help you to relax and be more patient.


object

DITA's <object> element corresponds to the HTML <object> element. The <object> element allows authors to include animated images, applets, plug-ins, ActiveX controls, video clips, and other multimedia objects in a topic for rendering after transformation to HTML.

Contained by

body , section , example , p , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , pd

Contains

( desc ) (optional) then ( param ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
declare | When this attribute is set to declare, the current object definition is a declaration only. The object must be instantiated by a later nested object definition referring to this declaration. |  |  | boolean: no
classid | Contains a URL that specifies the location of an object's implementation. It can be used together with the data attribute which is specified relative to the value of the codebase attribute. | CDATA | #IMPLIED | boolean: no
codebase | Specifies the base path (a URL) used for resolving the URL values given for classid, data, and archive attributes. If codebase is not set, the default is the base URL of the current document. | CDATA | #IMPLIED | boolean: no
data | Contains a reference to the location of an object's data. If this attribute is a URL, it is specified relative to the value of the codebase attribute. If this attribute is set, the type attribute should also be set. | CDATA | #IMPLIED | boolean: no
type | Indicates the content type for the data specified by the data attribute. This attribute should be set when the data attribute is set to avoid loading unsupported content types. | CDATA | #IMPLIED (No default type) | boolean: no
codetype | Indicates the content type for the data specified by the classid attribute. This attribute should be set when the classid attribute is set to avoid loading unsupported content types. If this attribute value is not set, the default is the value of the type attribute. | CDATA | #IMPLIED | boolean: no
archive | Specifies a space-separated list of URLs indicating resources needed by the object. These resources may include those URLs specified by the classid and data attributes. Preloading these resources usually results in faster loadtimes for objects. The URLs in the list should be relative to the URL specified in the codebase attribute. | CDATA | #IMPLIED | boolean: no
standby | Contains a message to be displayed while an object is loading. | CDATA | #IMPLIED | boolean: no
height | Indicates the maximum height of an image. | NMTOKEN | #IMPLIED | boolean: no
width | Indicates the maximum width of an image. | NMTOKEN | #IMPLIED | boolean: no
usemap | Indicates that a client-side image map is to be used. An image map specifies active geometric regions of an included object and assigns a link to each region. When a link is selected, a document may be retrieved or a program may run on the server. | CDATA | #IMPLIED | boolean: no
name | Submit the object as part of a form. | CDATA | #REQUIRED | boolean: yes
tabindex | Position the object in tabbing order. | NMTOKEN | #IMPLIED | boolean: no
longdescref | A reference to a textual description of the graphic. This attribute supports creating accessible content. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Output processors may need to modify data to enable compatible function across various browsers, so these examples are only representative:
<p>Cutting the keys from the system unit:</p>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=6,0,0,0"
 data="cutkey370.swf"
 type="application/x-shockwave-flash"
 height="280"
 width="370"
 id="cutkey370">
 <desc>A description of the task</desc>
 <param name="movie" value="cutkey370.swf"/>
 <param name="quality" value="high"/>
 <param name="bgcolor" value="#FFFFFF"/>
</object>

<p>What's EIM?</p>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=6,0,0,0"
 data="eim.swf"
 height="400"
 width="500"
 id="eim">
 <desc>Some great, glorious info</desc>
 <param name="movie" value="eim.swf"/>
 <param name="quality" value="high"/>
 <param name="bgcolor" value="#FFFFFF"/>
 <param name="pluginspace"
 value="http://www.macromedia.com/go/getflashplayer"/>
</object>


ol

An ordered list (<ol>) is a list of items sorted by sequence or order of importance.

Contained by

body , section , example , desc , p , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

li

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
 (yes | no) "yes" boolean: no
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Here are the colors of the rainbow in order of appearance from top to bottom:
<ol>
<li>Red</li>
<li>Orange</li>
<li>Yellow</li>
<li>Green</li>
<li>Blue</li>
<li>Indigo</li>
<li>Violet</li>
</ol>


p

A paragraph element (<p>) is a block of text containing a single main idea.

Contained by

body , section , example , desc , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>
It is probable that <q>temporary</q> or <q>new</q> stars, as these
wonderful apparitions are called, really are <term>conflagrations</term>;
not in the sense of a bonfire or a burning house or city, but in that of
a sudden eruption of <i>inconceivable</i> heat and light, such as would
result from the stripping off the shell of an encrusted sun or the crashing
together of two mighty orbs flying through space with a hundred times
the velocity of the swiftest cannon-shot.</p>


param

The parameter (<param>)element specifies a set of values that may be required by an <object> at runtime. Any number of <param> elements may appear in the content of an object in any order, but must be placed at the start of the content of the enclosing object. This element is comparable to the XHMTL <param> element.

Contained by

object

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
name | Submit the object as part of a form. | CDATA | #REQUIRED | boolean: yes
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
value | Specifies the value of a run-time parameter specified by the name attribute. | CDATA | #IMPLIED | boolean: no
valuetype | Specifies the type of the value attribute. Allowed values are: data, ref or object. A value of data means that the value will be evaluated and passed to the object's implementation as a string. A value of ref indicates that the value of valuetype is a URL that designates a resource where run-time values are stored. This allows support tools to identify URLs that are given as parameters. A value of object indicates that the value of valuetype is an identifier that refers to an object declaration in the document. The identifier must be the value of the ID attribute set for the declared object element. | CDATA | #IMPLIED | boolean: no
type | This attribute specifies the content type of the resource designated by the value attribute only in the case where valuetype is set to "ref". This attribute thus specifies for the user agent, the type of values that will be found at the URI designated by value. | CDATA | #IMPLIED (No default type) |
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Output processors may need to modify data to enable compatible function across various browsers, so these examples are only representative:
<p>Cutting the keys from the system unit:</p>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=6,0,0,0"
 data="cutkey370.swf"
 type="application/x-shockwave-flash"
 height="280"
 width="370"
 id="cutkey370">
 <desc>A description of the task</desc>
 <param name="movie" value="cutkey370.swf"/>
 <param name="quality" value="high"/>
 <param name="bgcolor" value="#FFFFFF"/>
</object>

<p>What's EIM?</p>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=6,0,0,0"
 data="eim.swf"
 height="400"
 width="500"
 id="eim">
 <desc>Some great, glorious info</desc>
 <param name="movie" value="eim.swf"/>
 <param name="quality" value="high"/>
 <param name="bgcolor" value="#FFFFFF"/>
 <param name="pluginspace"
 value="http://www.macromedia.com/go/getflashplayer"/>
</object>


ph

The phrase (<ph>) element is used to organize content for reuse or conditional processing (for example, when part of a paragraph applies to a particular audience). It can be used by future specializations of DITA to apply specific processing or formatting to marked up phrases.

Contained by

title , shortdesc , section , example , desc , p , note , lq , q , sli , li , itemgroup , dthd , ddhd , dt , dd , figgroup , pre , lines , ph , stentry , draft-comment , fn , cite , xref , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , fragref , synnote

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or image or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This was not changed. <ph rev="v5r2">This was updated.</ph> This was not.


pre

The preformatted element (<pre>) preserves line breaks and spaces entered manually by the author in the content of the element, and also presents the content in a monospaced type font (depending on your output formatting processor).

Contained by

body , section , example , desc , p , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:space | This attribute is provided on <pre>, <lines>, and on elements derived from them. It ensures that parsers in editors and transforms respect the line-end characters that are part of the data in those elements. It is intended to be part of the default properties of these elements, and not for authors to change or delete. | (preserve) | #FIXED 'preserve' | boolean: yes
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

MEMO: programming team fun day
Remember to bring a kite, softball glove, or other favorite
outdoor accessory to tomorrow's fun day outing at Zilker Park.
Volunteers needed for the dunking booth.


q

A quotation element (<q>) indicates content quoted from another source. This element is used for short quotes which are displayed inline. Use the long quote element (<lq>) for quotations that should be set off from the surrounding text.

Contained by

title , shortdesc , section , example , desc , p , note , lq , q , sli , li , itemgroup , dthd , ddhd , dt , dd , pre , lines , ph , stentry , draft-comment , fn , cite , xref , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , fragref , synnote

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

George said, <q>Disengage the power supply before servicing the unit.</q>


sl

The <sl> element contains a simple list of items of short, phrase-like content, such as in documenting the materials in a kit or package.

Contained by

body , section , example , desc , p , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

sli

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
 (yes | no) "yes" boolean: no
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In a reference topic discussing related modules, the following sample markup could be used:
<section><title>Messages</title>
 <p>Messages from the ags_open module are identical with messages from:</p>
 <sl>
  <sli>ags_read</sli>
  <sli>ags_write</sli>
  <sli>ags_close</sli>
 </sl>
</section>


sli

A simple list item (<sli>) is a single item in a simple list<sl>. Simple list items have phrase or text content, adequate for describing package contents, for example. When a DITA topic is formatted for output, the items of a simple list are placed each on its own line, with no other prefix such as a number (as in an ordered list) or bullet (as in an unordered list)..

Contained by

sl

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or image or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>Package contents:
 <sl>
  <sli>three french hens</sli>
  <sli>two turtledoves</sli>
  <sli>a partridge in a pear tree</sli>
 </sl>
</p>


ul

In an unordered list (<ul>), the order of the list items is not significant. List items are typically styled on output with a "bullet" character, depending on nesting level.

Contained by

body , section , example , desc , p , note , lq , li , itemgroup , dd , fig , stentry , draft-comment , fn , linkinfo , entry , conbody , prereq , context , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , propdesc , pd

Contains

li

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
 (yes | no) "yes" boolean: no
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<ul>
 <li>This is an item in an unordered list.</li>
 <li>To separate it from other items in the list, the
 formatter puts a bullet beside it.</li>
 <li>The following paragraph, contained in the list item
 element, is part of the list item which contains it.
 <p>This is the contained paragraph.</p></li>
 <li>This is the last list item in our unordered list.</li>
</ul>


xref

Use the cross-reference (<xref>) element to link to a different location within the current topic, or a different topic within the same help system or DITA document. You can also point to external sources, such as Web pages, or to a location in another topic as well. The href attribute on the <xref> element is used to create the link pointer, or URL.

Typically it is best to restrict yourself to linking to reference topics where the content of the target is clear from the <xref>'s text, for example API names and their descriptions. With other information types, it may be less clear to the user whether they should follow the link, and often they will, thereby missing important information in following paragraphs. Therefore it is a good idea to use related-links wherever possible.

Contained by

section , example , desc , p , note , lq , q , sli , li , itemgroup , dt , dd , figgroup , pre , lines , ph , stentry , draft-comment , fn , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , synnote

Contains

text data or ph or term or q or boolean or state or keyword or tm or image

Attributes

Name | Description | Data Type | Default Value | Required?
href A hyperlink to an external Web page (URL) or to another topic in the same file or in another file. The href attribute identifies the destination of the cross-reference link using conventional URL syntax:
href="http://www.xxx.com" format="html"
href="myfile.xml" type="concept"
   (or task, reference, or topic)
href="myfile.xml#topicid/figid" type="fig"
   (or table, fn, or section)
href="mything.pdf" format="pdf"

If the URL contains an ampersand character, the ampersand symbol (&amp;) should be used to indicate that character

 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
type Describes the target of a cross-reference and may generate cross-reference text based on that description.

Allowed values are:

fig
Indicates a link to a figure.
table
Indicates a link to a table.
li
Indicates a link to an ordered list item.
fn
Indicates a link to a footnote.
section
"section" indicates a link to a section.
concept, task, reference, topic
Cross-reference to a topic type.
other
Indicates a cross-reference to an alternate topic information type (currently unsupported).

Note: Valid types for <link> include topic, concept, task, and reference. Valid types for <xref> also include fig, figgroup, table, li, fn, and section.

Note: The values external and local are deprecated for this attribute, and will be removed in later versions of the DTDs. Use the scope attribute instead to specify these linking semantics.

 CDATA #IMPLIED (Processed as if the target were of type "topic.") boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
format The format attribute identifies the format of the resource being cross referenced. The default format is dita.

Allowable values are:

dita
The format of the linked-to resource is native DITA. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
(no value)
Defaults to "dita"
(for anything else)
Use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value)
 CDATA #IMPLIED boolean: no
scope | The scope attribute identifies the closeness of the relationship between the current topic and the target resource. Set scope to local when the resource is part of the current set of content, and should be accessed and copied to the output directory. Set scope to peer when the resource is part of the current set of content but is not accessible at build time. Set scope to external when the resource is not part of the current information set and should open in a new browser window. The default is local. | (local | peer | external) | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Here's an example of a cross-reference to another topic; that topic's title will be used as the link text.

<p>Background information about DITA is provided in the section titled
<xref href="whatsdita.xml#tmmdita"></xref>.</p>

Here's an example of a cross-reference to another topic; the supplied text will be used as the link text

<p><xref href="whatsdita.xml#tmmdita">Background information about DITA</xref> is provided
free of charge.</p>
If you are linking to anything within a topic, you should use the following format in the href attribute:
filename.xml#topicid/elementid
If you are linking within the same file, you can leave off the "filename.xml" part. So, for a section with the ID "mysection", you should use:
#topicid/mysection
For a list item within that section, assuming the item has an ID of "mylist", use
#topicid/mylist

Regardless of how deeply the target element is nested, the only important pieces are the ID of the containing topic, and the ID of the target element. IDs in DITA need not be unique within a file, but they must be unique within a topic, so you need to be sure that the topic ID is part of your reference.

If your URL has an ampersand in it; you need to code that using the symbol. For example; for this URL:
http://www.ibm.com/docview.wss?rs=757&context=SSVNX5
You need to enter the &amp; in the Href attribute as follows:
<xref href="http://www.ibm.com/docview.wss?rs=757&amp;context=SSVNX5">
Part number SSVNX5</xref>


Table elements

DITA topics support two types of tables. One is the most common table format used in industry, the <CALS table> (or more recently known also as the Oasis Table Exchange Model). The CALS table supports the spanning of multiple rows or columns for special layout or organizational needs, and provides a wide variety of controls over the display properties of the data and even the table structure itself.

The other table structure in DITA is called <simpletable>. As the name implies, it is structurally less sophisticated than the CALS table, and can be used as a very simple, regular table for which close control of formatting is not as important. However, the main advantage of simpletable is for describing lists of data with regular headings, such as telephone directory listings, display adapter configuration data, or API properties. If you have ever needed a "three-part definition list," simpletable is used for that purpose.

Upon output, the CALS table is often fully reproduced using presentation hints contained in the markup itself (such as specific column widths or span controls). The simpletable has a similar, table-like output, but it is more adaptable for dynamic, in-browser data viewports that show one set (row or column) of information at a time, with controls for "paging" through the data.


table

The <table> element organizes arbitrarily complex relationships of tabular information. This standard table markup allows column or row spanning and table captions or descriptions. A optional title allowed inside the table element provides a caption to describe the table. See simpletable for a simplified table model that can be specialized to represent more regular relationships of data.

Contained by

body , section , example , p , note , lq , li , itemgroup , dd , draft-comment , conbody , prereq , context , info , tutorialinfo , stepxmp , stepresult , result , postreq , refbody , refsyn , pd

Contains

( ( title ) (optional) then ( desc ) (optional) ) (optional) then ( tgroup ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
rowsep | Row separator. A value of 0 indiates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
rowheader This attribute specifies whether the content of the first column in a table contains row headings. In the same way that a column header introduces a table column, the row header introduces the table row. This attribute makes tables whose first column contains row headings more readable on output. Allowable values are:
firstcol
The first column contains the row headings.
norowheader
Indicates that no column contains row headings. This is the default.
 (firstCol | norowheader) #IMPLIED boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Animal | Gestation Period
Elephant (African and Asian) | 19-22 months
Giraffe | 15 months
Rhinoceros | 14-16 months
Hippopotamus | 7 1/2 months

<table frame="all">
 <tgroup cols="2">
  <colspec colname="col1" colwidth="3*"/>
  <colspec colname="col2"colwidth="2*"/>
  <thead>
   <row>
    <entry valign="top">Animal</entry>
    <entry valign="top">Gestation Period</entry>
   </row>
  </thead>
  <tbody>
   <row>
    <entry colname="col1">Elephant (African and Asian)</entry>
    <entry colname="col2">19-22 months</entry>
   </row>
   <row>
    <entry colname="col1">Giraffe</entry>
    <entry colname="col2">15 months</entry>
   </row>
   <row>
    <entry colname="col1">Rhinoceros</entry>
    <entry colname="col2">14-16 months</entry>
   </row>
   <row>
    <entry colname="col1">Hippopotamus</entry>
    <entry colname="col2">7 1/2 months</entry>
   </row>
  </tbody>
 </tgroup>
</table>


tgroup

The <tgroup> element in a table contains column, row, spanning, header and footer specifications, and the body (<tbody>) of the table.

Contained by

table

Contains

( colspec ) (0 or more) then ( spanspec ) (0 or more) then ( thead ) (optional) then ( tfoot ) (optional) then tbody

Attributes

Name | Description | Data Type | Default Value | Required?
cols | Indicates the number of columns in a <tgroup> in a table. | NMTOKEN | #REQUIRED | boolean: no
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
rowsep | Row separator. A value of 0 indiates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
 (left | right | center | justify | char) #IMPLIED boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Animal | Gestation Period
Elephant (African and Asian) | 19-22 months
Giraffe | 15 months
Rhinoceros | 14-16 months
Hippopotamus | 7 1/2 months

<table frame="all">
 <tgroup cols="2">
  <colspec colname="col1" colwidth="3*"/>
  <colspec colname="col2"colwidth="2*"/>
  <thead>
   <row>
    <entry valign="top">Animal</entry>
    <entry valign="top">Gestation Period</entry>
   </row>
  </thead>
  <tbody>
   <row>
    <entry colname="col1">Elephant (African and Asian)</entry>
    <entry colname="col2">19-22 months</entry>
   </row>
   <row>
    <entry colname="col1">Giraffe</entry>
    <entry colname="col2">15 months</entry>
   </row>
   <row>
    <entry colname="col1">Rhinoceros</entry>
    <entry colname="col2">14-16 months</entry>
   </row>
   <row>
    <entry colname="col1">Hippopotamus</entry>
    <entry colname="col2">7 1/2 months</entry>
   </row>
  </tbody>
 </tgroup>
</table>


thead

The table header (<thead>) element precedes the table body (<tbody>) element in a complex table.

Contained by

tgroup

Contains

( colspec ) (0 or more) then ( row ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
 (top | bottom | middle) "top" boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The following example shows the desired effect and the code that produced the table header:
Animal | Gestation Period
Elephant (African and Asian) | 19-22 months
Giraffe | 15 months
Rhinoceros | 14-16 months
Hippopotamus | 7 1/2 months

<table frame="all">
 <tgroup cols="2">
  <colspec colname="col1" colwidth="3*"/>
  <colspec colname="col2"colwidth="2*"/>
  <thead>
   <row>
    <entry valign="top">Animal</entry>
    <entry valign="top">Gestation Period</entry>
   </row>
  </thead>
  <tbody>
   <row>
    <entry colname="col1">Elephant (African and Asian)</entry>
    <entry colname="col2">19-22 months</entry>
   </row>
   <row>
    <entry colname="col1">Giraffe</entry>
    <entry colname="col2">15 months</entry>
   </row>
   <row>
    <entry colname="col1">Rhinoceros</entry>
    <entry colname="col2">14-16 months</entry>
   </row>
   <row>
    <entry colname="col1">Hippopotamus</entry>
    <entry colname="col2">7 1/2 months</entry>
   </row>
  </tbody>
 </tgroup>
</table>


tfoot

The table footer (<tfoot>) element precedes the table body (<tbody>) element in a complex table.

Contained by

tgroup

Contains

( colspec ) (0 or more) then ( row ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
 (top | bottom | middle) "top" boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example


spanspec

A span specification (<spanspec>) in a table column or row specifies how two or more cells are to be combined.

Note: Typically, XML editors should manage this attribute for you in a graphical table environment.

Contained by

tgroup

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
namest | Specifies the first logical column that is included in a horizontal span. | NMTOKEN | #IMPLIED | boolean: no
nameend | Specifies the last logical column that is included in a horizontal span. | NMTOKEN | #IMPLIED | boolean: no
spanname | Indicates the name and definition of a horizontal span. | NMTOKEN | #IMPLIED | boolean: no
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
 (left | right | center | justify | char) #IMPLIED boolean: no
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
rowsep | Row separator. A value of 0 indiates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example


stentry

The simpletable entry (<stentry>) element represents a single table cell, like <entry> in <table>. You can place any number of stentry cells in either an sthead element (for headings) or strow element (for rows of data).

Contained by

sthead , strow

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
specentry | The specialized entry attribute allows architects of specialized DTDs to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<simpletable>
. . . .
 <strow>
  <stentry>Bold</stentry>
  <stentry>b</stentry>
 </strow>
. . .
</simpletable>


colspec

The <colspec> element contains a column specification for a table, including assigning a column name and number, cell content alignment, and column width.

Contained by

tgroup , thead , tfoot

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
colnum | Indicates the number of a column in the table, counting from the first logical column to the last column. | NMTOKEN | #IMPLIED | boolean: no
colname | Specifies the table column name in which an entry is found. | NMTOKEN | #IMPLIED | boolean: no
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
 (left | right | center | justify | char) #IMPLIED boolean: no
colwidth | Describes the column width. | CDATA | #IMPLIED | boolean: no
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
rowsep | Row separator. A value of 0 indiates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Tagging for this table is shown below.
Animal | Gestation
Elephant (African and Asian) | 19-22 months
Giraffe | 15 months
Rhinoceros | 14-16 months
Hippopotamus | 7 1/2 months

<table>
<tgroup cols="2">
<colspec colname="COLSPEC0" colwidth="121*"/>

            <colspec colname="COLSPEC1" colwidth="76*"/>
<thead>
<row>
<entry colname="COLSPEC0" valign="top">Animal</entry>
<entry colname="COLSPEC1" valign="top">Gestation</entry>
</row>
</thead>
<tbody>
<row>
<entry>Elephant (African and Asian)</entry>
<entry>19-22 months</entry>
</row>
<row>
<entry>Giraffe</entry>
<entry>15 months</entry>
</row>
<row>
<entry>Rhinoceros</entry>
<entry>14-16 months</entry>
</row>
<row>
<entry>Hippopotamus</entry>
<entry>7 1/2 months</entry>
</row>
</tbody>
</tgroup>
</table>


tbody

The <tbody> element contains the rows in a table.

Contained by

tgroup

Contains

row

Attributes

Name | Description | Data Type | Default Value | Required?
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
 (top | bottom | middle) "top" boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example


row

The <row> element contains a single row in a table <tgroup>.

Contained by

thead , tfoot , tbody

Contains

entry

Attributes

Name | Description | Data Type | Default Value | Required?
rowsep | Row separator. A value of 0 indiates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
 (top | bottom | middle) "top" boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<table>
 <tgroup cols="2">
  <colspec colnum="1" colname="col1" colwidth="100*"/>
  <colspec colnum="2" colname="col2" colwidth="100*"/>
  <thead>
   <row>
    <entry colname="col1">Type style</entry>
    <entry colname="col2">Elements used</entry>
   </row>
  </thead>
  <tbody>
   <row>
    <entry colname="col1">Bold</entry>
    <entry colname="col2">b</entry>
   </row>
   <row>
    <entry colname="col1">Italic</entry>
    <entry colname="col2">i</entry>
   </row>
   <row>
    <entry colname="col1">Underlined</entry>
    <entry colname="col2">u</entry>
   </row>
  </tbody>
 </tgroup>
</table


entry

The <entry> element defines a single cell in a table.

Contained by

row

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
colnum | Indicates the number of a column in the table, counting from the first logical column to the last column. | NMTOKEN | #IMPLIED | boolean: no
colname | Specifies the table column name in which an entry is found. | NMTOKEN | #IMPLIED | boolean: no
namest | Specifies the first logical column that is included in a horizontal span. | NMTOKEN | #IMPLIED | boolean: no
nameend | Specifies the last logical column that is included in a horizontal span. | NMTOKEN | #IMPLIED | boolean: no
spanname | Indicates the name and definition of a horizontal span. | NMTOKEN | #IMPLIED | boolean: no
morerows | Specifies the number of additional rows to add in a vertical span. | NMTOKEN | "0" | boolean: no
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
rowsep | Row separator. A value of 0 indiates no separators; 1 indicates separators. | NMTOKEN | "0" | boolean: no
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
 (top | bottom | middle) "top" boolean: no
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
 (left | right | center | justify | char) #IMPLIED boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The tagging for the following table is shown below:
Asian elephant | Elephas maximus
African elephant (savannah) | Loxodonta africana africana
African elephant (forest) | Loxodonta africana cyclotis

<table>
<tgroup cols="2"><colspec colname="col1"/><colspec colname="col2"/>
<tbody>
<row><entry colname="col1">Asian elephant</entry>
<entry colname="col2"><i>Elephas maximus</i></entry> </row>
<row><entry colname="col1">African elephant (savannah)</entry>
<entry colname="col2"><i>Loxodonta africana africana</i></entry></row>
<row> <entry colname="col1">African elephant (forest)</entry>
<entry colname="col2"><i>Loxodonta africana cyclotis</i></entry>
</row> </tbody> </tgroup> </table>


simpletable

The <simpletable> element is used for tables that are regular in structure and do not need a caption. Choose the simple table element when you want to show information in regular rows and columns. For example, multi-column tabular data such as phone directory listings or parts lists are good candidates for simpletable. Another good use of simpletable is for information that seems to beg for a "three-part definition list"—just use the keycol attribute to indicate which column represents the "key" or term-like column of your structure.

DITA insight: This close match of simpletable to tabular, regular data makes simpletable suitable as the basis for specialized structures such as properties (for programming information) and choice tables (for tasks).

Contained by

body , section , example , p , note , lq , li , itemgroup , dd , fig , draft-comment , conbody , prereq , context , info , tutorialinfo , stepxmp , stepresult , result , postreq , refbody , refsyn , pd

Contains

( sthead ) (optional) then ( strow ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
relcolwidth A relative value to specify the width of a column in relationship to the width of the other columns for print output. The values are totaled and made a percent. For example:
relcolwidth="1* 2* 3*"
causes widths of 16.7%, 33.3%, and 66.7%.
relcolwidth="90* 150*"
causes width of 37.5% and 62.5%. 		CDATA #IMPLIED boolean: no
keycol | Defines the column that will be used for row headings. No value indicates no key column. When present, the numerical value causes the specified column to be highlighted as a vertical header. | NMTOKEN | #IMPLIED | boolean: no
refcols | Designates columns that contain references, and are candidates for automated linking (not currently supported). Columns are identified by a comma-delimited list of numbers (for example: 1,3). | NMTOKENS | #IMPLIED | boolean: no
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Create this table using the markup example that follows:
Type style | Elements used
Bold | b
Italic | i
Underlined | u
<simpletable>
 <sthead>
  <stentry>Type style</stentry>
  <stentry>Elements used</stentry>
 </sthead>
 <strow>
  <stentry>Bold</stentry>
  <stentry>b</stentry>
 </strow>
 <strow>
  <stentry>Italic</stentry>
  <stentry>i</stentry>
 </strow>
 <strow>
  <stentry>Underlined</stentry>
  <stentry>u</stentry>
 </strow>
</simpletable>


sthead

The simpletable header (<sthead>) element contains the table's header row. The header row is optional in a simple table.

Contained by

simpletable

Contains

stentry

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<simpletable>
 <sthead>
  <stentry>Type style</stentry>
  <stentry>Elements used</stentry>
 </sthead>
 . . .
</simpletable>


strow

The <simpletable> row (<strow>) element specifies a row in a simple table, like row in a conventional table .

Contained by

simpletable

Contains

stentry

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<simpletable id="s1">
 <sthead>
  <stentry>hi</stentry>
  <stentry>there</stentry>
 </sthead>
 <strow>
  <stentry>how</stentry>
  <stentry>are</stentry>
  <stentry>you?</stentry>
 </strow>
</simpletable>


Domain elements

The base release of the DITA authoring DTDs includes specialized content elements from four particular subject domains:

  1. programming related terms and structures
  2. software related terms and structures
  3. user interface related terms and structures
  4. common word-processor like capabilities (to support the correct typographic convention for as-yet-unintroduced domain vocabulary)


Typographic elements

The typographic elements are used to highlight text with styles (such as bold, italic, and monospace).


b

The bold (<b>) element is used to apply bold highlighting to the content of the element. Use this element only when there is not some other more proper tag. For example, for specific items such as GUI controls, use the uicontrol tag. This element is part of the DITA highlighting domain.

Contained by

All contexts where ph is valid.

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p><b>STOP!</b> This is <b>very</b> important!</p>


i

The italic (<i>) element is used to apply italic highlighting to the content of the element. Use this element only when there is not some other more proper tag. For example, for specific items such as GUI controls, use the uicontrol tag. Italic highlighting generally means a font that is slanted for emphasis, but this may vary depending on your output formatting process. This element is part of the DITA highlighting domain.

Contained by

All contexts where ph is valid.

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>Unplug the unit <i>before</i> placing the metal screwdriver
against the terminal screw.</p>


u

The underline (<u>) element is used to apply underline highlighting to the content of the element. Use this element only when there is not some other more proper tag. For example, for specific items such as GUI controls, use the uicontrol tag. This element is part of the DITA highlighting domain.

Contained by

All contexts where ph is valid.

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Beware: <u>overuse</u> <i>of</i> <b>highlighting</b> is
sometimes known as font-itis!


tt

The teletype (<tt>) element is used to apply monospaced highlighting to the content of the element. Use this element only when there is not some other more proper tag. For example, for specific items such as GUI controls, use the uicontrol tag. This element is part of the DITA highlighting domain.

Contained by

All contexts where ph is valid.

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>Make sure that the screen displays <tt>File successfully created</tt> before
proceeding to the next stage of the task.</p>
(Tag purists may delight to point out that this example could be more correctly marked with the msgph element.)


sup

The superscript (<sup>) element indicates that text should be superscripted, or vertically raised in relationship to the surrounding text. Superscripts are usually a smaller font than the surrounding text. Use this element only when there is not some other more proper tag. For example, for specific items such as GUI controls, use the uicontrol tag. This element is part of the DITA highlighting domain.

Contained by

Most contexts that allow phrases.

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The power produced by the electrohydraulic dam was 10<sup>10</sup> more than
the older electric plant.  The difference was H<sub>2</sub>O.


sub

A subscript (<sub>) indicates that text should be subscripted, or placed lower in relationship to the surrounding text. Subscripted text is often a smaller font than the surrounding text. Formatting may vary depending on your output process. This element is part of the DITA highlighting domain.

Contained by

Most contexts that allow phrases.

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The power produced by the electrohydraulic dam was 10<sup>10</sup> more than
the older electric plant.  The difference was H<sub>2</sub>O.


Programming elements

The programming domains elements are used to define the syntax and to give examples of programming languages.


codeph

The code phrase (<codeph>) element represents a snippet of code within the main flow of text. The code phrase may be displayed in a monospaced font for emphasis. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph; the same contexts as ph

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>The second line of the sample program code, <codeph>Do forever</codeph>,
represents the start of a loop construct.</p>


codeblock

The <codeblock> element represents lines of program code. Like the <pre> element, content of this element has preserved line endings and is output in a monospaced font. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

The same contexts as pre

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:space | This attribute is provided on <pre>, <lines>, and on elements derived from them. It ensures that parsers in editors and transforms respect the line-end characters that are part of the data in those elements. It is intended to be part of the default properties of these elements, and not for authors to change or delete. | (preserve) | #FIXED 'preserve' | boolean: yes
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<codeblock>
/* a long sample program */
Do forever
  Say "Hello, World"
End
</codeblock>


option

The <option> element describes an option that can be used to modify a command (or something else, like a configuration). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph; the same contexts as keyword

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

something <option>/modifier</option>


kwd

The <kwd> element defines a keyword in a syntax definition. A keyword must be typed or output, either by the user or application, exactly as specified in the syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph , groupseq , groupchoice , groupcomp

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to associate the <kwd> with another topic that provides more details for that particular keyword. | NMTOKEN | #IMPLIED | boolean: no
importance | The attribute indicates whether a variable is optional, required, or default. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | default | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>


var

Within a syntax definition, the <var> element defines a variable for which the user must supply content, such as their user name or password. It is represented in output in an italic font. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph , groupseq , groupchoice , groupcomp

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether a variable is optional, required, or default. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | default | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>


parmname

When referencing the name of an application programming interface parameter within the text flow of your topic, use the parameter name (<parmname>) element to markup the parameter. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph; the same contexts as keyword

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Use <cmdname>config</cmdname> to update the <parmname>/env</parmname>
 field value.


synph

The syntax phrase (<synph>) element is a container for syntax definition elements. It is used when a complete syntax definition is not needed, but some of the syntax elements, such as kwd, oper, delim, are used within the text flow of the topic content. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph; the same contexts as ph

Contains

text data or codeph or option or parmname or var or kwd or oper or delim or sep or synph

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

            <synph><kwd>format</kwd> <var>volumename</var></synph>


oper

The operator (<oper>) element defines an operator within a syntax definition. Typical operators are equals (=), plus (+) or multiply (*). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph , groupseq , groupchoice , groupcomp

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether a variable is optional, required, or default. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | default | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram>
  <title>Adding</title>
  <groupseq><kwd>1</kwd><oper>+</oper><var>two</var>
<delim>=</delim><kwd>something</kwd>
  </groupseq>
</syntaxdiagram>


delim

Within a syntax definition, the delimiter (<delim>) element defines a character marking the beginning or end of a section or part of the complete syntax. Typical delimiter characters are the parenthesis, comma, tab, vertical bar or other special characters. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph , groupseq , groupchoice , groupcomp

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether the element it modifies is optional or required. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram>
 <title>Adding</title>
 <groupseq><kwd>1</kwd><oper>+</oper><var>two</var><delim>=</delim>
 <kwd>something</kwd>
</groupseq>
</syntaxdiagram>


sep

The separator (<sep>) element defines a separator character that is inline with the content of a syntax definition. The separator occurs between keywords, operators or groups in a syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

synph , groupseq , groupchoice , groupcomp

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether the element it modifies is optional or required. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram>
 <title>Adding</title>
 <groupseq><kwd>1</kwd><oper>+</oper><sep>(</sep><var>two</var><sep>)</sep>
<delim>=</delim><kwd>something</kwd></groupseq>
</syntaxdiagram>


apiname

The <apiname> element provides the name of an application programming interface (API) such as a Java class name or method name. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

The same contexts as keyword

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>Use the <apiname>document.write</apiname> method to create text
output in the dynamically constructed view.</p>


parml

The parameter list (<parml>) element contains a list of terms and definitions that describes the parameters in an application programming interface. This is a special kind of definition list that is designed for computer parameters. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

The same contexts as dl

Contains

plentry

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
 (yes | no) "yes" boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

            <parml>
 <plentry>
  <pt><synph><kwd>from</kwd><delim> </delim><var>this</var></synph></pt>
  <pd>copy from somewhere</pd>
 </plentry>
 <plentry>
  <pt><synph><kwd>to</kwd><delim> </delim><var>that</var></synph></pt>
  <pd>to somewhere else</pd>
 </plentry>
</parml>


plentry

The parameter list entry element (<plentry>) contains one or more parameter terms and definitions (pd and pt). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

parml

Contains

( pt ) (one or more) then ( pd ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Markup Example

Markup ExampleThis code example is a basic method signature:
returnType methodName(pList1, pList2) {
where
pList1
is the first variable declaration passed to methodName
pList2
is the second variable declaration passed to methodName
Markup Equivalent
This code example is a basic method signature:
<codeblock>returnType methodName(pList1, pList2) {</codeblock>
where
<parml>
 <plentry>
  <pt>pList1</pt>
  <pd>is the first variable declaration passed to methodName</pd>
 </plentry>
   <plentry>
  <pt>pList2</pt>
  <pd>is the second variable declaration passed to methodName</pd>
 </plentry>
</parml>


pt

A parameter term, within a parameter list entry, is enclosed by the <pt> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

plentry

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or image

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Markup Example

Markup ExampleThis code example is a basic method signature:
returnType methodName(pList1, pList2) {
where
pList1
is the first variable declaration passed to methodName
pList2
is the second variable declaration passed to methodName
Markup Equivalent
This code example is a basic method signature:
<codeblock>returnType methodName(pList1, pList2) {</codeblock>
where
<parml>
 <plentry>
  <pt>pList1</pt>
  <pd>is the first variable declaration passed to methodName</pd>
 </plentry>
 <plentry>
  <pt>pList2</pt>
  <pd>is the second variable declaration passed to methodName</pd>
 </plentry>
</parml>


pd

A parameter definition, within a parameter list entry, is enclosed by the <pd> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

plentry

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or itemgroup or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Markup Example

Markup ExampleThis code example is a basic method signature:
returnType methodName(pList1, pList2) {
where
pList1
is the first variable declaration passed to methodName
pList2
is the second variable declaration passed to methodName
Markup Equivalent
This code example is a basic method signature:
<codeblock>returnType methodName(pList1, pList2) {</codeblock>
where
<parml>
 <plentry>
  <pt>pList1</pt>
  <pd>is the first variable declaration passed to methodName</pd>
 </plentry>
 <plentry>
  <pt>pList2</pt>
  <pd>is the second variable declaration passed to methodName</pd>
 </plentry>
</parml>


syntaxdiagram

The syntax diagram (<syntaxdiagram>) element is the main container for all the syntax elements that make up a syntax definition. The syntax diagram represents the syntax of a statement from a computer language, or a command, function call or programming language statement. Traditionally, the syntax diagram is formatted with "railroad tracks" that connect the units of the syntax together, but this presentation may differ depending on the output media. The syntax diagram element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

The same contexts as fig

Contains

( title ) (optional) then ( groupseq or groupchoice or groupcomp or fragref or fragment or synblk or synnote or synnoteref ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram>
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice> <var>input-filename</var> <kwd>*INFILE</kwd></groupchoice>
 <groupchoice> <var>output-filename</var> <kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>


synblk

The syntax block (<synblk>) element organizes small pieces of a syntax definition into a larger piece. The syntax block element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram

Contains

( title ) (optional) then ( groupseq or groupchoice or groupcomp or fragref or fragment or synnote or synnoteref ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

            <synblk>
<groupseq><kwd>this</kwd><sep>-</sep><kwd>is</kwd><sep>-</sep><kwd>a</kwd>
<sep>-</sep><var>test</var></groupseq>
</synblk>


groupseq

The <groupseq> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. Within the syntax definition, groups of keywords, delimiters and other syntax units act as a combined unit, and they occur in a specific sequence, as delimited by the <groupseq> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram , synblk , groupseq , groupchoice , groupcomp , fragment

Contains

( title ) (optional) then ( repsep ) (optional) then ( groupseq or groupchoice or groupcomp or fragref or kwd or var or delim or oper or sep or synnote or synnoteref ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether a variable is optional, required, or default. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | default | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>


groupchoice

The <groupchoice> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. A group choice specifies that the user must make a choice about which part of the syntax to use. Groups are often nested. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram , synblk , groupseq , groupchoice , groupcomp , fragment

Contains

( title ) (optional) then ( repsep ) (optional) then ( groupseq or groupchoice or groupcomp or fragref or kwd or var or delim or oper or sep or synnote or synnoteref ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether a variable is optional, required, or default. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | default | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>

            <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>


groupcomp

The <groupcomp> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. The group composite means that the items that make up the syntax diagram will be formatted close together rather than being separated by a horizontal or vertical line, which is the usual formatting method. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram , synblk , groupseq , groupchoice , groupcomp , fragment

Contains

( title ) (optional) then ( repsep ) (optional) then ( groupseq or groupchoice or groupcomp or fragref or kwd or var or delim or oper or sep or synnote or synnoteref ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether a variable is optional, required, or default. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | default | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>


fragment

Within a syntax definition, a <fragment> is a labeled subpart of the syntax. The <fragment> element allows breaking out logical chunks of a large syntax diagram into named fragments. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram , synblk

Contains

( title ) (optional) then ( groupseq or groupchoice or groupcomp or fragref or synnote or synnoteref ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<syntaxdiagram frame="none">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
 <fragment>
  <groupchoice><kwd>*OVERLAP</kwd><kwd>*Prompt</kwd></groupchoice>
 </fragment>
</syntaxdiagram>


fragref

The fragment reference (<fragref>) element provides a logical reference to a syntax definition fragment so that you can reference a syntax fragment multiple times. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram , synblk , groupseq , groupchoice , groupcomp , fragment

Contains

text data or ph or term or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
href A reference to a syntax diagram fragment element. The href attribute uses conventional URL syntax to point to the ID of the matching syntax diagram fragment:
href="#topicid/fragmentid"
 CDATA #IMPLIED boolean: no
importance | The attribute indicates whether the element it modifies is optional or required. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This markup example:
<syntaxdiagram frame="none">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <fragref href="#syntax/overlay"></fragref>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
 <fragment id="overlay">
  <title>Overlay</title>
  <groupchoice><kwd>*OVERLAP</kwd><kwd>*Prompt</kwd></groupchoice>
 </fragment>
</syntaxdiagram>
produces the following output:
CopyFile

>>-COPYF--input-filename*INFILE--output-filename--*OUTFILE------>

>--| Overlay |--+-input-filename-+--+-output-filename-+--------><
                '-*INFILE--------'  '-*OUTFILE--------'

Overlay

|--+-*OVERLAP-+-------------------------------------------------|
   '-*Prompt--'


synnote

The syntax note (<synnote>) element contains a note (similar to a footnote) within a syntax definition group or fragment. The syntax note explains aspects of the syntax that cannot be expressed in the markup itself. The note will appear at the bottom of the syntax diagram instead of at the bottom of the page. The syntax block element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram , synblk , groupseq , groupchoice , groupcomp , fragment

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm

Attributes

Name | Description | Data Type | Default Value | Required?
callout | Specifies what character is used for the footnote link, for example a number or an alpha character. Numbers are the default. You could also specify a graphic for the footnote callout during output processing. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<groupcomp><var>one</var><var>two</var><var>three</var></groupcomp>
<synnote>My first syntax note.</synnote>


synnoteref

The syntax note (<synnoteref>) reference element references a syntax note element (<synnote>) that has already been defined elsewhere in the topic. The same notation can be used in more than one syntax definition. The syntax note reference element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

syntaxdiagram , synblk , groupseq , groupchoice , groupcomp , fragment

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
href A hyperlink to an external Web page (URL) or to another topic in the same file or in another file. The href attribute identifies the destination of the cross-reference link using conventional URL syntax:
href="http://www.xxx.com" format="html"
href="myfile.xml" type="concept"
   (or task, reference, or topic)
href="myfile.xml#topicid/figid" type="fig"
   (or table, fn, or section)
href="mything.pdf" format="pdf"

If the URL contains an ampersand character, the ampersand symbol (&amp;) should be used to indicate that character

 CDATA #IMPLIED boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<synnoteref href="#syntaxdiagram/mysyn"/>


repsep

The repeat separator (<repsep>) element defines a group of syntax elements that can (or should) be repeated. If the <repsep> element contains a separator character, such as a plus (+), this indicates that the character must be used between repetitions of the syntax elements. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

groupseq , groupchoice , groupcomp

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether the element it modifies is optional or required. This is a property attribute which supports conditional processing for filtering or flagging. | optional | required | #IMPLIED | boolean: no
%univ-atts-no-importance | A set of related attributes, described at %univ-atts;, but without the importance attribute | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example


Software elements

The software domains elements are used to describe the operation of a software program.


msgph

The message phrase (<msgph>) element contains the text content of a message produced by an application or program. It can also contain the variable name (varname) element to illustrate where variable text content can occur in the message. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

Any context valid for ph

Contains

text data or varname or msgnum; the same contexts as ph

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>A server log entry of <msgnum>I:0</msgnum> is equivalent to the
text message, <msgph>informational: successful</msgph>.</p>


msgblock

The message block (<msgblock>) element contains a multi-line message or set of messages. The message block can contain multiple message numbers and message descriptions, each enclosed in a <msgnum> and <msgph> element. It can also contain the message content directly. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

The same contexts as pre

Contains

text data or varname or msgnum

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:space | This attribute is provided on <pre>, <lines>, and on elements derived from them. It ensures that parsers in editors and transforms respect the line-end characters that are part of the data in those elements. It is intended to be part of the default properties of these elements, and not for authors to change or delete. | (preserve) | #FIXED 'preserve' | boolean: yes
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>A sequence of failed password attempts generates the following
characteristic message stream:</p>
<msgblock>
I:0
S:3
I:1
S:3
I:1
S:4
S:99 (lockup)


msgnum

The message number (<msgnum>) element contains the number of a message produced by an application or program. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

msgph , msgblock; the same contexts as keyword

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>A server log entry of <msgnum>I:0</msgnum> is equivalent to the
text message, <msgph>informational: successful</msgph>.</p>


cmdname

The command name (<cmdname>) element specifies the name of a command when it is part of a software discussion. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

The same contexts as keyword

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to associate the <cmdname> with the reference topic for the command, if the command name itself isn't sufficient. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example


varname

The variable name (<varname>) element defines a variable that must be supplied to a software application. The variable name element is very similar to the variable (var) element, but variable name is used outside of syntax diagrams, possibly within a message or API description to describe a system variable or environment variable. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

msgph , msgblock , filepath , userinput , systemoutput; the same contexts as keyword

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<filepath>
  <varname>install-dir</varname>\projects\working\<varname>project-dir</varname>
       \source\<varname>filename</varname>.java
</filepath>


filepath

The <filepath> element indicates the name and optionally the location of a referenced file by specifying the directory containing the file, and other directories that may precede it in the system hierarchy. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

[unknown for this context]

Contains

text data or varname; the same contexts as ph

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>Uncompress the <filepath>gbbrsh.gz</filepath> file to the
<filepath>/usr</filepath> directory. Ensure that the
<filepath>/usr/tools/data.cfg</filepath> path is listed in
the execution path system variable.</p>


userinput

The user input (<userinput>) element represens the text a user should input in response to a program or system prompt. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

[unknown for this context]

Contains

text data or varname; the same contexts as ph

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>After you type <userinput>mealplan dinner</userinput>, the meal planning program
will print a <systemoutput>For what day?</systemoutput> message.
Reply by typing the day of the week for which you want a meal plan,
for example, <userinput>Thursday</userinput>.</p>


systemoutput

The system output (<systemoutput>) element represents computer output or responses to a command or situation. A generalized element, it represents any kind of output from the computer, so the author may wish to choose more specific markup, such as msgph, for messages from the application. The system output element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contained by

[unknown for this context]

Contains

text data or varname; the same contexts as ph

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>After you type <userinput>mealplan dinner</userinput>, the meal planning program
will print a <systemoutput>For what day?</systemoutput> message.
Reply by typing the day of the week for which you want a meal plan,
for example, <userinput>Thursday</userinput>.</p>


User interface elements

The user interface domain elements are used to describe the user interface of a software program.


uicontrol

The user interface control (<uicontrol>) element represents a button, entry field, menu item, or other object that allows the user to control the interface. This could also include a menu or dialog. For example, use the <uicontrol> element inside a <menucascade> element when the menu item is nested, such as File --> New . This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contained by

menucascade; the same contexts as ph

Contains

text data or image or shortcut

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Press the <uicontrol>OK</uicontrol> button.


wintitle

The window title <wintitle> element represents the title text that appears at the top of a window or dialog, and applies to wizard titles, wizard page titles, and pane titles. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contained by

The same contexts as keyword

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step>
  <cmd>Click <uicontrol>Configure</uicontrol>.</cmd>
  <stepresult>The <wintitle>Configuration Options</wintitle> window
  opens with your last set of selections highlighted.</stepresult>
</step>


menucascade

The <menucascade> element is used to document a series of menu choices, or to show any choice on a menu from which the user needs to choose. The <menucascade> element contains one or more user interface control (<uicontrol>) elements, for example: Start > Programs > Accessories > Notepad. If there is more than one <uicontrol> element, the formatter may show connecting characters between the menu items to represent the menu cascade. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contained by

[unknown for this context]

Contains

uicontrol; the same contexts as ph

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This example:
<menucascade>
 <uicontrol>Start</uicontrol>
 <uicontrol>Programs</uicontrol>
 <uicontrol>Accessories</uicontrol>
 <uicontrol>Notepad</uicontrol>
</menucascade>
produces this output: Start --> Programs --> Accessories --> Notepad


shortcut

The <shortcut> element identifies a keyboard shortcut for a menu or window action. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contained by

uicontrol

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This example:
<menucascade>
 <uicontrol>Start</uicontrol>
 <uicontrol><shortcut>P</shortcut>rograms</uicontrol>
</menucascade>
produces the following reusult: Start --> Programs


screen

The <screen> element contains or refers to a textual representation of a computer screen or user interface panel (window).

Use <screen> to contain representations of text-based online panels, text consoles ("term" or "curses" windows, for example), or other text-based user interface components. The default print representation is to enclose the screen within a box, suggesting a computer display screen. In contrast to graphical screen captures normally used to represent GUI parts (see the image element description), this element specifically supports constructions for which text is the primary content.

This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts and reference information.

Contained by

The same contexts as pre

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%display-atts; (scale, frame, expanse) | A set of related attributes, described at %display-atts; | parameter entity | PE not applicable | state: reqval=NA
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
xml:space | This attribute is provided on <pre>, <lines>, and on elements derived from them. It ensures that parsers in editors and transforms respect the line-end characters that are part of the data in those elements. It is intended to be part of the default properties of these elements, and not for authors to change or delete. | (preserve) | #FIXED 'preserve' | boolean: yes
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This example demonstrates using the <screen> element to represent a DOS edit session, where this code:
<p>Type "edit" after the command line prompt and press Enter.  The following
editing interface will be displayed.</p>
<screen>
   File  Edit  Search  View  Options  Help
+--------------------------------- UNTITLED1 ----------------------------------+
¦                                                                              ¦
¦                                                                              ¦

¦                                                                              ¦
¦                                                                              ¦
 F1=Help                                             ¦  Line:1    Col:1
</screen>
produces this output:

Type "edit" after the command line prompt and press Enter. The following editing interface will be displayed.

   File  Edit  Search  View  Options  Help
+--------------------------------- UNTITLED1 ----------------------------------+
¦                                                                              ¦
¦                                                                              ¦

¦                                                                              ¦
¦                                                                              ¦
 F1=Help                                             ¦  Line:1    Col:1


Utilities elements

The utilities domain elements represent common features of a language that may not necessarily be semantic, such as image maps. This is a new domain, and its content is provisional be definition... non-semantic markup could always be replaced by more specific markup in a full specialization, etc..


imagemap

The imagemap element supports the basic functionality of the HTML "client-side" image map markup. Imagemap allows you to designate a linkable area or region over an image, allowing a link in that region to display another topic.

An HTML client-side image map binds an image to the navigation structure (the "map") by means of an id association from the map to the image. In contrast, the DITA version of imagemap markup simply includes the target image as the first required element in the markup, followed by a sequence of area elements that represent the links associated with the contained image.

An imagemap structure can be output either to a standard HTML image map or to alternative forms of navigation (such as table-based image maps). When output as PDF, the minimal form would be to represent at least the image; advanced PDF output processors should be able to provide equivalent region-oriented hyperlinks.

The xref content contains the intended "alt" or hover text for the map area.

Contains

image (required), area (one or more)

Contained by

Allowed in the same contexts as fig.

Attributes

Same as for fig.

Examples

A simple imagemap looks like this (note that the rendering will depend on how this markup is supported for particular output formats):

rect 0,0,21,12 What is a tip?

The values for use in the shape and coords elements must follow the guidelines defined for image maps in HTML 4.1, at http://www.w3.org/TR/html401/struct/objects.html#edef-MAP

The markup for this example looks like this:

<imagemap>
  <image href="tip-ing.jpg" height="12" width="21"/>
  <area>
    <shape>rect</shape>
    <coords>0,0,21,12</coords>
    <xref href="tip.xml"/>
  </area>
</imagemap>
For additional information about HTML 4.1 image maps, see:
  1. at http://www.w3.org/TR/html401/struct/objects.html#edef-MAP
  2. Night of the Image Map, http://www.alistapart.com/articles/imagemap/


area

The area element defines an area of the image in an imagemap that is linkable.

Contains

shape (required), coords (required)

Contained by

Allowed in the same contexts as fig.

Attributes

Same as for figgroup.

Examples

See imagemap


coords

The coords element specifies the coordinates of the linkable region in an imagemap area.

The coords element uses the following data for the appropriate shapes:

Shape | Data format
rect | left-x, top-y, right-x, bottom-y
circle | center-x, center-y, radius
poly | x1, y1, x2, y2, ..., xN, yN. The first x and y coordinate pair and the last should be the same to close the polygon.

Note: The behavior of image maps will depend on the browser on which they are rendered.

Contains

Text data representing HTML coordinate data for image maps. The syntax of the coordinate data depends on the shape described by the coordinates.

Contained by

Allowed in the same contexts as figgroup.

Attributes

Same as for ph.

Examples

The markup for a rectangular shape looks like this:
<imagemap>
  <image href="tip-ing.jpg" height="12" width="21"/>
  <area>
    <shape>rect</shape>
    <coords>0,0,21,12</coords>
    <xref href="tip.xml"/>
  </area>
</imagemap>


shape

The shape element defines the shape of a linkable area in an imagemap.

The shape element supports these values:

  • default (no value): Specifies the entire region.
  • rect : Define a rectangular region.
  • circle : Define a circular region.
  • poly : Define a polygonal region.

Contains

Text data representing HTML shape keywords: default, rect, circle, poly

Contained by

Allowed in the same contexts as figgroup.

Attributes

Examples

Same as for keyword.The values for the shape element are coded like this:
<imagemap>
  <image href="tip-ing.jpg" height="12" width="21"/>
  <area>
    <shape>rect</shape>
    <coords>0,0,21,12</coords>
    <xref href="tip.xml"/>
  </area>
</imagemap>


Miscellaneous elements

Most DITA elements represent discourse, or information that is placed exactly as entered. However, there are also types of information that are usually authored in context with a thought or issue, but upon output, the content might be relocated, suppressed, or used only for purposes such as inline annotations for drafts. These elements include footnotes, index entries, draft comments, and special cleanup containers that can hold migrated data that still needs a writer's intervention to get into the right place.


draft-comment

The <draft-comment> element allows simple review and discussion of topic contents within the marked-up content. Use the <draft-comment> element to ask a question or make a comment that you would like others to review. To indicate the source of the draft comment or the status of the comment, use the author, time or disposition attributes.

Note: Your processing system will provide a run-time flag or parameter to cause the content of this element to be specially displayed for draft output only. By default, it is stripped out to prevent publishing internal comments by mistake!.

Contained by

section , example , p , note , lq , sli , li , itemgroup , dd , pre , lines , ph , stentry , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , screen , codeblock , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable

Attributes

Name | Description | Data Type | Default Value | Required?
author | Designates the originator of the draft comment. | CDATA | #IMPLIED | boolean: no
time | Describes when the draft comment was created. | CDATA | #IMPLIED | boolean: no
disposition | Status of the draft comment. Values can be issue, open, accepted, rejected, deferred, duplicate, reopened, unassigned, or completed. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

A draft-comment looks like this in the source:
<draft-comment author="EBP" disposition="open">Where's the usage information for this
section?</draft-comment>


fn

Use footnote (<fn>) to annotate text with notes that are not appropriate for inclusion in line or to indicate the source for facts or other material used in the text. Footnote content is always skipped at the place where it was entered, and reproduced elsewhere, according to these rules:

  • A footnote with no given id attribute is a single-use footnote. Upon output, it generates a number as a superscript "callout" that is linked to the placement of the footnote, usually at the bottom of the immediate printed page or at the end of the Web article. Subsequent footnotes in the same topic will have the next number in sequence for their callouts. If you enter a particular character in the callout attribute for the footnote, that character will be used as the superscript "callout" that is linked to the placement of the footnote. This override callout mechanism is not supported for PDF output.
  • A footnote entered with an id attribute is a use-by-reference footnote. Upon output, it does not appear anywhere unless it has been referenced using an <xref> with the type attribute set to "fn". The same callout behaviors will apply.
  • Ordinarily, a footnote in one topic can't be referenced in another topic. The previous behaviors are local to each topic. But by using the <conref> mechanism, you can instance another topic's footnote into the local topic where it will then follow those behaviors:
    • If you use <fn conref="thatid"></fn> all by itself, the result will be the same as the single-use footnote entered literally in the same location.
    • If you use <fn conref="thatid" id="thisid"></fn>, then <xref href="thisid" type="fn"/>, the result will be the same as the use-by-reference model described before.

Contained by

section , example , p , note , lq , sli , li , itemgroup , dd , figgroup , pre , lines , ph , stentry , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , screen , codeblock , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object

Attributes

Name | Description | Data Type | Default Value | Required?
callout | Specifies what character is used for the footnote link, for example a number or an alpha character. Numbers are the default. You could also specify a graphic for the footnote callout during output processing. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

This markup:
The memory storage capacity of the computer is
2 GB<fn callout="#">A GB (gigabyte) is equal to
1 million bytes</fn> with error correcting support.
produces this output:
The memory storage capacity of the computer is 2 GB# with error correcting support.

Note: Footnote support may vary between different output types, depending on conventions and capabilities. For example, PDF output may lack support for the callout attribute, or footnotes may be collected as endnotes for certain types of Web publications.

End Notes

# A GB (gigabyte) is equal to 1 million bytes


indexterm

An <indexterm> is an index entry. You can nest entries to create multi-level indexes. The content is not output as part of topic content, only as part of the index.

When DITA topics are output to XHTML, any keyword or indexterm elements in the <keywords> element are placed in the Web page metadata. In addition, the indexterms are added to supported index processing (for example, for print versions).

Contained by

section , example , p , note , lq , sli , li , itemgroup , dd , pre , lines , ph , stentry , entry , keywords , indexterm , prereq , context , cmd , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , screen , codeblock , pd

Contains

text data or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<purpose>An indexterm is an index entry. You can nest entries to
create multi-level indexes.<indexterm>indexterm</indexterm>
<indexterm>Valid in Many Places elements<indexterm>indexterm</indexterm>
</indexterm></purpose>


indextermref

An <indextermref> is a reference to an index entry in a lookup table used by the indexing process. If you want to create index markers pointing to referenced items, but only want page numbers instead of separate index entries to be generated, use the index term reference <indextermref> element. This adds the page number of the reference to the index without creating a separate index entry.

Note: Not currently supported in DITA processing.

Contained by

section , example , p , note , lq , sli , li , itemgroup , dd , pre , lines , ph , stentry , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , screen , codeblock , pd

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to point to an <indexterm> and to change what it points to for different contexts. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>Use <indextermref keyref="yellow"/> lemon zest to add a tangy citrus
flavor to the cake icing.</p>


tm

The trademark (<tm>) element in DITA is used to markup and identify a term or phrase that is trademarked. Trademarks include registered trademarks, service marks, slogans and logos.

Remember: In your company's documents, these attributes should only be set with an approved editor that follows corporate rules for nesting trademarks and setting attribute properties. The business rules for indicating and displaying trademarks may differ from company to company and must be enforced by authoring policy and by specific processing.

Contained by

title , shortdesc , section , example , desc , p , note , lq , q , sli , li , itemgroup , dthd , ddhd , dt , dd , pre , lines , term , ph , tm , stentry , draft-comment , fn , cite , xref , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , b , u , i , tt , sup , sub , pt , pd , fragref , synnote

Contains

text data or tm

Attributes

Name | Description | Data Type | Default Value | Required?
trademark | The trademarked term | CDATA | #IMPLIED | boolean: no
tmowner | The trademark owner, for example "IBM Corporation." | CDATA | #IMPLIED | boolean: no
tmtype | The trademark type: trademark, registered trademark, or service mark | CDATA | #IMPLIED | boolean: no
tmclass | Classification of the trademark (is it an IBM trademark, IBM subsidiary trademark, etc). Values can include IBM, IBMSUB, SPECIAL and OTHER. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>The advantages of using <tm trademark="DB2 Universal Database" tmtype="tm">
<tm trademark="DB2" tmtype="reg" tmclass="ibm">DB2</tm> Universal Database</tm> are
well known.</p>


Prolog elements

The prolog elements represent the <metadata> associated with a document.

The primary types of information that you can store in the prolog include:

  • author
  • copyright information
  • critical tracking dates
  • permissions for use/management of the content
  • extensive metadata about the content of the document
  • a resourceid that allows a topic to be associated with external resources such as linking to programming components as contextual help


audience

The <audience> metadata element indicates, through the value of its type attribute, the intended audience for a topic. Since a topic can have multiple audiences, you can include multiple audience elements. For each audience you specify, you can identify the high-level task ( job ) they are trying to accomplish and the level of experience ( experiencelevel ) expected.

Contained by

metadata

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
type Indicates the kind of person for whom the content of the topic is intended. Allowable values are:
user
A user of the product
purchaser
A product purchaser
administrator
A product administrator
programmer
A programmer
executive
An executive
services
Someone who provides services related to the product
other
Use the value specified by the othertype attribute
 (user | purchaser | administrator | programmer | executive | services | other) #IMPLIED boolean: no
othertype | Indicates an alternate audience type, when the type is not available in the type attribute value list. This value is used as the user-provided audience when the type attribute value is set to "other." | CDATA | #IMPLIED | boolean: no
job | Indicates the high-level task the audience for the topic is trying to accomplish. Different audiences may read the same topic in terms of different high-level tasks; for example, an administrator may read the topic while administering, while a programmer may read the same topic while customizing. Allowable values are: installing, customizing, administering, programming, using, maintaining, troubleshooting, evaluating, planning, migrating, other. | installing | customizing | administering | programming | using | maintaining | troubleshooting | evaluating | planning | migrating | other | #IMPLIED | boolean: no
otherjob | If the job attribute value is "other" the value of this attribute is used to identify a kind of job other than the default ones provided by the job attribute. | CDATA | #IMPLIED | boolean: no
experiencelevel Indicates the level of experience the audience is assumed to possess. Different audiences may have different experience levels with respect to the same topic; for example, a topic may require general knowledge from a programmer, but expert knowledge from a user. Allowable values are:
novice
A first time user.
general
The most common user.
expert
An experienced user.
 (novice | general | expert) #IMPLIED boolean: no
name | Used to associate the audience element with values used in the audience attribute | CDATA | #REQUIRED | boolean: yes
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

For a command reference topic for experienced programmers, the following might be an appropriate indication of that audience:

<audience type="programmer" job="programming" experiencelevel="expert"/>


author

The <author> metadata element contains the name of the topic's author. The currently unsupported keyref attribute can point to another location where the author information is defined.

Contained by

prolog

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
href A hyperlink representing a resource that defines the person or company named in the parent element. Typically you would use this attribute to cite the URL for the named entity's "home page." The href attribute identifies the destination of the resource using conventional URL syntax:
href="http://www.seuss.org/seuss/seuss.bio.html"
href="http://www.amazon.com/exec/obidos/ISBN=039480001X/
   thedrseusswebpagA"
 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
type Indicates the primary author of the content. Allowable values are:
creator
The primary or original author of the content.
contributor
An additional author who is not primary.
 (author | contributor) #IMPLIED boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
<author type="creator">Jane Roe</author>
<author type="contributor">John Doe</author>
</prolog>


brand

The <brand> element indicates the manufacturer or brand associated with the product described by the parent <prodinfo> element.

Contained by

prodinfo

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prodinfo>
<prodname>...</prodname>
<vrmlist>
<brand>eServer</brand>
<series>iSeries</series>
<opsys>Linux</opsys>
</vrmlist>
</prodinfo>


category

The <category> element can represent any category by which a topic might be classified for retrieval or navigation; for example, the categories could be used to group topics in a generated navigation bar. Topics can belong to multiple categories.

Contained by

metadata

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

 <prolog>
  <metadata>
   <category platform="Linux" product="EMacs" audience="editors"
     importance="high"></category>
  </metadata>
 </prolog>


component

The <component> element describes the component of the product that this topic is concerned with. For example, a product might be made up of many components, each of which is installable separately. Components might also be shared by several products so that the same component is available for installation with many products. This identification can be used to check cross-component dependencies when some components are installed, but not others. It could also be used to make sure that topics are hidden, removed, or flagged in some way when the component they describe isn't installed. Such process-control logic is not currently supported in DITA processing.

Contained by

prodinfo

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prodinfo>
 <prodname>BatCom</prodname>
 <vrmlist>
  <vrm version="v5r2"/>
 </vrmlist>
 <component>TCP/IP</component>
</prodinfo>


copyrholder

The copyright holder (<copyrholder>) element names the entity that holds legal rights to the material contained in the topic.

Contained by

copyright

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<copyright>
<copyryear year=2001></copyryear>
<copyrholder>IBM</copyrholder>
</copyright>


copyright

The <copyright> element is used for a single copyright entry. It includes the copyright years and the copyright holder. Multiple <copyright> statements are allowed.

Contained by

prolog

Contains

( copyryear ) (one or more) then copyrholder

Attributes

Name | Description | Data Type | Default Value | Required?
type Indicates the legal status of the copyright holder. Allowable values are:
primary
The copyright holder with first claim on the copyright
secondary
An additional copyright holder who is not primary
 (primary | secondary) #IMPLIED boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
<copyright>
<copyryear year="2001-04-12"></copyryear>
<copyrholder>IBM</copyrholder>
</copyright>
<copyright type=secondary>
<copyryear year="2002-03-03></copyryear>
<copyrholder>Schweetones Publishing, Inc.</copyrholder>
</copyright>
</prolog>


copyryear

The <copyryear> element contains the copyright year as specified by the year attribute.

Contained by

copyright

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
year | The year in YYYY format. See A Summary of the International Standard Date and Time Notation for background. | CDATA | #IMPLIED | boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<copyright>
<copyryear year="2001"></copyryear>
<copyrholder>IBM</copyrholder>
</copyright>


created

The <created> element specifies the document creation date using the date attribute.

Contained by

critdates

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
date | The document creation date. Enter the date as YYYY-MM-DD where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. See A Summary of the International Standard Date and Time Notation for background. | CDATA | #IMPLIED | boolean: no
golive | The publication or general availability (GA) date, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | boolean: no
expiry | The date when the information should be retired or refreshed, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
 <critdates>
  <created date="2001-06-12"></created>
  <revised golive="2001-08-20"></revised>
 </critdates>
</prolog>


critdates

The <critdates> element contains the critical dates in a document life cycle, such as the creation date and multiple revision dates.

Contained by

prolog

Contains

created then ( revised ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
 <critdates>
  <created date="2001-06-12"></created>
  <revised golive="2001-08-20"></revised>
 </critdates>
</prolog>


featnum

The <featnum> element contains the feature number of a product in the document metadata.

Contained by

prodinfo

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prodinfo>
 <prodname>BatCom</prodname>
 <vrmlist>
  <vrm version="v5r2"/>
 </vrmlist>
 <featnum>135</featnum>
 <component>TCP/IP</component>
</prodinfo>


keywords

The <keywords> element contains a list of keyword entries (using indexterm or keyword markup) that can be used by a search engine.

When DITA topics are output to XHTML, any <keyword> or <indexterm> elements in the <keywords> element are placed in the Web page metadata. In addition, any index terms in this context are also used for supported index processing (for example, for print versions).

Contained by

metadata

Contains

indexterm or keyword

Attributes

Name | Description | Data Type | Default Value | Required?
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The following example is metadata from an installation task:

<prolog>
 <keywords>
  <keyword>installing</keyword>
  <keyword>uninstalling</keyword>
  <keyword>prerequisites</keyword>
  <keyword>helps</keyword>
  <keyword>wizards</keyword>
 </keywords>
</prolog>


metadata

The <metadata> section of the prolog contains information about a topic such as audience and product information. Metadata can be used by computational processes to select particular topics or to prepare search indexes or to customize navigation.

Contained by

prolog

Contains

( audience ) (0 or more) then ( category ) (0 or more) then ( keywords ) (0 or more) then ( prodinfo ) (0 or more) then ( othermeta ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
  <metadata>
    <audience type="user" job="using" experiencelevel="novice"/>
  </metadata>
</prolog>


othermeta

The <othermeta> element can be used to identify properties not otherwise included in <metadata> and assign name/content values to those properties. The name attribute identifies the property and the content attribute specifies the property's value. The values in this attribute are output as HTML metadata elements, and have no defined meaning for other possible outputs such as PDF.

Contained by

metadata

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
name | Submit the object as part of a form. | CDATA | #REQUIRED | boolean: yes
content | The value for the property named in the name attribute. | CDATA | #REQUIRED | boolean: no
translate-content | Indicates whether the content attribute of the defined metadata property should be translated or not. | yes | no | #IMPLIED | boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<othermeta name="ThreadWidthSystem" content="metric"/>


permissions

The <permissions> empty prolog element can indicate any preferred controls for access to a topic. Topics can be filtered based on the permissions element. This capability depends on your output formatting process.

Contained by

prolog

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
view Defines the classifications of viewers allowed to view the document. Allowable values are:
internal
For internal use only.
classified
For a certain group, only.
all
The world.
entitled
Special folks, only.
 (internal | classified | all | entitled) #IMPLIED boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
<permissions view="entitled"/>
...


platform

The <platform> metadata element contains a description of the operating system and/or hardware related to the product being described by the <prodinfo> element.

Contained by

prodinfo

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Transcription Assistant</prodname>
   <vrmlist><vrm version="1" release="3" modification="1"/></vrmlist>
   <platform>AIX</platform>
  </prodinfo>
 </metadata>
</prolog>


prodinfo

The <prodinfo> metadata element in the prolog contains information about the product or products that are the subject matter of the current topic.

Contained by

metadata

Contains

prodname then vrmlist then ( brand or series or platform or prognum or featnum or component ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Transcription Assistant</prodname>
    <vrmlist><vrm version="1" release="3" modification="1"/></vrmlist>
   <platform>AIX</platform>
  </prodinfo>
 </metadata>
</prolog>


prodname

The <prodname> metadata element contains the name of the product that is supported by the information in this topic.

Contained by

prodinfo

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Transcription Assistant</prodname>
   <vrmlist><vrm version="1" release="3" modification="1"/></vrmlist>
   <platform>AIX</platform>
  </prodinfo>
 </metadata>
</prolog>


prognum

The <prognum> metadata element identifies the program number of the associated program product. This is typically an order number or a product tracking code that could be replaced by an order number when a product completes development.

Contained by

prodinfo

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prodinfo>
 <prodname>BatCom</prodname>
 <vrmlist><vrm version="v5r2"/></vrmlist>
 <prognum>5412-SS1</prognum>
 <featnum>135</featnum>
 <component>TCP/IP</component>
</prodinfo>


prolog

The <prolog> element contains information about the topic as an whole (for example, author information or subject category) that is either entered by the author or machine-maintained. Much of the metadata inside the <prolog> will not be displayed with the topic on output, but may be used by processes that generate search indexes or customize navigation.

Contained by

topic , concept , task , reference

Contains

( author ) (0 or more) then ( source ) (optional) then ( publisher ) (optional) then ( copyright ) (0 or more) then ( critdates ) (optional) then ( permissions ) (optional) then ( metadata ) (optional) then ( resourceid ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
  <metadata>
    <audience type="user" job="using" experiencelevel="novice"/>
  </metadata>
</prolog>


publisher

The <publisher> metadata element contains the name of the person, company, or organization responsible for making the content or subject of the topic available.

Contained by

prolog

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
href A hyperlink representing a resource that defines the person or company named in the parent element. Typically you would use this attribute to cite the URL for the named entity's "home page." The href attribute identifies the destination of the resource using conventional URL syntax:
href="http://www.seuss.org/seuss/seuss.bio.html"
href="http://www.amazon.com/exec/obidos/ISBN=039480001X/
   thedrseusswebpagA"
 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<publisher>AJ Printing Inc.</publisher>


resourceid

The <resourceid> element provides an identifier for applications that require them in a particular format, when the normal id attribute of the topic can't be used. Each resourceid entry should be unique. It is one of the metadata elements that can be included within the prolog of a topic, along with document tracking and product information, etc. The element has no content, but takes an id attribute or an appname attribute.

Contained by

prolog

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
appname | Contains the name of the application with which the topic is associated. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<resourceid id="fred" appname="sqlid00375"/>


revised

The <revised> element in the prolog is used to maintain tracking dates that are important in a topic development cycle, such as the last modification date, the original availability date, and the expiration date.

Contained by

critdates

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
modified | The last modification date, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | boolean: no
golive | The publication or general availability (GA) date, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | boolean: no
expiry | The date when the information should be retired or refreshed, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | boolean: no
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
 <critdates>
  <created date="1/1/1999" golive="2/15/1999" expiry="9/9/9999"/>
  <revised modified="3/3/2003" golive="2/3/2002" expiry="9/9/9999"/>
 </critdates>
</prolog>


series

The <series> metadata element contains information about the product series that the topic supports.

Contained by

prodinfo

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prodinfo>
 <prodname>BatCom</prodname>
 <vrmlist><vrm version="v5r2"/></vrmlist>
 <series>tSeries</series>
 <prognum>5412-SS1</prognum>
 <featnum>135</featnum>
 <component>TCP/IP</component>
</prodinfo>


source

The <source> element contains a reference to a resource from which the present topic is derived, either completely or in part. The element can contain a description of the resource; the href reference can be a string or a URL that points to it.

Contained by

prolog

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
href A hyperlink representing an external Web resource (URL) from which the present resource is derived. The href attribute identifies the destination of the resource using conventional URL syntax:
href="http://www.xxx.com" format="html"
href="myfile.xml" type="concept"  (or task, reference, or topic)
href="myfile.xml#topicid/figid" type="fig"  (or table, fn, or
  section)

href="mything.pdf" format="pdf"
 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<prolog>
 <source href="http://www.ibm.com">Somewhere, someplace</source>
</prolog>


vrm

The vrm empty element contains information about a single product's version, modification, and release, to which the current topic applies.

Contained by

vrmlist

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
version | Indicates the released version number of the product(s) that the document describes. | CDATA | #IMPLIED | boolean: no
release | Contains the product release identifier. | CDATA | #IMPLIED | boolean: no
modification | Indicates when the product described in this topic was last modified. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The recent versions of a mythical product might be logged thus using the vrmlist markup:

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Widge-o-matic</prodname>
   <vrmlist>
     <vrm version="1.0" release="2001-03-30" modification="0"/>
     <vrm version="1.0" modification="1" release="2001-10-03"/>
   </vrmlist>
  </prodinfo>
 </metadata>
</prolog>


vrmlist

The <vrmlist> element contains a set of <vrm> elements for logging the version, release, and modification information for multiple products or versions of products to which the topic applies.

Contained by

prodinfo

Contains

vrm

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The recent versions of a mythical product might be logged thus using the vrmlist markup:

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Widge-o-matic</prodname>
   <vrmlist>
     <vrm version="1.0" release="2001-03-30" modification="0"/>
     <vrm version="1.0" modification="1" release="2001-10-03"/>
   </vrmlist>
  </prodinfo>
 </metadata>
</prolog>


Related links elements

The related-links section of DITA topics is a special structure that supports the navigational rules from a topic to its related neighbor topics, whether parent/child relationships (hierarchy), sibling relationships (browse sequences), types (collections), and whether the link is internal or external to the set.

Links are different from cross-references in that cross-references occur only within the body of a topic and can target any element in this or other topics; links only represent topic-to-topic connections.


link

The <link> element defines a relationship to another topic. Links represent the types and roles of topics in a web of information, and therefore represent navigational links within that web. The parent structures of link allow authors to define named groups and even sort orders that can be applied to sets of links.

Contained by

related-links , linklist , linkpool

Contains

( linktext ) (optional) then ( desc ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
href A hyperlink to an external Web page (URL) or to another topic in the same file or in another file. The href attribute identifies the destination of the cross-reference link using conventional URL syntax:
href="http://www.xxx.com" format="html"
href="myfile.xml" type="concept"
   (or task, reference, or topic)
href="myfile.xml#topicid/figid" type="fig"
   (or table, fn, or section)
href="mything.pdf" format="pdf"

If the URL contains an ampersand character, the ampersand symbol (&amp;) should be used to indicate that character

 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%rel-atts; (type, role, otherrole) | A set of related attributes, described at %rel-atts; | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
format The format attribute identifies the format of the resource being cross referenced. The default format is dita.

Allowable values are:

dita
The format of the linked-to resource is native DITA. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
(no value)
Defaults to "dita"
(for anything else)
Use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value)
 CDATA #IMPLIED boolean: no
scope | The scope attribute identifies the closeness of the relationship between the current topic and the target resource. Set scope to local when the resource is part of the current set of content, and should be accessed and copied to the output directory. Set scope to peer when the resource is part of the current set of content but is not accessible at build time. Set scope to external when the resource is not part of the current information set and should open in a new browser window. The default is local. | (local | peer | external) | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<related-links>
<linklist><title>Related Concepts</title>
<link href="czover.htm#sqljsupp">
<linktext>SQLJ support in VisualAge for Java</linktext></link>
<link href="czesqlj.htm#sqljemb>
<linktext>Embedded SQLJ</linktext></link>
</linklist>
<related-links>


linkinfo

The <linkinfo> element allows you to place a descriptive paragraph following a list of links in a linklist element.

Contained by

linklist

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or image

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<linklist>
  <title>Related tasks</title>
  <link href="debug.xml" type="task"></link>
  <link href="repair.xml" type="task"></link>
  <link href="test.xml" type="task"></link>
  <linkinfo>To repair a reciprocating widget,
you must follow the instructions very carefully. Note
the sequence to follow. Do it.</linkinfo>
</linklist>


linklist

The <linklist> element defines an author-arranged group of links. Within <linklist>, the organization of links on final output is in the same order as originally authored in the DITA topic file.

There are two ways to organize related information links: add them all in no particular order and let the output formatting processor sort them using the <linkpool> or <related-links> elements, or pre-group them using one or more <linklist> elements. When you pre-group them using <linklist>, then the order of the links as you created them is preserved during the output formatting process.

Attributes set on <linklist> are inherited by its descendants. For example, if you've got a <linklist> that contains all external links, you can set scope="external" on that outer<linklist> element and thereby leave it off the nested content of the element.

Contained by

related-links , linklist

Contains

( title ) (optional) then ( desc ) (optional) then ( linklist or link ) (0 or more) then ( linkinfo ) (optional)

Attributes

Name | Description | Data Type | Default Value | Required?
collection-type | Collection types describe how links relate to each other. A family represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other. Allowed values are: unordered sequence choice family. Should you see the value "tree" in a pulldown list, it is not supported. | (unordered|sequence|choice|family) | "unordered" | boolean: no
duplicates | Specifies whether or not duplicate links will be filtered out of a linklist. Allowable values are: "yes" (allow duplicate links), or "no" (filter out duplicate links). In general, duplicate links in linklists are preserved, all other duplicates in other contexts are removed. Note that links are regarded as duplicates only if their content plus all attributes match. Currently not supported in DITA processing. | #IMPLIED | The attribute value is ignored. The actual function is currently processor-dependent. | boolean: no
mapkeyref | Identifies the map, if any, from which the <linklist> and its links are derived. This would be automatically generated by the same process that created the map from the <linklist>, as a way to identify which map the links came from. If the <linklist> is manually created by the author in the <related-links> section,, there is no need to use this attribute. | CDATA | #IMPLIED | boolean: no
%rel-atts; (type, role, otherrole) | A set of related attributes, described at %rel-atts; | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
spectitle | The specialized title attribute allows architects of specialized DTDs to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | boolean: no
format The format attribute identifies the format of the resource being cross referenced. The default format is dita.

Allowable values are:

dita
The format of the linked-to resource is native DITA. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
(no value)
Defaults to "dita"
(for anything else)
Use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value)
 CDATA #IMPLIED boolean: no
scope | The scope attribute identifies the closeness of the relationship between the current topic and the target resource. Set scope to local when the resource is part of the current set of content, and should be accessed and copied to the output directory. Set scope to peer when the resource is part of the current set of content but is not accessible at build time. Set scope to external when the resource is not part of the current information set and should open in a new browser window. The default is local. | (local | peer | external) | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>...</taskbody>
 <related-links>
  <linklist>
   <title>Related Concepts</title>
  </linklist>
  <linklist>
   <title>Related Tasks</title>
  </linklist>
 </related-links>
</task>


linkpool

The <linkpool> element defines a group of links that have common characteristics, such as type or audience or source. Within <linkpool>, the organization of links on final output is determined by the output process, not by the order that the links actually occur in the DITA topic file.

There are two ways to organize related information links: add them all in no particular order and let the output formatting processor sort them using the <linkpool> or <related-links> elements, or pre-group them using one or more <linklist> elements. When you pre-group them using <linklist>, then the order of the links as you created them is preserved during the output formatting process.

Attributes set on <linkpool> are inherited by its descendants. For example, if you've got a <linkpool> that contains all external links, you can set scope="external" on that outer<linkpool> element and thereby leave it off the nested content of the element.

Contained by

related-links , linkpool

Contains

linkpool or link

Attributes

Name | Description | Data Type | Default Value | Required?
collection-type | Collection types describe how links relate to each other. A family represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other. Allowed values are: unordered sequence choice family. Should you see the value "tree" in a pulldown list, it is not supported. | (unordered|sequence|choice|family) | "unordered" | boolean: no
duplicates | Specifies whether or not duplicate links will be filtered out of a linklist. Allowable values are: "yes" (allow duplicate links), or "no" (filter out duplicate links). In general, duplicate links in linklists are preserved, all other duplicates in other contexts are removed. Note that links are regarded as duplicates only if their content plus all attributes match. Currently not supported in DITA processing. | #IMPLIED | The attribute value is ignored. The actual function is currently processor-dependent. | boolean: no
mapkeyref | Identifies the map, if any, from which the <linklist> and its links are derived. This would be automatically generated by the same process that created the map from the <linklist>, as a way to identify which map the links came from. If the <linklist> is manually created by the author in the <related-links> section,, there is no need to use this attribute. | CDATA | #IMPLIED | boolean: no
%rel-atts; (type, role, otherrole) | A set of related attributes, described at %rel-atts; | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
format The format attribute identifies the format of the resource being cross referenced. The default format is dita.

Allowable values are:

dita
The format of the linked-to resource is native DITA. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
(no value)
Defaults to "dita"
(for anything else)
Use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value)
 CDATA #IMPLIED boolean: no
scope | The scope attribute identifies the closeness of the relationship between the current topic and the target resource. Set scope to local when the resource is part of the current set of content, and should be accessed and copied to the output directory. Set scope to peer when the resource is part of the current set of content but is not accessible at build time. Set scope to external when the resource is not part of the current information set and should open in a new browser window. The default is local. | (local | peer | external) | #IMPLIED | boolean: no
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<related-links>
<linkpool collection-type="family" type="task">
<link href="generalfaq.html#installing" role="parent">
<linktext>Installing the eReview client</linktext></link>
<link href="register.html#newuser" role="sibling">
<linktext>Register as new eReview user</linktext></link>
</linkpool>
</related-links>


linktext

The <linktext> element provides the literal label or line of text for a link. In most cases, the text of a link can be resolved during processing by cross reference with the target resource. Use the <linktext> element only when the target cannot be reached, such as when it is a peer or external link.

Contained by

link

Contains

text data

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<link href="tzover.htm#accsqlj">
 <linktext>Accessing relational data with SQLJ</linktext>
</link>


Specialization elements

Several DITA elements exist either for architectural reasons or for support of specialized markup yet to be designed. Although there is little need to use these elements unless you are directed to, some of them, such as <boolean> and <state>, can be used if your content makes use of these semantic distinctions. A discussion of signals on a gate of an integrated logic circuit, for example, might use the state element to represent either on or off conditions of that gate.


boolean

The <boolean> element is used to express one of two opposite values, such as yes or no, on or off, true or false, high or low, and so forth. The element itself is empty; the value of the element is stored in its state attribute, and the semantic associated with the value is typically in a specialized name derived from this element. If you need more than two values (for example, "yes," "no" and "don't care") use the <state> element instead. This element is primarily for specialization, where it can be used to require a logical true or false designation in a particular part of the document.

Contained by

title , shortdesc , section , example , desc , p , note , lq , q , sli , li , itemgroup , dthd , ddhd , dt , dd , pre , lines , ph , stentry , draft-comment , fn , cite , xref , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , fragref , synnote

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
state | The state of the boolean element. Allowable values are: yes no | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

She said "<boolean state="yes"/>" when I asked her to marry me!


itemgroup

The <itemgroup> element is reserved for specialization of DITA. As a container element, it can be used to sub-divide or organize elements that occur inside a list item, definition, or parameter definition.

Contained by

li , dd , pd

Contains

text data or ph or term or xref or cite or q or boolean or state or keyword or tm or p or lq or note or dl or ul or ol or sl or pre or lines or fig or image or object or table or simpletable or draft-comment or required-cleanup or fn or indextermref or indexterm

Attributes

Name | Description | Data Type | Default Value | Required?
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<li>Second point of a list.
 <itemgroup>related discourse</itemgroup>
</li>


no-topic-nesting

The <no-topic-nesting> element is a placeholder in the DITA architecture. It is not actually used by the DITA DTDs; it is for use only when creating a customized DTD where the information designer wants to eliminate the ability to nest topics. Not for use by authors.

Contained by

Not used in DITA authoring DTDs.

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example


required-cleanup

A <required-cleanup> element is used as a placeholder for migrated elements that cannot be appropriately tagged without manual intervention. As the element name implies, the intent for authors is to clean up the contained material and eventually get rid of the <required-cleanup> element. Authors should not insert this element into documents.

Note: Because the content of <required-cleanup> is not considered to be verified data, DITA processors are required to strip this element from output by default. A runtime flag may be provided to allow a draft view of migrated content in context.

Contained by

body , section , example , p , note , lq , sli , li , itemgroup , dd , pre , lines , ph , stentry , entry , conbody , prereq , context , cmd , info , tutorialinfo , stepxmp , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , screen , codeblock , pd

Contains

any content

Attributes

Name | Description | Data Type | Default Value | Required?
remap | Indicates the element that the contents of the required-cleanup element were mapped from (provides an idea about what the new intent should be). | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

Presuming an original HTML document had contained some content within a <center> tag (for which there is no clear migrational equivalent in DITA), the following might be the result that is valid within an XML editor, but which requires an author to decide how to better tag or revise this original content:

<section>
  <title>Some section title</title>
  <required-cleanup remap="center">Some original content migrated
  from a &lt;center> tag.</required-cleanup>
</section>


state

The <state> element specifies a name/value pair whenever it is necessary to represent a named state that has a variable value. The element is primarily intended for use in specializations to represent specific states (like logic circuit states, chemical reaction states, airplane instrumentation states, and so forth).

Contained by

title , shortdesc , section , example , desc , p , note , lq , q , sli , li , itemgroup , dthd , ddhd , dt , dd , pre , lines , ph , stentry , draft-comment , fn , cite , xref , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , fragref , synnote

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
name | Submit the object as part of a form. | CDATA | #REQUIRED | boolean: yes
value | Specifies the value of a run-time parameter specified by the name attribute. | CDATA | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<step><cmd>Verify the presence of  an "on" or high condition at the input gate
(ie,  <state name="inflag" value="high"/>)</cmd></step>


term

The <term> element identifies words that represent extended definitions or explanations. In future development of DITA, for example, terms might provide associative linking to matching glossary entries.

Contained by

title , shortdesc , section , example , desc , p , note , lq , q , sli , li , itemgroup , dthd , ddhd , dt , dd , pre , lines , ph , stentry , draft-comment , fn , cite , xref , linkinfo , entry , prereq , context , cmd , info , tutorialinfo , stepxmp , choice , choptionhd , chdeschd , choption , chdesc , stepresult , result , postreq , refsyn , proptype , propvalue , propdesc , screen , b , u , i , tt , sup , sub , codeph , codeblock , pt , pd , fragref , synnote

Contains

text data or tm

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
%univ-atts; (%select-atts;, %id-atts;, translate, xml:lang) | A set of related attributes, described at %univ-atts; | parameter entity | PE not applicable | state: reqval=NA
outputclass | Designates an element style in a local Cascading Style Sheet (CSS) to override whatever style is normally applied. See outputclass processing for more information. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

<p>The <term>reference implementation</term> of DITA represents the standard,
<q>fallback</q> behaviors intended for DITA elements.</p>


Commonly referenced descriptions

Several parts of a language reference are common between many locations, such as the descriptions for the selection and property attributes of DITA elements. These are described as sets to reduce unnecessary duplication of common information. The technique you use to reference this common information within the various topics of this language reference is a model for how you can likewise maintain oft-reused information in a single location.


%display-atts;

Display attributes is a parameter entity declaration in the topic DTD that includes attributes whose values may be used for affecting the display of a topic or its selection by search tools.

Contained by

Used in fig, pre, lines, simpletable, and their derivatives.

Contains

Declarations for attributes.

Attributes

Name | Description | Data Type | Default Value | Required?
scale | Specifies a percentage, selected from an enumerated list, that is used to resize fonts in relation to the normal text size. DITA processing does not support this attribute for XHTML output. | (50|60|70|80|90|100|110|120|140|160|180|200) | #IMPLIED | boolean: no
frame Specifies which portion of a border should surround the element. Allowable values are:
top
Draw a line before the element
bottom
Draw a line after the element
topbot
Draw a line both before and after the element
all
Draw a box around the element
sides
Draw a line at each side of the element
none
Don't draw any lines around this element
DITA processing for XHTML output supports only top, bottom, and topbot rules. 		(top | bottom | topbot | all | sides | none) #IMPLIED boolean: no
expanse Determines the horizontal placement of the element.

For PDF, allowable values are: "page" places the element on the left page margin; "column" aligns the element with the current column margin; "textline" aligns the element with the left margin of the current text line and takes indention into account.

For XHTML, allowable values are textline only. The table surrounds the table data. Column and page set the table width to 100%.

 (page|column|textline) #IMPLIED boolean: no

Example

The %display-atts; parameter entity is used within the DITA dtds as a common definition for attributes that affect presentation of certain elements. Not all of these capabilities have been provided yet for DITA topic processing. A typical example might be:

<codeblock scale="90" frame="topbot" expanse="page">
/* a long sample program */
Do forever
  Say "Hello, World"
End
</codeblock>


%global-atts;

Debugging attributes, normally hidden from authoring view.

External-best practice for implementation: These attributes are intended to store debugging information during intermediate processing, to relate error results to source locations for authors. The suggested best practice for implementation is to use xtrf (xml-trace-filename) to store the original source filename through intermediate processing steps, and use xtrc ( xml-trace-counter) to store an element counter for repositioning authoring tools at the originating error location.

Contained by

[unknown for this context]

Contains

Declarations for processing attributes that are globally available on all DITA elements.

Attributes

Name | Description | Data Type | Default Value | Required?
xtrf | xml-trace-filename, the original filename | CDATA | #IMPLIED | state: reqval=NA
xtrc | xml-trace-counter, an element counter for repositioning editors at a known edit location | CDATA | #IMPLIED | boolean: no

Example

These attributes are normally hidden from authors and exposed only to processing tools or editor macros. Values used in these attributes may be implementation-dependent.


%id-atts;

ID attributes (%id-atts;) is a parameter entity declaration in the topic DTD that includes attributes that enable the naming and referencing of elements in a DITA topic: id and conref .

Contained by

Used in the topic DTD.

Contains

Declarations for attributes.

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
conref This attribute is used to reference an ID on content that can be reused. For example, you could create a <note> in a topic and then reference its ID (using conref) from a <note> in another topic. During output processing, a lookup process will pull the contents of the first note into the note that has the conref attribute.

The conref value follows the same conventions as HTML for what HTML calls a "fragment identifier"—a required "#" separator separates an optional filename from the fully qualified id (in the form topicid/elementid). To refer to target content in a different file, put the full URL of that topic before the # character.

Local target: conref="#topicid/elementid"
Different file: conref="filename.xml#topicid"
In different file: conref="filename.xml#topicid/elementid"
 CDATA #IMPLIED boolean: no

Example

The %id-atts; parameter entity is used within the DITA dtds as a common definition for attributes available to most elements that enable you to name or reference (link to or fetch) the content of particular elements. Not all of these capabilities have been provided yet for DITA topic processing. Some typical examples include:

<p id="mainpara">The war cry of Kudzu University, <q id="warcry">To the victor
go the spoils!</q>, is often heard on campus during freshman orientation.</p>
<p id="dullpara">One often hears the cry, <q conref="#topicid/warcry"/>, when
students are competing in intramural sports.</p>


%rel-atts;

Relational attributes (<%rel-atts;>) is a parameter entity declaration in the topic DTD that includes attributes whose values may be used for representing navigational relationships. These attributes occur only on elements that represent relationships between topics.

Contained by

[unknown for this context]

Contains

Declarations for attributes

Attributes

Name | Description | Data Type | Default Value | Required?
type Describes the target of a cross-reference and may generate cross-reference text based on that description.

Allowed values are:

fig
Indicates a link to a figure.
table
Indicates a link to a table.
li
Indicates a link to an ordered list item.
fn
Indicates a link to a footnote.
section
"section" indicates a link to a section.
concept, task, reference, topic
Cross-reference to a topic type.
other
Indicates a cross-reference to an alternate topic information type (currently unsupported).

Note: Valid types for <link> include topic, concept, task, and reference. Valid types for <xref> also include fig, figgroup, table, li, fn, and section.

Note: The values external and local are deprecated for this attribute, and will be removed in later versions of the DTDs. Use the scope attribute instead to specify these linking semantics.

 CDATA #IMPLIED (Processed as if the target were of type "topic.") boolean: no
role The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time.

Allowable values are:

parent
Indicates a link to a topic that is a parent of the current topic.
child
Indicates a link to a direct child such as a directly nested or dependent topic.
sibling
Iindicates a link between two children of the same parent topic.
friend
Indicates a link to a similar topic that is not necessarily part of the same hierarchy.
next
Indicates a link to the next topic in a sequence.
previous
Indicates a link to the previous topic in a sequence.
cousin
Indicates a link to another topic in the same hierarchy that is not a parent, child, sibling, next, or previous.
ancestor
Indicates a link to a topic above the parent topic.
descendent
Indicates a link to a topic below a child topic.
sample
Deprecated.
external
Deprecated--use the scope="external" attribute to indicate external links..
other
Indicates any other kind of relationship or role. Enter that role as the value for the otherrole attribute.
 (parent | child | sibling | friend | next | previous | cousin | ancestor | descendant | sample | external | [deprecated] other) "friend" boolean: no
otherrole | Indicates an alternate role. This value is used when the role attribute is set to other. | CDATA | #IMPLIED | boolean: no

Example

The %rel-atts; parameter entity is used within the DITA dtds as a common definition for attributes available to elements that represent topic-to-topic relationships. Not all of these capabilities have been provided yet for DITA topic processing. Some typical examples include:

<link type="task" role="child" href="how2uninst.xml" scope="local"/>


%select-atts;

Attributes that support both filtering and flagging include platform , product , audience , and otherprops . Attribute rev only lets you flag information that matches a run-time parameter. Attribute importance currently provides output effects only for steps (where only the values "optional" and "required" are supported).

Contained by

Used in the topic DTD.

Contains

Declarations for attributes.

Attributes

Name | Description | Data Type | Default Value | Required?
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. | CDATA | #IMPLIED | boolean: no
product | Contains the name of the product to which the topic applies. This is a property attribute which supports conditional processing for filtering or flagging. | CDATA | #IMPLIED | boolean: no
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. | CDATA | #IMPLIED | boolean: no
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. | CDATA | #IMPLIED | boolean: no
importance | A range of values that describe an importance or priority attributed to an element. For example, in steps of a task, the attribute indicates whether a step is optional or required. In other contexts or specializations, other values are possible. This is a property attribute which supports conditional processing for filtering or flagging. Allowable values are: obsolete, deprecated, optional, default, low, normal, high, recommended, required, urgent. | obsolete | deprecated | optional | default | low | normal | high | recommended | required | urgent | #IMPLIED | boolean: no
rev | Indicates revision level of an element. It is useful for flagging outputs based on revision. This is a property attribute which supports conditional processing for filtering or flagging. | CDATA | #IMPLIED | boolean: no
status | The status of the current element. This is a property attribute which supports conditional processing for filtering or flagging. Allowable values are: new changed deleted unchanged | CDATA | #IMPLIED | boolean: no

Example

The %select-atts; parameter entity is used within the DITA dtds as a common definition for attributes available to most elements for you to enable the content for improved retrieveability or for selection. Not all of these capabilities have been provided yet for DITA topic processing. Some typical examples include:

The <keyword platform="Linux">chmod</keyword> command...
<ph product="Whiteknuckle Handsoap">Amalgamated Cleansers get the grime!</ph>
<msgph audience="programmer">Divide by -1 error.</msgph>
<ph otherprops="java">When using Java, use the
  <apiname>com.ibm.obscureclass</apiname> to calculate the value.</ph>
<p importance="recommended" rev="3.2">Update anti-virus software often.</p>


%univ-atts;

Universal attributes is a parameter entity declaration in the topic DTD that includes:

  • the attributes in the select-atts parameter entity ( platform , product , audience , otherprops , importance , rev , status )
  • the attributes in the id-atts parameter entity ( id , conref )
  • two additional attributes: translate and xml:lang .

Contained by

Used in the topic DTD.

Contains

Declarations for attributes.

Attributes

Name | Description | Data Type | Default Value | Required?
%select-atts; | A set of related attributes, described at select-atts: platform , product , audience , otherprops , importance , rev , status . |  |  |
%id-atts; | A set of related attributes, described at id-atts: id , conref . |  |  |
translate | Indicates whether the content of the element should be translated or not. | yes | no | #IMPLIED | boolean: no
xml:lang | Specifies the language of the element content. When no xml:lang value is supplied, the default value of English is assumed. For example, if there is a note element with the attribute xml:lang set to the value "es-es," then the label on the note, which is normally output as "Note" is now output in Spanish as "Nota." A list of supported values is given in xml:lang values. | NMTOKEN | #IMPLIED | boolean: no

Example

See examples for the select-atts and id-atts parameter entries. The translate and xml:lang attributes identify language-specific words or phrases for specific processing (or non-processing, in the case of translate="no").
<p>The cordial response to the question is
<q translate="no" xml:lang="de-de">nein.</q></p>


Map elements

A map describes the relationships among a set of DITA topics. The following are some examples of relationships that can be described in a map:

  • Hierarchical (Parent/Child). Nested topics create a hierarchical relationship. The topic that does the nesting is the parent, and the topics that are nested are the children.
  • Ordered. Child topics can be labeled as having an ordered relationship, which means they are referenced in a definite sequence.
  • Family. Child topics can be labeled as having a family relationship, which means they all refer to each other.

The relationships defined in a map can be used to create a Table of Contents (TOC), aggregate topics into a PDF document, or to create links between topics in output.


map

The <map> element is used to define a map which describes the relationships among a set of DITA topics. Maps consist of references to topics organized into hierarchies and tables. Maps provide a way to express these relationships in a single common format that can be used for different outputs.

The containing element for a map is the <map> element, which can take title and id attributes. Within the map, use the <topicref> element to add and organize references to the topics. You can use the map element to set default attribute values for all topicrefs in the map.

While the Title attribute on a map is optional, the Title attribute is required by the Eclipse help system. The primary XML table of contents must have a title (label in Eclipse), in order for that help's table of contents to load.

Contained by

[unknown for this context]

Contains

( topicmeta ) (optional) then ( navref or anchor or topicref or reltable ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
title | An identifying title for this element. | CDATA | #IMPLIED | boolean: no
id | This attribute is only used for debugging purposes to tell where generated links came from. | ID | #IMPLIED | boolean: no
anchorref | Identifies a location within another map file where this map will be anchored (referenced). For example, "anchorref=map1.ditamap/a1" causes this map to be referenced from within the map1.ditamap file at anchor point a1. | CDATA | #IMPLIED | boolean: no
%topicref-atts; (collection-type, type, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See %topicref-atts;. | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
DTDVersion | Designates the version of the DTD that is in use. | CDATA | "V1.1.0" (version dependent; will increase) | boolean: yes
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, there are six topicrefs. They are nested and have a hierarchical relationship. Bats.xml is the parent topic and the other topics are its children.
<map title="Bats" id="mybats"> Bats
 <topicref href="bats.xml" type="topic"
  <topicref href="batcaring.xml" type="task"></topicref>
  <topicref href="batfeeding.xml" type="task"></topicref>
  <topicref href="batsonar.xml" type="concept"></topicref>
  <topicref href="batguano.xml" type="reference"></topicref>
  <topicref href="bathistory.xml" type="reference"></topicref>
 </topicref>
</map>


anchor

The <anchor> element is used for runtime integration of navigation. It provides an integration point that another map can point to in order to insert its navigation into the current navigation tree. It is currently supported by Eclipse output only.

Contained by

map , topicref , topichead , topicgroup

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, an anchor is defined with an ID of "a1". This ID can be referenced by the anchorref attribute on another map's map element.
<map title="MyComponent tasks">
<topicref navtitle="Start here" href="" toc="yes"> Start here
<navref mapref="othermap2.ditamap"/>
<navref mapref="othermap3.ditamap"/>
<anchor id="a1"/>
</topicref>
</map>


navref

The <navref> element references a map file from within a map file. The reference is resolved at runtime for Eclipse navigation, typically to pull together the navigation for multiple components into a product navigation. This element is for runtime resolution of references, and is for navigation only. It is currently only supported by Eclipse output.

Contained by

map , topicref , topichead , topicgroup

Contains

no content

Attributes

Name | Description | Data Type | Default Value | Required?
mapref | Specifies the URL (local filename, at least) of the map file to reference. This element is for runtime resolution of references, and is for navigation only. It is currently only supported by Eclipse output. | CDATA | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, the map titled "MyComponent tasks" references the maps "othermap2.ditamap" and "othermap3.ditamap".
<map title="MyComponent tasks">
<topicref navtitle="Start here" href="" toc="yes"> Start here
<navref mapref="../com.ibm.xml.doc/othermap1.ditamap"/>
<navref mapref="../com.ibm.xml.doc/othermap2.ditamap"/>
</topicref>
</map>


reltable

The relationship table (<reltable>) defines relationships between topics, based on the familiar table model of rows (<relrow>), columns (<relheader>), and cells (<relcell>). The <relcell> elements can contain <topicref> elements, which are then related to other <topicref> elements in the same row (although not necessarily in the same cell). By default, the contents of a <reltable> element are not output for navigation or TOC purposes, and are used only to define relationships that can be expressed as topic-to-topic links.

Contained by

map

Contains

( topicmeta ) (optional) then ( relheader ) (optional) then ( relrow ) (one or more)

Attributes

Name | Description | Data Type | Default Value | Required?
title | An identifying title for this element. | CDATA | #IMPLIED | boolean: no
%topicref-atts-no-toc; (collection-type, type, locktitle, format, linking, print, search, chunk) | A related set of attributes. See %topicref-atts-no-toc;. | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, a relationship table is defined with three columns; one for "concept", one for "task", and one for "reference". Three cells are defined within one row. The first cell contains one concept topic: batsonar.xml. The second cell contains two task topics: batcaring.xml and batfeeding.xml. The third cell contains two reference topics: batguano.xml and bathistory.xml.
<map>
 <reltable>
  <relheader>
   <relcolspec type="concept">
   <relcolspec type="task">
   <relcolspec type="reference">
  </relheader>
  <relrow>
   <relcell><topicref href="batsonar.xml"/></relcell>
   <relcell><topicref href="batcaring.xml"/><topicref
   href="batfeeding.xml"/></relcell>
   <relcell><topicref href="batguano.xml"/><topicref
   href="bathistory.xml"/></relcell>
  </relrow>
 </reltable>
</map>


relrow

A <relrow> is a row in the relationship table. This creates a relationship between the cells in the row, which will end up expressed as links among the <topicref> elements in the cells.

Contained by

reltable

Contains

relcell

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, a relationship table is defined with three columns; one for "concept", one for "task", and one for "reference". Three cells are defined within one row. The first cell contains one concept topic: batsonar.xml. The second cell contains two task topics: batcaring.xml and batfeeding.xml. The third cell contains two reference topics: batguano.xml and bathistory.xml.
<map>
 <reltable>
  <relheader>
   <relcolspec type="concept">
   <relcolspec type="task">
   <relcolspec type="reference">
  </relheader>
  <relrow>
   <relcell><topicref href="batsonar.xml"/></relcell>
   <relcell><topicref href="batcaring.xml"/><topicref
   href="batfeeding.xml"/></relcell>
   <relcell><topicref href="batguano.xml"/><topicref
   href="bathistory.xml"/></relcell>
  </relrow>
 </reltable>
</map>


relcell

A <relcell> element is a cell in the relationship table. The <topicref> elements it contains will be related to topicrefs in other cells of the same row. By default, topicrefs in the same cell are not related to each other, unless you change the relcell's collection-type attribute to indicate that they are related.

Contained by

relrow

Contains

( topicref ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
%topicref-atts; (collection-type, type, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See %topicref-atts;. | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, a relationship table is defined with three columns; one for "concept", one for "task", and one for "reference". Three cells are defined within one row. The first cell contains one concept topic: batsonar.xml. The second cell contains two task topics: batcaring.xml and batfeeding.xml. The third cell contains two reference topics: batguano.xml and bathistory.xml.
<map>
 <reltable>
  <relheader>
   <relcolspec type="concept">
   <relcolspec type="task">
   <relcolspec type="reference">
  </relheader>
  <relrow>
   <relcell><topicref href="batsonar.xml"/></relcell>
   <relcell><topicref href="batcaring.xml"/><topicref
   href="batfeeding.xml"/></relcell>
   <relcell><topicref href="batguano.xml"/><topicref
   href="bathistory.xml"/></relcell>
  </relrow>
 </reltable>
</map>


relheader

The <relheader> element is a row of column definitions (<relcolspec> elements) in a relationship table. Each table can have only one set of column definitions.

Contained by

reltable

Contains

relcolspec

Attributes

Name | Description | Data Type | Default Value | Required?
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, a relationship table is defined with three columns; one for "concept", one for "task", and one for "reference". Three cells are defined within one row. The first cell contains one concept topic: batsonar.xml. The second cell contains two task topics: batcaring.xml and batfeeding.xml. The third cell contains two reference topics: batguano.xml and bathistory.xml.
<map>
 <reltable>
  <relheader>
   <relcolspec type="concept">
   <relcolspec type="task">
   <relcolspec type="reference">
  </relheader>
  <relrow>
   <relcell><topicref href="batsonar.xml"/></relcell>
   <relcell><topicref href="batcaring.xml"/><topicref
   href="batfeeding.xml"/></relcell>
   <relcell><topicref href="batguano.xml"/><topicref
   href="bathistory.xml"/></relcell>
  </relrow>
 </reltable>
</map>


relcolspec

A column definition in the relationship table. You can use <relcolspec> column definitions to set defaults for the attributes of <topicref> elements in the column. For example, you can set type="concept" to treat all untyped <topicref> elements in the column as concepts.

Contained by

relheader

Contains

topicmeta

Attributes

Name | Description | Data Type | Default Value | Required?
%topicref-atts; (collection-type, type, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See %topicref-atts;. | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, a relationship table is defined with three columns; one for "concept", one for "task", and one for "reference". Three cells are defined within one row. The first cell contains one concept topic: batsonar.xml. The second cell contains two task topics: batcaring.xml and batfeeding.xml. The third cell contains two reference topics: batguano.xml and bathistory.xml.
<map>
 <reltable>
  <relheader>
   <relcolspec type="concept">
   <relcolspec type="task">
   <relcolspec type="reference">
  </relheader>
  <relrow>
   <relcell><topicref href="batsonar.xml"/></relcell>
   <relcell><topicref href="batcaring.xml"/><topicref
   href="batfeeding.xml"/></relcell>
   <relcell><topicref href="batguano.xml"/><topicref
   href="bathistory.xml"/></relcell>
  </relrow>
 </reltable>
</map>


topicmeta

The <topicmeta> element defines the metadata that applies to a topic and the topic's children. When creating links, it can also be used to override the title and short description of the topic. In addition, it can insert index entries through the <keywords> element..

Contained by

map , topicref , reltable , relcolspec , topichead , topicgroup

Contains

( linktext ) (optional) then ( searchtitle ) (optional) then ( shortdesc ) (optional) then ( author ) (0 or more) then ( source ) (optional) then ( publisher ) (optional) then ( copyright ) (0 or more) then ( critdates ) (optional) then ( permissions ) (optional) then ( audience ) (0 or more) then ( category ) (0 or more) then ( keywords ) (0 or more) then ( prodinfo ) (0 or more) then ( othermeta ) (0 or more) then ( resourceid ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
lockmeta | Currently unsupported. Defaults to "yes". | (yes | no) | #IMPLIED | boolean: no
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, the metadata defined by the metadata element applies to the associated <topicref> (bats.xml) and all of its children. The <topicmeta> element contains an audience definition which indicates that bats.xml and its children are of interest to experienced programmers who are troubleshooting.
<map>
 <topicref href="bats.xml">
  <topicmeta>
   <audience type="programmer" job="troubleshooting" experiencelevel="expert"/>
  </topicmeta>
  <topicref href="batcaring.xml"></topicref>
  <topicref href="batfeeding.xml"></topciref>
 </topicref>
</map>


topicref

The <topicref> element designates a topic (such as a concept, task, or reference) as a link in a DITA map. A <topicref> can contain other<topicref> elements, allowing you to express navigation or table-of-contents hierarchies, as well as implying relationships between the containing <topicref> and its children. You can set the collection-type of a container <topicref> to determine how its children are related to each other. Relationships end up expressed as links in the output (with each participant in a relationship having links to the other participants).

You can fine tune the output from your map by setting different attributes on topicrefs: for example, the linking attribute controls how its relationships to other topicrefs are expressed as links, and the toc attribute controls whether the topicref shows up in TOC or navigation output.

Contained by

map , topicref , relcell , topichead , topicgroup

Contains

( topicmeta ) (optional) then ( topicref or navref or anchor ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of a container in a toc. | CDATA | #IMPLIED | boolean: no
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
href A hyperlink to an external Web page (URL) or to another topic in the same file or in another file. The href attribute identifies the destination of the cross-reference link using conventional URL syntax:
href="http://www.xxx.com" format="html"
href="myfile.xml" type="concept"
   (or task, reference, or topic)
href="myfile.xml#topicid/figid" type="fig"
   (or table, fn, or section)
href="mything.pdf" format="pdf"

If the URL contains an ampersand character, the ampersand symbol (&amp;) should be used to indicate that character

 CDATA #IMPLIED boolean: no
keyref | Currently not implemented in DITA processors. Provides a key that a process can use to look up associated information. | NMTOKEN | #IMPLIED | boolean: no
query | Lists query criteria for topicref, or uses topicref's metadata as query criteria. The query pulls in matching topics under the current one if the title is present, or replaces the current location if title is not present. | CDATA | #IMPLIED | boolean: no
conref | [TO BE DEVELOPED--description for conref to a topicref] | CDATA | #IMPLIED | boolean: no
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Note: The copied files will appear in search results as near-duplicates of the original, with only their related links serving to differentiate them.

 CDATA #IMPLIED boolean: no
%topicref-atts; (collection-type, type, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See %topicref-atts;. | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

In this example, there are six topicrefs. They are nested and have a hierarchical relationship. Bats.xml is the parent topic and the other topics are its children.
<map title="Bats" Bats
 <topicref href="bats.xml" type="topic">
  <topicref href="batcaring.xml" type="task"></topicref>
  <topicref href="batfeeding.xml" type="task"></topicref>
  <topicref href="batsonar.xml" type="concept"></topicref>
  <topicref href="batguano.xml" type="reference"></topicref>
  <topicref href="bathistory.xml" type="reference"></topicref>
 </topicref>
</map>


topicgroup

The <topicgroup> element is for creating groups of <topicref> elements without affecting the hierarchy, as opposed to nested <topicref> elements within a <topicref>, which does imply a structural hierarchy. It is typically used outside a hierarchy to identify groups for linking without affecting the resulting toc/navigation output.

Contained by

Contains

( topicmeta ) (optional) then ( topicref or navref or anchor ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
conref This attribute is used to reference an ID on content that can be reused. For example, you could create a <note> in a topic and then reference its ID (using conref) from a <note> in another topic. During output processing, a lookup process will pull the contents of the first note into the note that has the conref attribute.

The conref value follows the same conventions as HTML for what HTML calls a "fragment identifier"—a required "#" separator separates an optional filename from the fully qualified id (in the form topicid/elementid). To refer to target content in a different file, put the full URL of that topic before the # character.

Local target: conref="#topicid/elementid"
Different file: conref="filename.xml#topicid"
In different file: conref="filename.xml#topicid/elementid"
 CDATA #IMPLIED boolean: no
%topicref-atts; (collection-type, type, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See %topicref-atts;. | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The following markup, for HTML Help output, will produce ....
<map title="DITA Reference">
 <topicref href="anchor.xml" type="topic"></topicref>
 <topicref href="apiname.xml" type="topic"></topicref>
 <topicref href="audience.xml" type="topic"></topicref>
 <topicref href="author.xml" type="topic"></topicref>
 <topicgroup  collection-type="family" toc="no">
  <topicref href="global-atts.xml" type="topic"></topicref>
  <topicref href="select-atts.xml" type="topic"></topicref>
  <topicref href="univ-atts.xml" type="topic"></topicref>
  <topicref href="topicref-atts.xml" type="topic"></topicref>
 </topicgroup>
</map>


topichead

The <topichead> element provides a title-only entry in a navigation map, as an alternative to the fully-linked title provided by the <topicref> element.

Contained by

Contains

( topicmeta ) (optional) then ( topicref or navref or anchor ) (0 or more)

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of a container in a toc. | CDATA | #IMPLIED | boolean: no
id | An anchor point. This ID is the target for references by link, xref, and conref, and for external applications that refer to DITA content.. | ID | #IMPLIED | boolean: no
conref This attribute is used to reference an ID on content that can be reused. For example, you could create a <note> in a topic and then reference its ID (using conref) from a <note> in another topic. During output processing, a lookup process will pull the contents of the first note into the note that has the conref attribute.

The conref value follows the same conventions as HTML for what HTML calls a "fragment identifier"—a required "#" separator separates an optional filename from the fully qualified id (in the form topicid/elementid). To refer to target content in a different file, put the full URL of that topic before the # character.

Local target: conref="#topicid/elementid"
Different file: conref="filename.xml#topicid"
In different file: conref="filename.xml#topicid/elementid"
 CDATA #IMPLIED boolean: no
%topicref-atts; (collection-type, type, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See %topicref-atts;. | parameter entity | PE not applicable | state: reqval=NA
%select-atts; (platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described at %select-atts; | parameter entity | PE not applicable | state: reqval=NA
%global-atts; (xtrf, xtrc) | A set of related attributes, described at %global-atts; | parameter entity | PE not applicable | state: reqval=NA
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values help the output transforms work correctly with ranges of related content. | CDATA | #IMPLIED | boolean: no

Example

The following markup, for HTML Help output, will produce a book icon that expands into a nested set when toggled.
<map title="DITA Reference">
 <topicref href="anchor.xml" type="topic"></topicref>
 <topicref href="apiname.xml" type="topic"></topicref>
 <topicref href="audience.xml" type="topic"></topicref>
 <topicref href="author.xml" type="topic"></topicref>
 <topichead navtitle="Parameter Entity elements">
  <topicref href="global-atts.xml" type="topic"></topicref>
  <topicref href="select-atts.xml" type="topic"></topicref>
  <topicref href="univ-atts.xml" type="topic"></topicref>
  <topicref href="topicref-atts.xml" type="topic"></topicref>
 </topichead>
</map>


%topicref-atts;

The %topicref-atts; parameter entity represents a group of attributes used in numerous map elements: map, topicref, relcolspec, relcell, topichead, and topicgroup. The set is similar to those documented in topicref-atts-no-toc but includes the toc attribute.

Contained by

Used in the map DTD.

Contains

Declarations for attributes.

Attributes

Name | Description | Data Type | Default Value | Required?
collection-type | Collection types describe how links relate to each other. A family represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other. Allowed values are: unordered sequence choice family. Should you see the value "tree" in a pulldown list, it is not supported. | (unordered|sequence|choice|family) | "unordered" | boolean: no
type Describes the target of a cross-reference and may generate cross-reference text based on that description.

Allowed values are:

fig
Indicates a link to a figure.
table
Indicates a link to a table.
li
Indicates a link to an ordered list item.
fn
Indicates a link to a footnote.
section
"section" indicates a link to a section.
concept, task, reference, topic
Cross-reference to a topic type.
other
Indicates a cross-reference to an alternate topic information type (currently unsupported).

Note: Valid types for <link> include topic, concept, task, and reference. Valid types for <xref> also include fig, figgroup, table, li, fn, and section.

Note: The values external and local are deprecated for this attribute, and will be removed in later versions of the DTDs. Use the scope attribute instead to specify these linking semantics.

 CDATA #IMPLIED (Processed as if the target were of type "topic.") boolean: no
locktitle This attribute makes sure the navtitle attribute is used if it is present; if locktitle isn't set to "yes", the navtitle attribute is ignored and text is retrieved from the target
yes
The navtitle in the map is used.
no
Default. The navtitle or title of the topic is used.
 (yes | no) #IMPLIED boolean: no
format The format attribute identifies the format of the resource being cross referenced. The default format is dita.

Allowable values are:

dita
The format of the linked-to resource is native DITA. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
(no value)
Defaults to "dita"
(for anything else)
Use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value)
 CDATA #IMPLIED boolean: no
linking Defines some specific linking characteristics of a topic.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
 (targetonly | sourceonly | normal | none) #IMPLIED boolean: no
toc | Specifies whether a topic appears in the table of contents (toc). This value is set to no. | boolean: no
print Specifies whether the topic should be included in a portable document format (PDF) file.
yes
Include the topic in a PDF file.
no
Do not include the topic in a PDF file.
 (yes | no) #IMPLIED boolean: no
search Currently not used.
yes
no
 (yes | no) #IMPLIED boolean: no
chunk | Currently not used. | CDATA | #IMPLIED | boolean: no

Example

Attributes in this group are used in numerous map elements except for reltable, which omits the toc attribute.


%topicref-atts-no-toc;

The %topicref-atts-no-toc; parameter entity represents the set of attributes used in the reltable map element. The set is similar to those documented in topicref-atts but for <reltable> the toc attribute defaults to "no". For the other elements that use the %topicref-atts; group declaration, the toc attribute doesn't have a default; they can inherit their toc value from the nearest container, otherwise it functions upon output as if set to "yes".

Contained by

Used in the map DTD.

Contains

Declarations for attributes.

Attributes

Name | Description | Data Type | Default Value | Required?
collection-type | Collection types describe how links relate to each other. A family represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other. Allowed values are: unordered sequence choice family. Should you see the value "tree" in a pulldown list, it is not supported. | (unordered|sequence|choice|family) | "unordered" | boolean: no
type Describes the target of a cross-reference and may generate cross-reference text based on that description.

Allowed values are:

fig
Indicates a link to a figure.
table
Indicates a link to a table.
li
Indicates a link to an ordered list item.
fn
Indicates a link to a footnote.
section
"section" indicates a link to a section.
concept, task, reference, topic
Cross-reference to a topic type.
other
Indicates a cross-reference to an alternate topic information type (currently unsupported).

Note: Valid types for <link> include topic, concept, task, and reference. Valid types for <xref> also include fig, figgroup, table, li, fn, and section.

Note: The values external and local are deprecated for this attribute, and will be removed in later versions of the DTDs. Use the scope attribute instead to specify these linking semantics.

 CDATA #IMPLIED (Processed as if the target were of type "topic.") boolean: no
locktitle This attribute makes sure the navtitle attribute is used if it is present; if locktitle isn't set to "yes", the navtitle attribute is ignored and text is retrieved from the target
yes
The navtitle in the map is used.
no
Default. The navtitle or title of the topic is used.
 (yes | no) #IMPLIED boolean: no
format The format attribute identifies the format of the resource being cross referenced. The default format is dita.

Allowable values are:

dita
The format of the linked-to resource is native DITA. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
(no value)
Defaults to "dita"
(for anything else)
Use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value)
 CDATA #IMPLIED boolean: no
linking Defines some specific linking characteristics of a topic.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
 (targetonly | sourceonly | normal | none) #IMPLIED boolean: no
print Specifies whether the topic should be included in a portable document format (PDF) file.
yes
Include the topic in a PDF file.
no
Do not include the topic in a PDF file.
 (yes | no) #IMPLIED boolean: no
search Currently not used.
yes
no
 (yes | no) #IMPLIED boolean: no
chunk | Currently not used. | CDATA | #IMPLIED | boolean: no

Example

Attributes in this grouping are used only in the reltable map element.


xml:lang values

The allowed xml:lang values are based on ISO-3166 Country Codes and RFC 3066 Language Codes (see W3C: Language tagging in HTML and XML).

xml:lang values

Value | Language | Value | Language
ar-eg | Arabic | nl-be | Belgian Dutch
fr-be | Belgian French | pt-br | Brazilian Portuguese
bg-bg | Bulgarian | ca-es | Catalan
en-ca | Canadian English | fr-ca | Canadian French
hr-hr | Croatian | cs-cz | Czech
da-dk | Danish | nl-nl | Dutch
en-us | US English | et-ee | Estonian
fi-fi | Finnish | fr-fr | French
de-de | German | el-gr | Greek
he-il | Hebrew | hu-hu | Hungarian
is-is | Icelandic | it-it | Italian
ja-jp | Japanese | ko-lr | Korean
lv-lv | Latvian | lt-lt | Lithuanian
mk-mk | Macedonian | no-no | Norwegian
pl-pl | Polish | pt-pt | Portuguese
ro-ro | Romanian | ru-ru | Russian
zh-cn | Simplified Chinese | sr-sp | Serbian
fr-ch | Swiss French | de-ch | Swiss German
it-ch | Swiss Italian | sk-sk | Slovak
sl-si | Slovenian | es-es | Spanish
sv-se | Swedish | zh-tw | Traditional Chinese
th-th | Thai | tr-tr | Turkish
en-gb | UK English |  |


outputclass processing

During transformation from XML to HTML, the value of outputclass is output instead of the class name ordinarily generated for the element. This new class can then be used by a CSS stylesheet to apply alternate formatting rules to the output HTML document.

For example, if a paragraph element is normally rendered in regular font but a bold paragraph is required, you could put boldpara as a value for the outputclass attribute, and then write a CSS stylesheet that applies bold formatting to result elements that will have that class value (for example, .boldpara {font-weight: bold; display: block;}). The paragraph is then displayed as bold when you view the HTML output using your CSS in a web browser.


keyref processing

Design note:

The intent of keyref is to provide indirection to linking information as an alternative to using href for hardcoded paths directly in your content. When you use keyref, you allow different processes to form the linking relationship in different ways: for example, a reviewing process might look up internal address and phone number information for the author, while a publishing process might look up a company address and feedback email address.

This functionality is not yet supported in DITA processing.


Colophon

This document was composed by IBM's dita13 toolkit, an externally available set of DTDs, transforms, and documentation for demonstrating DITA publishing capabilities. It consists of a DITA bookmap structure that supports book production structures, such as front matter and back matter. This map-based shell uses <topicref> elements to reference a hierarchy of DITA topics as the main content of the book.

The initial content and linking for the individual DITA Language Reference topics was done by running a DTD-parsing tool on the current DITA DTDs, which parsed the content model relationships and attribute information as links among topics. The attribute descriptions were all mapped by use of the conref attribute to a single topic, commonLRdefs.xml, that provides maintenance for the descriptions of ALL of DITA's attributes in a single location. Hence, common repeating structures such as the attribute definition for "href" are all the result of reuse by reference from a single definition. The content of the Purpose and Examples sections of each topic was then individually written and reviewed. In effect, the DTDs constructed everything but the descriptive information in each reference topic.

Note: For the dita13 package, some new and proposed elements have been included. The documentation for this new markup remains to be integrated into the full document. For now, the available new descriptions have been incorporated into the current bookmap, but any linking is hand authored in these.

The DTD used for these element reference topics is the base reference.dtd . The topics were reprocessed (by generalization) from their original elementref doctype to the reference doctype, and the purpose sections were modified to move the key descriptions into <shortdesc> markup as an example of a Best Practice for similar user assistance.

These 200 or so reference topics were then assembled into a structured hierarchy to represent the body of this document, using a specialized DITA map (see the demo/book directory for the dtds and notes). A concept topic was written to introduce each major category. Each category becomes a chapter when the book is output to PDF using the dita13 bookmap production tools. A different conventional map (not a bookmap) represents the alphabetized sequence that was used to generate an HTML Help online version of this documentation.

The ant tool (from http://jakarta.apache.org) was used to run the build.xml processing script to produce the PDF and compiled help outputs.